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Chapter

1
Welcome

This chapter introduces you to this guide, offers some tips on how to use it effec-
tively, and helps you set up your Profit Builder control information.

This guide is intended for the daily operations user. It offers step-by-step instructions 
for many of Profit Builder®’s daily activities. It is not intended to guide set up or 
implementation activities.

How to Use this Manual
This guide should be used as a reference for learning the day-to-day operations of 
Profit Builder®. Each chapter is organized with headings to help you better navigate 
the topics.

There are tools used in this guide to help draw your attention to certain information. 

Throughout the guide you will see references to other topics. These references typi-
cally include a heading and page number. If you are viewing this guide electronically, 
you can click the reference to be taken automatically to that spot in the guide.

You can also use the table of contents at the beginning of this guide and the index at 
the end to locate the information your are looking for.

Profit Builder Editions
There are four different editions of Profit Builder. Depending on the edition you have 
purchased, the features that are available to you may be different than other editions. 
Throughout this guide you will see icons on the left side of the page to indicate a fea-
ture that is available in a specific edition. Features that do not have an icon are avail-
able in all editions.

You will notice text that appears in shaded boxes, such as this one. This text is 
especially important and should always be read with special attention.
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Project Management Edition – The PM Edition takes project management to a new 
level of ease and precision. Tight cost control is achieved by tying Purchasing with 
cPM Scheduling and automating payment approval from the field. The system gives 
Superintendents more control while keeping the process simple and exact.

CFO Edition – The CFO Edition is designed to make life easier for the corporate 
CFO.  From multi-company journal entries to audit tools, the CFO Edition is every 
controller's dream.

Big Builder Edition – The Big Builder Edition gives ease of use and flexibility to 
Builders with the need for a concise purchasing system.  It is available with MS Access 
or SQL as its database and is custom designed in three different levels—custom, semi-
custom, and production-style builders.  

Small, mid-sized and large builders will find a perfect fit for performance require-
ments and total cost. The Big Builder Edition includes all features with the Big 
Builder icon as well as all those with the CFO and Project Management edition icons.

Commercial Edition – The Commercial Edition is designed specifically with the 
commercial builder in mind. This edition includes certified payroll, retainage track-
ing, job cost budgeting at the class level and the ability to assign general ledger 
accounts to a job cost classes.

In this Guide
You find the following chapters:

Welcome – This chapter outlines the most effective way to utilize this guide 
and introduces you to the Profit Builder system.
Accounts Payable – This chapter outlines how to create a new vendor, 
invoices and issue checks.
General Ledger – This chapter outlines journal entries, creating new 
accounts, closing a period and general ledger reports.
Job Cost – This chapter outlines entering new jobs, setting up budgets, 
updating progress and job reports.
Payroll – This chapter outlines adding new employees, setting up new 
deductions and running payroll.
Accounts Receivables – This chapter outlines adding new customers, 
invoices and accepting invoice payments.
Draw Requests – This chapter outlines adding residential loans, commercial 
contracts and generating payment requests.
Purchasing & Production Building – This chapter outlines developing a 
new plan, starting a new house, scheduling and purchase orders.
Custom Building – This chapter outlines the steps to create custom plans for 
building one-of-a-kind properties.
Appendix – This chapter offers additional tools to help you in your daily 
operations.
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Using Profit Builder
Before you can really begin to use Profit Builder to better manage your business, you 
should first be acquainted with the basics of actually using the program.

Profit Builder is divided into separate modules. The chapters in this book follow these 
divisions. When you first start Profit Builder and log in, you will see the different 
modules along the top portion of the screen.

You can access these modules by clicking the picture and name of each module. This 
will bring up a menu for that module.

From this menu, you can then access the different features within each module by 
clicking the Add/Edit, Process and Reports menus. Click Cancel will close the mod-
ule menu.

You can use hot keys to bring up the menus without using your mouse to click each 
selection. To use the hot keys, you simply type the first letter of the module you want 
to use and the menu will open. Because there are some modules that begin with the 



P R O F I T  B U I L D E R W E L C O M E

O P E R A T I O N S  G U I D E 11

same letters, you should type an “r” for Accounts Receivable and a “u” for Purchasing. 
Once the menu has opened, you can continue to navigate through the selections by 
typing letters to open additional menus. For example, “a” for Add/Edit, “p” for Pro-
cess, “r” for Reports and “c” for Cancel. You can continue to type letters to correspond 
to the different functions of these menus as well.

You can also access the individual modules and menus from the menu bar at the top 
of the Profit Builder window. From this menu bar, you can access some advanced fea-
tures that are not available through the regular module menus.

These additional features include a system supervisor and housekeeping menu. 
Depending on your role and access to the program, you may or may not be able to 
access these features.

This basic orientation should help you to become proficient with navigating the sys-
tem very quickly. It is most important for you to feel comfortable navigating the dif-
ferent modules so that you can efficiently complete the tasks and utilize the program 
to most benefit your business.

Control Information
Your first data entry task is to set up control information for the company in which 
you are working. Control Information stores general information about your com-
pany and how you wish to process accounting information in Profit Builder®. 

This includes your company name and address, federal and state tax numbers and fis-
cal year end information. In addition it stores the current system processing date, 
next check number and payroll processing information. 
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The Control Information function can be accessed from the Add/Edit menu in any 
program module. 

TO ENTER CONTROL INFORMATION:

1. Go to Modules > Accounts Payable > Add/Edit > Control Information.
You can access Control Information from any Add/Edit menu. We use 
Accounts Payable because it is the first listed under Modules.

GENERAL

2. On the General tab, enter your company’s name, address, city, state, zip, e-
mail, phone numbers and web address.

3. In the Processing Date field, select the processing date you want to work from 
in your current session.
This is the date that is used for posting and processing information in Profit 
Builder®. It is not necessarily the same as the current calendar date.

4. In the Federal Tax ID field, enter the tax id number assigned to you for fed-
eral tax purposes.

5. In the Corporate State Tax ID field, enter your company’s state tax id num-
ber.

6. Click the Payables tab.

PAYABLES

7. In the Next Accounts Payable invoice number field, enter the number you 
want your accounts payable invoices to begin at.

8. In the Material cost class field, select a cost class for materials.
9. In the Subcontract cost class field, select a cost class for subcontracted labor.
10. Check the Print Payables checks created in AP Invoice Add/Edit box to add 

checks created from paid invoices into the printing queue.
11. Check the Notify if JC posting exceeds budget box to display a warning 

when invoiced amounts exceed job costing budgets.
12. In the Retainage field, select how you want to track retainage on jobs.

Failure to use the correct processing date may cause inaccuracies in your 
accounting records. When processing information in General Ledger, the 
system prevents you from posting any entries that do not match the current 
accounting month/year selected in Control Information. Once set, the date 
is updated automatically by the program whenever you use the CLOSE 
PERIOD function on the General Ledger Process Menu. 

When processing in other modules such as Accounts Payable, the program 
posts to the general ledger only those items whose month/year match that 
of the current processing date. Items for months following the current 
accounting month are held until they match the current accounting month
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13. In the Track job cost budgets by field, select how you want to track job cost 
budgets.

14. Check the Show units and quantity in invoice lines box to show this infor-
mation for each item on invoices.

15. Click the Receivables tab.

RECEIVABLES

16. Check the Default AR income account box to default the income account on 
accounts receivable invoices to the previously saved account.

17. In the AR Year End Rollover field, select when you want your customer sales 
totals to be rolled over.

18. In the Automatically number invoices field, select how you want auto-num-
bering to number customer invoices.

19. Click the General Ledger tab.

GENERAL LEDGER

20. In the Month fiscal year ends field, enter the number for the month your 
company’s fiscal year ends.
For example, if you fiscal year ends in July, you would enter 7.

21. In the Balance Sheet field, select the account you want Profit Builder® to use 
for your last journal entry when closing a G/L Period.

22. In the Income Statement field, select the account you want Profit Builder® to 
use for your last journal entry when closing a G/L Period.

23. Check the Positive amounts are always debit box to make all positive 
amounts debits and negative amounts credits when entering journal entries.

24. Check the Maximum detailed GL postings to show each amount individu-
ally posted without combining posting to the same account.

25. Check the Use Direct Cost accounts in invoices and PO’s box to charge job 
related costs to direct cost accounts.

26. Click the Payroll tab.

PAYROLL

27. In the Overtime rate field, enter the rate for overtime pay. For example, if 
overtime is paid at time and a half you would enter 1.5.

28. In the Premium rate field, enter the rate for premium pay.
29. In the Labor cost class field, select a cost class for labor.
30. Check the Detail payroll postings box to show the payroll posting for each 

employee rather than consolidating all postings.
31. Check the Enable local tax withholding box to withhold local taxes from 

your employees.
32. Check the Show pay rates on time cards  box to show each employee’s pay 

rate on the time card.
33. Click the Purchase Order tab.



P R O F I T  B U I L D E R W E L C O M E

O P E R A T I O N S  G U I D E 14

PURCHASE ORDER

34. Check the Use revision numbers box to assign a revision number to invoices 
to track changes.

35. Check the Allow quantity overrun on invoice box to allow quantities on 
invoices to overrun what was listed on the corresponding purchase orders.

36. Check the Allow price overrun on invoice box to allow prices on invoices to 
overrun what was listed on the corresponding purchase orders.

37. Check the Update vendor’s price list from Payables box to update vendor 
prices from the prices listed on purchase orders.

38. Check the Issue over budget POs box to allow purchase orders to be issued 
over budget.

39. Check the Default Activity from Job Category code box to assign a default 
activity to line items on purchase orders depending on the job category code.

40. In the PO default form names section, select the default forms for Material 
PO, Subcontract and Quotation form.

41. In the PO Numbering section, check the Force Autonumbering box to auto-
number your purchase orders as they are entered. 

42. In the Numbering Base field, select what you want auto-assigned numbers to 
be based on.

43. If you base your auto-numbering on the system, under System Based Num-
bering and Non-Job Related PO, in the Next PO Number field, enter the 
number you want used for your next purchase order.

44. If you base your auto-numbering on jobs, under Job Based Numbering, 
select if you want the job code to be used as a prefix or suffix in the PO num-
ber.

45. In the Starting Sequence No field, enter the number you want used to begin 
each sequence of purchase orders.

46. Click the System tab.

SYSTEM

47. In the Removable storage data path section, click Browse to change your 
backup location. This drive MUST be a writable drive. If you select a drive 
that is not writable, the system will default back to your program folder. Back-
ups cannot be made to a floppy disk drive. The size of backup information is 
too large to fit on a standard floppy disk.

48. In the Archive data path section, click Browse to change your archive loca-
tion.

49. In the Logo image for report headings section, click Browse to find and 
select an image to appear on your reports.

50. If you have multiple companies, check the Share vendors, customers and 
employees between companies box to use the same vendors, customer and 
employees in all of your companies.

51. Check the Suppress Audit Trails box to hide audit trails.
52. Check the Use Printer Dialog box to select which printer to use and how 

many copies to print when printing.
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53. Check the Order pick lists by code (not name) box to have your pick lists 
sorted by code instead of name.

54. Click the Transfer tab.

TRANSFER

55. In the Check for new information section, select how often you want to 
check for updates from sales and scheduling.
You can click Now at any time to check for updates.

56. In the Inbox field, enter the data path to your inbox or click Browse to find 
and select your inbox.

57. In the Outbox field, enter the data path to your outbox or click Browse to find 
and select your outbox.

58. In the Email section, if you have an e-mail program to integrate with Profit 
Builder®, select the location in the Network path field or enter the URL in the 
Web URL field.
If you do not have an e-mail program, select I don’t have an Email program.

59. In the Scheduling section, if you have purchased a scheduling package to 
integrate with Profit Builder®, select the location in the Network path field or 
enter the URL in the Web URL field.
If you have not purchased a scheduling package, select I don’t have cPM 
Scheduling.

60. When you have finished, click OK.

Once all of your control information has been set you can start entering data into 
Profit Builder®.
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Chapter

2
Accounts Payable

This chapter introduces you to the operations involved with your accounts pay-
ables.

In this chapter, you learn how to complete the following tasks:

Create vendor records
Create invoices
Prepare Checks

Entering Vendor Records
Although vendor records can be entered "on-the-fly" as you enter invoices, it is a 
good habit to enter at least those vendors who are subcontractors separately. 

This is so you don't feel rushed in researching critical information, such as Tax ID# 
and insurance information. It also gives you a head start so you are not distracted 
when you enter invoices.

Rules for Assigning Vendor Codes
Establishing rules for assigning codes to vendors, jobs, and other accounts yields pre-
dictability, prevention of duplication, and logical ranging capability on reports.

If the vendor is Rule Example Code

A person Use the first six 
letters of his/her 
last name.

Bill Shocker SHOCKE

A company Use the first three 
letters of the first 
two words of the 
company name.

Ace Plumbing, 
Inc.

ACEPLU



P R O F I T  B U I L D E R A C C O U N T S  P A Y A B L E

O P E R A T I O N S  G U I D E 17

Using the Vendor Pick List
Before you add a vendor, make sure that the vendor record has not already been 
added. It is easy to search the vendor list by both name and by code.

Go to Accounts Payable > Add/Edit > Vendors and 
click the search button next to the Code field. Click on 
the column heading "Vendor" and the list will be sorted 
by the vendor code.

You may sort on either the Vendor Code or Name by 
clicking the appropriate column heading. The second 
click of the column heading reverses the order of the 
column. By default, the list is sorted by Name.

Using the search and the vendor list makes it much eas-
ier to locate existing vendor records and prevent 
unwanted duplicate entries.

Creating New Vendor Records

TO CREATE A NEW VENDOR RECORD:

1. Go to Accounts Payable > Add/Edit > Vendors to add a subcontractor or 
supplier.

2. In the Code field, enter the vendor code as determined by your established 
coding rules. Note that the Vendor Code is automatically capitalized as you 
enter it. Do not use special characters (& $ % , : * #, etc.) in your vendor codes.

3. On the Remittance Address tab, enter the address information for this sub-
contractor or supplier. The Remittance Address is printed on the payable 
checks.

You can type any letter to jump to that point in the 
vendor list. Typing a letter shows a Find Name field 
in the vendor list. Enter the vendor name you are 
searching for in this field to determine if the vendor 
record has already been created.
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Remember, you don't need to format the phone number as you enter it; Profit 

Builder® does it for you.
4. The Send reports via field refers to the preferred method for sending pur-

chase orders and the Vendor To Do List from Scheduling.
5. The last 4 lines shown on this screen are user defined custom fields.

The System Manager can set these fields up via System Supervisor > User 
Defined Fields > Payables. 

6. Click on the Alternate tab if you wish to enter a second address and contact 
for this vendor. The remittance address is used on checks and 1099s; this 
alternate address is used on purchase orders.
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7. Click on the Payments tab to enter payment defaults that speed up invoice 
entry.

8. In the Payments section, select when this vendor’s invoices are typically due.
9. If this vendor typically offers a discount for invoice paid within a certain time 

period, enter the discount and time period in the Discounts section.
10. In the JC Category field, select the default job-costing category to be placed 

on invoices for this vendor. The category can be changed as an invoice is 
entered.

11. In the GL account field, select the default account to be placed on invoices for 
this vendor. The account can be changed as an invoice is entered.

12. Check the Primary vendor box if this vendor is the primary vendor for the 
GL account selected.
This box indicates that this vendor's terms are to be used in the cash flow cal-
culations for projecting when budgeted expenses should be paid. This is not 
required for direct cost WIP (job related) vendors. 
For example, the primary phone vendor with terms of "Pay on the 10th" 
would cause the cash flow report to project spending the budgeted phone 
expense on the 10th of the month. The cash flow report calculates expendi-
tures on a weekly basis.

13. Enter this vendor’s typical retainage rate.
14. Enter a Federal Tax ID and check the appropriate box if this vendor should 

receive a 1099. Leave blank where there are exceptions.
15. In the Purchases This Year field, enter the amount you have purchased from 

this vendor this year.
This amount is automatically updated whenever a check is cut for this vendor.
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16. Check the On Hold box to put this vendor on hold. By order of and Reason 
are not required, but can be used for reporting purposes. Expiration of insur-
ance causes a subcontractor and all his open invoices to be placed on hold 
automatically.

17. Now click on the Insurance Carrier tab to enter information about the sub-
contractor's insurance agent.

18. Click the Insurance tab. If your company does not allow expired subs to be 
carried on your policy, you can choose to enter only the expiration dates of the 
subcontractor's policy. The system warns you during invoice entry when 
insurance is expired.

19. Under the Worker's Compensation heading, in the Insurance class field, 
enter the code for this vendor's insurance class.
You can get the code for this vendor from your insurance agent. The code is 
dependent on the type of work the vendor does for you and is used to by your 
insurance auditor to determine rates.

20. In the Withholding rate field, enter the rate you charge the vendor for insur-
ance. In the Insurance premium rate enter the rate you pay for the vendor's 
insurance. 
The difference in these two rates is what your company keeps for the adminis-
trative costs it incurs when handling more complex insurance audits. There 
are insurance reports that show where you have withheld these funds.
Workers compensation insurance is generally quoted as dollars per hundred, 
for example, 48 per 100 for roofers. You can simply enter 48 in the rate field 
and the system automatically converts the entry to the correct percentage.
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21. In the Percent labor field, enter the invoice amount subject to WC insurance. 
If the insurance has expired, Profit Builder® uses this percentage to calculate 
how much of the invoice is to be charged with the withholding rate entered 
above. The withholding charge is automatically placed on the invoice and may 
be overridden if desired.
Profit Builder® automatically updates the amount in the Withheld this year 
field.

22. Click Save when you have finished. Cancel causes the information you have 
just entered to be discarded. Delete removes any vendor you have called to the 
screen. An override code is required to delete an existing vendor record.

Do not delete any vendors that have accounting activity for the current year. These 
vendors may require a 1099 to be printed at the end of the current tax year.
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Entering Invoices
Payables invoicing is the heart of every control system because it is generally the most 
labor-intensive accounting function. Profit Builder® reduces and eliminates much of 
this tedious and error-prone work by relying heavily on prepared purchase orders.

There are 4 ways to enter invoices into the system:

Auto-create via scheduling - This is the most common way of entering job 
related invoices when the scheduling feature is available. The scheduling 
operator exports a file (generally to the Inbox folder) and a message appears 
below the menu icons. 

The accounting operator clicks this message and selects the jobs for which to 
create invoices. Invoices are created based on the scheduling approvals of ele-
ments within purchase orders. Audit trails are then printed, and the imported 
file is placed in the Processed folder.
Invoice against a Purchase Order - This is a common way to enter invoices 
for To Be Determined (TBD) Purchase Orders or when the scheduling fea-
ture is not enabled. TBD POs are frequently issued for utilities, construction 
interest, and contracts without fixed quantities such as concrete by the yard. 

The operator selects Accounts Payable > Add / Edit > Invoices and Credit 
Memos and checks the Invoice from PO or Subcontract box. After selecting 
the PO and entering an invoice number, the PO is presented and the operator 
can select full or partial invoicing. The invoice screen is then auto-filled and 
the operator reviews and saves the information.
Add during Quick Checks - This is available for handling the exceptional 
invoice that needs to be paid immediately. It is not required that the invoice 
be on file to pay it fully or partially with Quick Checks. This is not available 
for invoices that are covered by purchase orders.
Add new Invoice - This is the manual way of entering invoices that are over-
head related. This method is also used if you do not have the PO or Schedul-
ing features enabled. Prepaid invoices in which the check has been issued 
prior to the invoice being entered are normally entered in this manner.

Note: In a multi-user system, you can process and enter AP information simulta-
neously. However, you must be sure NOT to process any batches that are being cre-
ated. Processing batches as they are being created can result in lost data.



P R O F I T  B U I L D E R A C C O U N T S  P A Y A B L E

O P E R A T I O N S  G U I D E 23

Auto-creating Invoices via Scheduling
This is the most streamlined and rapid method for creating invoices. The system 
relies on data that is entered in purchase orders and melds it with the inspection 
approvals from scheduling to automatically generate invoices. The accounting dis-
bursement officer then has control in determining when and if to pay these invoices.

This method requires the following:

The job must have purchase orders for all construction activities.
The orders must have activities assigned to every line in the purchase order.
There must be a schedule for the job.
(Optional) The schedule can be cost loaded and vendor assigned by linking 
with a purchase order export for the job.
The scheduling operator must record activity payment approvals.

If an activity has a percentage complete, Profit Builder® looks to see what has previ-
ously been invoiced for that activity and then prepares an invoice for the balance. For 
example, if the Pour Slab activity was previously 20% complete and is now 100% com-
plete, the program prepares an invoice for 80% of the slab’s purchase order.

The scheduling operator uses Tools > Accounting Interface > Export to create a file 
containing the latest inspection approvals for one or more jobs. When this export file 
is placed in the Inbox folder, a message appears below the menu icons "You have 
updates from sales and scheduling."

TO CREATE AN INVOICE FROM SCHEDULING:

1. Click "You have updates from sales and scheduling."
2. For every file in the folder, there is an entry. You can select the files to process 

by checking the box in the Accept column and click OK.
3. Once the file has been selected, all jobs in the file are displayed. You can select 

the jobs to process by checking the box next to each job.
4. Click on the Posting Accounts tab. It is important during the first post to set 

the correct General Ledger accounts.
5. In the Next Invoice Number field, specify the first invoice number that is gen-

erated. Additional invoices have incremental numbers.
6. Verify the account numbers for each of the 5 required accounts.
7. When the accounts are correct, click OK and the invoices are created.

If there are any invoices on file related to POs that are To Be Determined (TBD), you 
can choose to print a list of these files. Invoices are never auto-created for TBDs.

You can print the report so that the amounts for materials and subcontract services 
can be recorded on the report. This list is also used to pick out invoices that need 
approval from the field since they are based on actual quantities delivered or installed. 
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You may select dates when the activities are scheduled as well as particular vendors. 
This keeps the list from being cluttered with items too far in the future or items that 
are handled at closing only.

The example report below is not filtered by date or vendor. You can see closing items 
as well as items that have been partially paid. Since most job utilities are TBD based, 
you see these showing invoice totals to date.

Invoices shown on this report should be attached to the report so that they can be 
reviewed. The amounts that were actually delivered or installed should be marked on 
the invoices.

The person who sorts all incoming job related invoices should have this report to help 
segregate those invoices that need review and approval. Invoices not on this list, 
should be filed by job. TBD invoices are entered against POs.
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Invoice Against a Purchase Order
As mentioned earlier, To Be Determined (TBD) POs are invoiced using this method. 
The system relies on information entered in purchase orders as the basis for the infor-
mation automatically filled into the invoice.

TO CREATE AN INVOICE AGAINST A PURCHASE ORDER:

1. Go to Accounts Payable > Add / Edit > Invoices and Credit Memos.
2. Check the Invoice from PO or Subcontract box. 
3. Click the search button next to the PO Num-

ber entry field. The list of purchase orders 
opens.

4. Select a PO and enter an invoice number. The purchase order appears with the 
full balance set to be invoiced.

5. If you are only invoicing a partial amount from this invoice, change the quan-
tities in the This Invoice column.

6. If you are partially invoicing this PO, you must select More invoices will fol-
low at the bottom of the window.

7. When you have finished, click OK. The invoice screen appears with the infor-
mation from your purchase order filled in.
You cannot change the amounts shown on the invoice.

8. Click Save to save the invoice for processing.

Once you saved the invoice for processing, go to Accounts Payable > Process > 
Invoices and Credit Memos to process the invoice.

Remember that you can click any heading in the 
pick list to sort the list by that heading. For 
example, you can click the top of the last column 
to sort the PO list by type and group all TBDs 
together.
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Adding Invoices with Quick Checks
You can add a new invoice directly from quick checks for invoices that need to be 
paid immediately. This allows you to issue payment at the same time as entering the 
invoice without having to process it separately.

TO CREATE AN INVOICE WITH QUICK CHECKS:

1. Go to Accounts Payable > Process > Quick Checks.
2. Click Setup in the bottom left corner.
3. Clear the Show only Vendors with unpaid invoices box.
4. Click OK.
5. In the Pay to the order of field, enter the vendor for this invoice.

You can also use the search button to select the vendor from a list.

6. At the bottom of the window, click the Invoice column of the first blank line 
in the list of invoices.

7. Enter the invoice number for the new invoice.
Once you have left this field, you cannot go back and change this invoice 
number.

8. In the Unpaid Amount column, enter the gross amount for this invoice. This 
amount should not include any discounts applied.

9. In the Unpaid Disc column, enter any discounts that should be applied to this 
invoice.

When you enter an invoice on-the-fly using Quick Checks, you cannot include 
Worker's Comp or GLI withholding on the invoice. In addition, the system does 
not check to if the item is over-budget.
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10. In the Pay this amount column, click the arrow to enter Job Cost/General 
Ledger charge information for the new invoice.

11. For each invoice line item, enter the Job, Category, Class, Account, Descrip-
tion, Amount, and the amount to pay.

12. When you have finished, click OK to return to the quick check.
13. You can enter additional invoices if necessary.
14. When you have finished, click Process.

When you click on the Process button, the system gives you the option of printing the 
check now or you can wait and print a group of checks using the Checks function at 
Accounts Payable > Reports.
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Adding Invoices Manually
You can also add an invoice by manually entering information from each line item. 
This method is typically used if you do not have a PO associated with this invoice. 
You can also use this method to enter prepaid invoices into Profit Builder®.

TO ENTER AN INVOICE MANUALLY:

1. Go to Accounts Payable > Add/Edit > Invoices and Credit Memos.

2. In the Vendor field, enter a vendor for this invoice or click search to select a 
vendor from the vendor list.

3. In the Invoice Number field, enter a number for this invoice. If you wish to 
call up an invoice that is already on file, click the button next to the invoice 
number field to display the invoice pick list.
Once you have left this field, you cannot go back and change this invoice 
number or vendor.

4. In the Description field, enter a description for this invoice.
5. Enter the date for this invoice. The default date is the processing date set when 

you start Profit Builder®.
6. If the information on file for this vendor contains payment due defaults, the 

system automatically calculates the invoice due date. This entry may be 
changed in the Due Date field for this invoice. The date is used for aging anal-
ysis.

7. In the Amount field, enter the gross amount of the invoice (i.e., the amount 
before any adjustments or taxes).

NOTE: The system will allow you to enter multiple invoices with identical invoice 
numbers as long as the vendors are different.
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8. In the Adjustment field, enter any adjustment amounts (e.g., for freight 
charges, sales tax, etc.). Adjustments can be positive or negative. Enter a 
minus sign in front of the amount to indicate a negative adjustment.

9. The default retainage rate entered on the vendor's record appears in the 
Retainage field. The retainage for this invoice is automatically calculated 
based on this rate. You can change the rate for this invoice in the Retainage 
field.

10. If this vendor's Worker's Comp certificate has expired, a message is displayed 
in red in the dialog box. If you have entered default Worker's Comp withhold-
ing information for this vendor (% labor portion of invoice and a withholding 
%), the system automatically calculates and display the withholding amount 
based on the net invoice amount. You can change the withholding amount for 
this invoice.

11. If this vendor's General Liability Insurance certificate has expired, a message 
is displayed in red in the dialog box. If you have entered default a General Lia-
bility withholding percentage for this vendor, the program automatically cal-
culates and displays the withholding amount based on the net invoice 
amount. You can change the withholding amount for this invoice.

12. If there is a default discount percentage on file for this vendor, it is displayed 
and the system calculates the discount amount using the adjusted gross 
amount of the invoice. On the screen this is shown as the adjusted net 
amount. You can change the discount amount for this invoice.

13. If you want to place this invoice on hold so that it cannot be paid, check the 
Hold invoice box.

14. In the bottom portion of the entry screen you can enter job cost and general 
ledger line items for this invoice. The postings for a single invoice can be 
spread to multiple job/category combinations and/or GL accounts. You must 
charge the total net invoice amount in General Ledger before the program 
allows you to save the invoice.

15. You can choose whether or not to charge the full amount or the discounted 
amount to Job Cost by selecting a job and category for each line item. If you 
enter a job and/or category number that is not already on file, a message is dis-
played and you have the option of adding the job or category now.

16. When you have finished adding line items to you invoice, click Save to save 
this invoice.
You can apply payments if a check has already been written for this invoice.

Once you have saved an invoice in the system, you can go back and apply payments to 
that invoice at any time.

The system calculates the NET AMOUNT of the invoice as the gross invoice 
amount +/- adjustment - retainage. This is also referred to as the adjusted gross 
invoice amount.
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TO APPLY PAYMENTS TO AN INVOICE:

1. Go to Accounts Payable > Edit > Invoices and Credit Memos.
2. In the Vendor field, enter or select the vendor for the invoice you want to 

apply payments to.
3. In the Invoice Number field, enter or select the invoice you want to apply pay-

ments to.
4. Click Apply Payments.
5. When the Payments window displays, enter the check number used to pay 

this invoice.
The system checks to see if that number is on file. If it is not on file, click on 
YES to add it.

6. Accept or enter a new check date. The program enters the invoice due date as 
the default Check Date. It is very important to have a date listed on all AP 
checks in order to proper reconcile your bank accounts.

7. When you TAB through the amount and discount fields, the program auto-
matically enters the total unpaid amount and discount. If the invoice was par-
tially paid you can change these amounts.

8. In the bottom portion of the payments window, the program prorates net 
amount paid (i.e., including any discount taken) for each charge line. If partial 
payment was made, you must adjust these manually.

9. Click OK when all entries are complete. The program checks to see that the 
line payments equal the total payment amount, then returns to the main 
invoice entry window.

10. On the main invoice screen, you’ll note that the program automatically dis-
plays the paid amount for each spread line. Click Save to save the invoice.

Now, when you process your invoice, the payments are applied and the invoice is 
recorded in the proper accounts.
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Editing and Processing Invoices
After you have entered your invoices, you may occasionally need to edit the invoice to 
change items or apply payments.

TO EDIT AN INVOICE:

1. Go to Accounts Payable > Add/Edit > Invoices and Credit Memos.
2. Enter or select the vendor for the invoice you want to change.
3. Click the search button next to the Invoice Number field.
4. Select the invoice you want to change.
5. Make any necessary changes to the invoice.
6. When you have finished, click Save.

TO REMOVE A HOLD FROM AN INVOICE:

1. Go to Accounts Payable > Add/Edit > Invoices and Credit Memos.
2. Enter or select the vendor for the invoice you want to change.
3. Click the search button next to the Invoice Number field.
4. Select the invoice you want to change.
5. Clear the Hold invoice box.
6. When you have finished, click Save.

If the invoice you have changed was already processed, you will need to process it 
again to record the changes properly in your accounts.

Processing an invoice posts information to your accounts payable journal, general 
ledger and job cost accounts. If you wish to print a list of items awaiting processing, 
go to Accounts Payable > Reports > New Invoices and Credit Memos.

Note: In a multi-user system, you can process and enter AP information simulta-
neously. However, you must be sure NOT to process any batches that are being cre-
ated. Processing batches as they are being created can result in lost data.
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TO PROCESS AN INVOICE:

1. Go to Accounts Payable > Process > Invoices and Credit Memos.
2. The system prompts you to make a preprocessing backup. Verify the backup 

location and click Make Backup.
3. Select the invoices to process by month and user.

It is very important that you only process invoices from users when you are 
sure they are no longer entering new items. Processing another user’s invoices 
while they are still entering information can cause a loss of data.  

4. Enter the accounts to be used for processing. 
You must fill in each account. The accounts displayed are the accounts that 
were used the last time you processed invoices. You can change these accounts 
or keep the displayed accounts.

5. When you are ready to process, click OK.

Your accounts are now updated and your invoices printed. If you apply payments or 
edit any invoices, you will need to process them again to update your accounts.
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Preparing Checks
There are two ways to prepare vendor checks in Profit Builder®.

Checks by Range – This enables you to select a range of invoices for payment 
by specifying the vendor, job, due date and/or discount expiration date. The 
system automatically selects the eligible invoices based on your input. If you 
specify certain jobs for payment, only the portion of each invoice that is 
charged to those jobs is paid. You may also select invoices individually.
Quick Checks – This allows you to pay individual vendors, one at a time. You 
can pay one or more invoices that are already on file for that vendor and/or 
create an invoice on the fly as you write the check. This is the quickest way to 
prepare a check.

Checks by Range
Preparing checks by range allows you to cut vendor checks for multiple invoices by 
selecting criteria for those invoices.

TO PREPARE CHECKS BY RANGE:

1. Go to Accounts Payable > Process > Checks by Range.
2. The system prompts you to make a preprocessing backup. Verify the backup 

location and click Make Backup.
3. The Process Checks window appears. 

Note: In a multi-user system, you can process and enter AP information simulta-
neously. However, you must be sure NOT to process any batches that are being cre-
ated. Processing batches as they are being created can result in lost data.

If you need to specify a special printer or tray for printing checks when using 
checks by range, you must go to File > Printer Setup to change your default 
printer settings before printing checks. When you have finished printing your 
checks, be sure to go back and reset your default printer settings.
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4. This window initially shows all unpaid invoices. It may take a minute or two 
to load and display. You can choose how you want to process each individual 
invoice by changing the value in the Action column. You can choose from the 
following options:
• None – This action leaves the invoice unchanged.
• Pay – This adds the unpaid balance to the list of checks to be issued.
• Hold – This places the invoice on hold so that it cannot be paid.
• Delete – This deletes the invoice.

5. If you want to pay all the listed invoices, click Pay All at the bottom of the 
screen. This changes each individual invoice’s action to pay.

6. If you want to filter the list of invoices by vendor, date, or job, click Filter by 
vendors, jobs, dates in the bottom corner of the window.

7. To filter by vendor, click All Vendors and select the vendors you want to 
include.

8. To filter by job, click All Jobs and select the jobs you want to include.
9. If you filter by job, you must also select how you want the invoices filtered.

• Show invoices with ONLY this job will show invoices that include only the jobs 
chosen.

• Show invoices with this job and other jobs to pay only THIS job will show you 
invoices that include this job and other jobs but you can only pay on the portion 
that applies to this job.

• Show invoices with this job and other job to pay this job AND other jobs will 
show you invoices that include this job and other jobs and allow you to pay the 
entire invoice regardless of which jobs the payment applies to.

10. To filter by date, select the dates you want to show in the Dates section.
11. If you want to take all expired discounts, check the box at the bottom of the 

window, and click OK.
12. When you have finished, click OK.

You can choose to print the checks now or later. If you wish to print them now, load 
your blank checks into your printer and click OK. If you wish to print the checks later, 
use the Checks selection on the Reports menu.
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Checks by range also supports checks that total $0. This may occur when there are 
invoices and credit memos that balance out a vendor’s total. Checks that are issued for 
$0 are automatically set not to print.

Quick Checks
Using quick checks allows you to pay an individual vendor or to record a handwritten 
check. You can also pay one or more invoices that are already on file (i.e., entered and 
processed), create a new invoice, or pay a combination of existing and new invoices.

TO CREATE A CHECK USING QUICK CHECKS:

1. Go to Accounts Payable > Process > Quick Checks.
2. The system prompts you to make a preprocessing backup. Verify the backup 

location and click Make Backup.
3. The quick checks window opens.

In the Bank field, select a bank for this check.
4. The check number is automatically filled in with the next available number. 

You can change the number if necessary.
5. The date is automatically filled in with the processing date. You can change 

this date if necessary.
6. In the Pay To Order of field, enter or select a vendor.
7. Fill in the amount for this check.
8. If the vendor has unpaid invoices, they appear below. If you want to apply this 

check to one of the unpaid invoices, enter the amount in the Pay this amount 
column. For information about entering a new invoice from quick checks, see 
“Adding Invoices with Quick Checks” on page 26.

9. Enter a Memo for this check.
10. When you have finished, click Process.
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You can choose to print the checks now or later. If you wish to print them now, load 
your blank checks into your printer and click OK. If you wish to print the checks later, 
use the Checks selection on the Reports menu.

Voiding Checks
You may find it necessary to void an accounts payable check from time to time. This 
process is simple in Profit Builder but does require an override password.

TO VOID AN ACCOUNTS PAYABLE CHECK:

1. Go to Accounts Payable > Add/Edit > Checks.
2. Enter the override password and press OK.

3. To select a single check to void, use the mouse to click in the blank column to 
the left of the check line. To select a range of checks to void, hold down the 
CTL key while you click in the left most column. The entire check line must 
be highlighted.

4. When the check line is highlighted, click Void Check at the bottom of the 
window. You will be asked to confirm your selection.

5. Click OK to void the check(s).

When you click OK to exit the check screen, the program generates the reversing 
postings and prints an audit trail automatically.
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Chapter

3
General Ledger

This chapter offers step-by-step instructions for journal entries, closing periods, 
adding accounts and using reports.

The general ledger gathers information generated by accounts payable, accounts 
receivable and journal entries and processes this information by posting it to the 
proper accounts.

These postings are then used to produce the Balance Sheet and Income Statement. 
You can use these reports to obtain credit from banks and suppliers and to prepare 
income tax returns.

Daily Operations
Control Information keeps track of your current accounting month and year. This 
date identifies the month in the general ledger that is currently open and the totals 
that are shown as the current balances for Balance Sheet accounts and Income State-
ment accounts. The current accounting month may or may not be the same as the 
current calendar month.

Information generated by accounts payable for the current accounting month is 
posted when processed in that module. If you attempt to post to a month that is not 
an open accounting period, you are prompted to open the period in order to post to 
the general ledger. Opening an accounting period requires an override password.

You may have a maximum of twelve consecutive months open at any given time. 
Opening a month that is closed will result in closing another accounting period. 
Whenever you post to the general ledger, an audit trail is produced and the posting 
detail is added to the monthly archive file.

If you need to change any posting information, you must change the information in 
the area in which it originated. For example, if an invoice is charged to the wrong 
account, use Add/Edit in the Accounts Payable menu to correct the invoice. 
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The corrected postings are generated when you process invoices and credit memos in 
Accounts Payable. Financial reports can be printed at any time during the month to 
reflect the latest postings.

Journal Entries
Journal entries are used to change the balance of your general ledger accounts. In 
general operations, journal entries should be used to account for bank charges, 
deposits and any adjustments that may be necessary. In the CFO Edition you can 
enter journal entries for multiple open months in a single session.

General Journal entries are used to:

Establish account balances during setup.
Record entries for bank charges, cash receipts and disbursements if you are 
not using Accounts Receivable and/or Payroll, cash activity where no check is 
written or to reduce and expense prepayments.
Make correcting entries to your ledger account balances.
Make period end closing entries.

Note: All payables disbursements should be entered in the Accounts Payable module. 
Receivables should be entered/modified in Accounts Receivable, if installed. 

TO ENTER A JOURNAL ENTRY:

1. Go to General Ledger > Add/Edit > General Journal Entries.

2. In the Date column, the current system posting date is displayed. You can 
change the date if necessary.

3. In the CO column, select the company for this journal entry.
Entries for each company must balance for each entry session.

4. In the Account column, enter or select the account number for this entry.
Click on the button to the right of the field to display a list of the accounts you 
have on file.
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5. In the Amount column, enter the amount for this entry. Journal entries may 
be positive or negative. You can precede the entry with a minus sign or you 
may suffix the amount with C for a credit or D for a debit (e.g., 100.00C for a 
$100.00 entry to credit the account). A negative sign can mean a credit or a 
reduction in the account depending on how you set up your options at Con-
trol Information > General Ledger.

6. In the Description column, enter information to describe this journal entry. 
7. In the Reference column, enter information to reference this journal entry. 
8. In the Rev column, check the box to create a reversing journal entry in the 

next posting month.
9. If you wish to post this entry to Job Cost as well as General Ledger, enter the 

job, category, and class. In addition, you must specify a valid vendor code and 
an invoice number. You may wish to set up a dummy vendor code for this 
purpose. The cost will be posted as an unpaid item.

10. The Proof box at the bottom of the window shows the total debit and credit 
entries made during this session. The proof amount of those totals should be 
equal to 0.00 before you exit. The system warns you if your entries are out of 
balance. If for some reason you must post an out-of-balance entry, you must 
use the OVERRIDE password to process and exit.

11. When you have finished, click Process and Exit.

You can only enter and process journal entries for open accounting periods. Attempt-
ing to enter an entry for a closed accounting period prompts you to open the 
accounting period. An override password is required to open an accounting period. 
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Importing Journal Entries
You can import a series of journal entries into Profit Builder using an Excel spread-
sheet. To utilize this feature, you must be using Excel 10.0 or higher and it must be 
installed on the same computer as your Profit Builder data. For example, if you use 
Profit Builder in a networked environment, Excel must be installed on the server 
where Profit Builder is installed.

CDCI provides an Excel template to use for importing your journal entries. However, 
if you do not have the template, you can create your own. Your spreadsheet must con-
tain the following columns in the order they are listed. 

Date
Company
Account
Amount
Description
Reference
Make Reversing Entry (Y/N)
Job
Category
Class
Vendor
Invoice

These columns mirror the columns in Profit Builder’s journal entry screen. The infor-
mation entered into your Excel spreadsheet must match the order and format exactly 
for the import to work properly.

TO IMPORT JOURNAL ENTRIES:

1. Go to General Ledger > Add/Edit > General Journal Entries.
2. At the bottom of the window, click Import from Excel.
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3. A window opens with additional instructions. Be sure you have closed the 
Excel program. Click Open Excel Workbook.

4. Select the spreadsheet you want to import and click Open. Profit Builder will 
load the spreadsheet and automatically send you to the next screen.

5. Enter the cell number that contains the first date to be posted. The system 
automatically defaults to cell number A3. If you are using the template CDCI 
provided, there is no need to change this number. If you are using your own 
template, be sure to enter the correct cell.

6. Click Next.
7. Click Finish to copy the posting to your Profit Builder journal entry screen.
8. Check the postings to ensure they are correct and click Process and Exit to 

post the journal entries.
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Closing a Period
The Close Period function is used to close the general ledger at the end of a month. 
This is the LAST step to be performed when closing your books each month. 

If you need to record any special entries at the end of a month, quarter or fiscal year, 
make the necessary journal entries for these adjustments, proof and process these 
postings and then close the period. You may also want to print a Trial Balance Sheet 
and Income Statement.

When closing a period, go to General Ledger > Process > Close Period. The system 
first checks to see that all postings for the oldest open accounting month have been 
made. If not, you are notified that you must Process Postings before you can proceed. 

The program then checks to see if the net difference between the Asset and Liability 
(Balance Sheet) accounts is equal to the net difference between the Income and 
Expense (Income Statement) accounts.

When the Proof line shows equal amounts for the Balance Sheet and Income State-
ment accounts, this is the profit/loss amount that will be posted in order to balance 
the ledger and close the month. 

The profit/loss amount to be posted is also shown when you run a TRIAL balance 
sheet and income statement. When the Proof line amounts are NOT EQUAL, your 
ledger is out-of-balance. You must exit and make the necessary journal entries to bal-
ance your accounts before you can close the month.

Automatic Profit/Loss Posting
The system automatically posts the period end profit/loss amount, transferring the 
amount from the income account to the capital account. The account numbers to be 
used are on file in Control Information.

When posting a profit, the Income Statement expense account “Period Profit/Loss” is 
debited and the Balance Sheet capital account “Profit/Loss Year-to-Date” is credited.

When posting a loss, the Income Statement expense account “Period Profit/Loss” is 
credited and the Balance sheet capital account for “Profit/Loss Year-to-Date” is deb-
ited.

After you have closed the fiscal year, you will need to make journal entries in the first 
month of the new accounting year to clear the Profit/Loss Year-to-Date account and 
move the balance to Retained Earnings (i.e., credit Profit/Loss Year to Date and debit 
Retained Earnings).
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Working In More Than One Month
Often it is necessary to work in more than one month in Profit Builder®. For example, 
say you have not closed September in general ledger, however, it’s October and you 
need to process vendor invoices and checks in accounts payable. 

At any given time, you may have twelve consecutive accounting months open. You 
may reopen past months if necessary to post to the general ledger. An override pass-
word is required to open and close accounting periods. 

When you reopen an accounting period, each period between the current period and 
the reopened period is also opened. For example, if it is September and you need to 
reopen last January, each closed month between January and September will also be 
reopened. The set of open accounting periods must fall in consecutive months.

Your current set of open accounting periods is shown at Control Information > 
General Ledger.

Reports
General ledger reports offer an overview of important information concerning your 
accounts. The reports list below each show a specific aspect of your business and 
accounts.

The default for printing general ledger reports is to print ALL accounts. To specify 
the accounts you wish to appear on the report, click on the bar labeled “ALL 
Accounts” at the bottom of the report selection window. 

Follow the instructions in the window for selecting (highlighting) account numbers. 
Then use the ADD and REMOVE buttons to move the account numbers to and from 
the “Appear on this report” column. Click on OK when you have made your selec-
tions.
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Balance Sheet
The balance sheet shows the assets, liabilities, and owners' equity of your company at 
a particular date.

TO PRINT A BALANCE SHEET:

1. Go to General Ledger > Reports > Balance Sheet.
2. Select the month for which you wish to print a balance sheet. Remember, the 

report reflects only POSTED amounts. 
3. Select to print either a trial (i.e., showing debit and credit account totals with a 

proof figure) or a standard balance sheet report. 
4. Check the Omit accounts with zero balance box to leave out information 

concerning accounts without a balance.
5. Click All Accounts at the bottom of the window if you wish to select specific 

accounts for your report.
6. Click This Company at the bottom of the window if you wish to add other 

companies to this balance sheet.
7. Click Preview to preview the report or click Print to print the report.
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Income Statement
The income statement summarizes the revenues generated and the expenses incurred 
by your company during a period of time.

TO PRINT AN INCOME STATEMENT:

1. Go to General Ledger > Reports > Income Statement.

2. Select the month for the report or select a period in the Period section.
3. Select the report type. A trial report shows debit and credit account totals, 

along with a proof figure. 
4. Check the Omit accounts with zero balance box to leave out information 

concerning accounts without a balance.
5. If you want to filter this report by division or department, make these selec-

tions in the Division and Department fields.
6. Click All Accounts at the bottom of the window if you wish to select specific 

accounts for your report.
7. Click This Company at the bottom of the window if you wish to add other 

companies to this income statement.
8. Click Preview to preview the report or click Print to print the report.
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Comparative Report
A comparative report allows you to create a report to compare the actual and bud-
geted amounts in your accounts for a particular period of time.

TO PRINT A COMPARATIVE REPORT:

1. Go to General Ledger > Reports > Comparative Report.

2. In the Left Column section, select actual or budget to determine which figure 
you want to see.

3. Select a month for the left column.
4. In the Middle Column section, select actual or budget to determine which 

figure you want to see.
5. Select a month for the middle column.
6. In the Right Column section, select how you want to display the difference 

between the first two columns, either dollars or percentage.
7. In the Accounts sections, select which report you want to base your compari-

son report on.
8. Click Preview to preview the report or click Print to print the report.
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Cash Position
The cash position report shows the current balances of your cash, payables and 
receivables accounts.

TO PRINT A CASH POSITION REPORT:

1. Go to General Ledger > Reports > Cash Position.
2. If you want to filter the companies included on this report, click This Com-

pany to select the companies to include.
3. Click Preview to preview the report or click Print to print the report.

Trial Balance Worksheet
This report prints the current debit and credit balances for both balance sheet and 
income statement accounts. A proof figure is printed at the end. Space is provided for 
adjusting entries and an adjusted balance for each account. 

TO PRINT A TRIAL BALANCE WORKSHEET:

1. Go to General Ledger > Reports > Trial Balance Worksheet.
2. Select a month for this report.
3. Click All Accounts at the bottom of the window if you wish to select specific 

accounts for your report.
4. Click Preview to preview the report or click Print to print the report.
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Posting Preview
The Posting Preview report lists all items waiting to be posted to the general ledger.

TO PRINT THE POSTING PREVIEW REPORT:

1. Go to General Ledger > Reports > Posting Preview.

2. In the Posting Source section, check the boxes next to the posting sources you 
want to see on this report.

3. In the Posting Period section, check the All Months box to include all months 
in the report or enter the posting month and year.

4. Click Preview to preview the report or click Print to print the report.

Detail of Ledger
The Detail of Ledger report prints a listing of all posted items in a given time period.

TO PRINT THE DETAIL OF LEDGER REPORT:

1. Go to General Ledger > Reports > Detail of Ledger.
2. Select a month or range of months for this report.
3. Click All Accounts at the bottom of the window if you wish to select specific 

accounts for your report.
4. Click Preview to preview the report or click Print to print the report.
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Detail Batches
The Detail Batches report shows lists the postings to the general ledger organized by 
the batches they are posted in.

TO PRINT THE DETAIL BATCHES REPORT:

1. Go to General Ledger > Reports > Detail Batches.
2. Select a month or range of months for this report.
3. Click All Accounts at the bottom of the window if you wish to select specific 

accounts for your report.
4. Click Preview to preview the report or click Print to print the report.
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Chart of Accounts
The Chart of Accounts report is used to check your accounts and show current and 
previous account balances and budgets.

TO PRINT THE CHART OF ACCOUNTS REPORT:

1. Go to General Ledger > Reports > Chart of Accounts.
2. Click All Accounts at the bottom of the window if you wish to select specific 

accounts for your report.
3. Select one of the following options for this report:

• Account numbers and names only – This option prints only the names and num-
bers of the accounts specified for this report.

• Account descriptions – This option prints the names, numbers and descriptions 
of each account specified for this report.

• Balances and budgets – This option prints the names, numbers, balances and bud-
gets for each account specified for this report. Check the boxes next to the balances 
and budgets you want to appear on this report—balances, this year’s budgets or 
next year’s budgets.

4. Click Preview to preview the report or click Print to print the report.

Bank Reconciliation
The Uncleared Items report lists the items that have yet to clear the selected bank 
account. This report is used to reconcile your bank accounts.

TO PRINT THE UNCLEARED ITEMS REPORT:

1. Go to General Ledger > Reports > Bank Reconciliation.
2. In the Bank Account field, select the bank account for this report.
3. Enter the closing date for this report.
4. Check the Show outstanding Accounts Payable checks box to show any 

uncleared accounts payable checks written on the selected account.
5. Check the Show outstanding Payroll checks box to show any uncleared pay-

roll checks written on the selected account.
6. Check the Show outstanding Accounts Receivable Receipts box to show any 

uncleared accounts receivable payments applied to the selected account.
7. Check the Show General Journal postings to the cash account box to show 

any uncleared journal entries posted to the selected account.
8. Click Preview to preview the report or click Print to print the report.
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Job Reconciliation
The Job Cost Reconciliation report is used to reconcile your job cost accounts. This 
report shows the general ledger postings for a given month and the job cost postings 
for the same period.

TO PRINT THE JOB COST RECONCILIATION REPORT:

1. Go to General Ledger > Reports > Job Reconciliation.
2. Select a month for this report.
3. Select one of the following options to format your report:

• Order by account and then by job within each account
• Order by job and then by account within each job
• Show batches for the month that don’t balance

4. Enter the days you want to show on this report.
5. In the Include classes section, check the boxes next to the classes you want to 

appear on this report.
6. Click All Accounts at the bottom of the window if you wish to select specific 

accounts for your report.
7. Click All Jobs at the bottom of the window if you wish to select specific jobs 

for your report.
8. Click Preview to preview the report or click Print to print the report.

Adding Accounts
The majority of general ledger accounts were added when your company was set up. 
However, it may be necessary to add or change an account during daily operation.

Guidelines for Assigning Account Numbers
When creating a new account, you must assign an account number. There are certain 
guidelines that should be followed when assigning a number to a new account. 

The account number must be five digits—no more, no less. Account numbers must 
be assigned in accordance with the following classifications:

Accounts 10000 - 29999 appear on the Balance Sheet
Accounts 30000 - 99999 appear on the Income Statement

Balance Sheet Accounts:

Assets 10000 - 19999
Liabilities & Capital 20000 - 29999

Income Statement Accounts:

Income 30000 - 39999
Expense 40000 - 99999
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Sequence Numbers
Each account number must have a sequence number. A sequence number of 0 (zero) 
signifies that the account will receive postings. Sequence numbers of 1 - 99 specify the 
order of printing for non-posting accounts. 

Non-posting accounts are used for headings, subheadings and totals on financial 
reports.

You may have several non-posting accounts with the same account number; however 
the sequence number for each of those account numbers must be different. It is the 
sequence number, then, that determines the order in which the accounts appear on 
reports. For example, account 10000 sequence 50 prints after account 10000 sequence 
40.

Contra Accounts

Some accounts have balances that are contrary to the surrounding accounts and their 
headings.

For example, Accumulated Depreciation is a fixed asset account with a credit balance 
(i.e., a reduction in assets). On the Balance Sheet you would expect it to show a nega-
tive sign which it does. 

This is controlled by the Heading account in front of it. All accounts with the same 
normal balance as the heading account print a positive amount; those with opposite 
normal balances print with a negative sign. 

Contra accounts are identified as such whenever you select account information or 
make a general journal entry using that account.

TO CREATE A NEW GENERAL LEDGER ACCOUNT:

1. Go to General Ledger > Add/Edit > Ledger Accounts.
2. In the Account field, enter a number for this account. The number entered 

should follow the guidelines outlined above.
3. In the Seq field, enter a sequence number for this account.

A sequence number of 1 is reserved for a gross margin total account. When a gross 
margin total account is placed after a total direct cost account, it prints revenue less 
direct cost totals on the Income Statement.

Once postings have been made to an account, you can not change the account’s 
normal balance. To make the change you must enter a new account with the cor-
rect normal balance and then use journal entries to zero out the incorrect account 
information and set the beginning balance for the new account.
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4. In the Name field, enter a name for this account.

5. On the Setup tab, in the Normal Balance section, select Debit or Credit as the 
normal balance for this account.
Most asset accounts (10000 - 19999) and expense accounts (40000-99999) 
have normal debit balances.
Most liability, capital/equity and income accounts (20000-29999 and 30000-
39999) accounts have normal credit balances.

6. In the Account Type section, select a type for this account from the following 
options:
• Posting – These accounts carry balances, while all other types are “formatting” 

accounts for printing your financial reports. If the Sequence Number for the 
account is 0, it is automatically a posting account.

• Heading – These accounts are used as “titles” to describe a group of accounts (e.g., 
ASSETS, SALES). The sequence number must be greater than 0 and the normal 
balance should match the accounts to which it refers. On the balance sheet and 
income statement reports headings print in bold type.

• Subheading – These accounts are used as subtitles to describe a group of accounts 
under a heading account (e.g., Current Assets, Contract Sales).

• Total – These accounts are used to print a total for a group of accounts. 
7. In the Account usage field, select how this account is going to be used.
8. In the Division and Department fields, you can select a division and depart-

ment for this account.
9. In the Blank lines to follow field, enter the number of blank lines you want to 

follow this account on reports or check the New page to follow box if you 
want this account to be the last on the page. You can enter up to nine blank 
lines.
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10. In the Print in column field, enter the column number you want this account 
to appear in on reports. Valid entries for this field are 1, 2 or 3.

11. If this is a Total account, in the Subtotal from account number field, enter or 
select the range of accounts to be totaled.

12. In the Cash Flow Analysis section, select how you want this account invoiced.
13. Click the This Year tab.
14. Enter actual and budgeted amounts for this year and next year for this 

account.
15. Click the Last Year tab.
16. Enter actual and budgeted amounts for last year for this account.
17. When you have finished, click Save to save this account.

Importing Account Balances and Budgets
You can import a your account balances and budgets into Profit Builder using an 
Excel spreadsheet. This feature is especially useful when first implementing the sys-
tem. To utilize this feature, you must be using Excel 10.0 or higher and it must be 
installed on the same computer as your Profit Builder data. For example, if you use 
Profit Builder in a networked environment, Excel must be installed on the server 
where Profit Builder is installed..

CDCI provides an Excel template to use for importing both balances and budgets. 
However, if you do not have the template, you can create your own fairly easily. Your 
spreadsheet must contain the following columns in the order they are listed. 

Account
Description

The remaining columns are used for each month you want to enter budgets or bal-
ances for. The months are not read from the spreadsheet; the starting month is 
selected when you import the file. For example, if you want to import budgets or bal-
ance beginning with June, you can enter June through May as your column headings 
but the system will not rely on these headings to determine the month.

In the Account column of your spreadsheet, enter the account number. In the 
Description column, enter the name of the account. In the remaining columns, fill in 
the budget or balance amounts for each month you want to import. You may only 
enter balances for open months.

Although the template is the same, balances and budgets must be imported separately 
with different spreadsheets. For example, you cannot import both balances and bud-
gets for accounts with the same import.

Deleting Accounts
You may not delete an account if there is a balance in the current year, or if there is 
no balance in the current year, but there is one in the previous year.
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TO IMPORT ACCOUNT BALANCES:

1. Go to General Ledger > Add/Edit > Import Budgets from Excel.
2. Enter the override password.
3. A window opens with additional instructions. Be sure you have closed the 

Excel program. Click Open Excel Workbook.
4. Select the spreadsheet you want to import and click Open. Profit Builder will 

load the spreadsheet and automatically send you to the next screen.
5. If your template contains more than one spreadsheet, you will be prompted to 

select the spreadsheet that contains the data you want to import. Check the 
box next to the correct spreadsheet and click Next.

6. Click the button next to I want to import BALANCES.

7. Enter the cell number that contains the first account number. The system 
automatically defaults to cell number A2. If you are using the template CDCI 
provided, there is no need to change this number. If you are using your own 
template, be sure to enter the correct cell.

8. Enter the cell number that contains the balance. The system automatically 
defaults to cell number C2. If you are using the template CDCI provided, 
there is no need to change this number. If you are using your own template, be 
sure to enter the correct cell.

9. Select the month that the balances start in.
10. Enter the year for the balances you are importing.
11. Click Next. If you have included balances for months that are not open, you 

will receive an error. You can only import balances for months that are open.
12. Click Finish to update your balances.
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TO IMPORT ACCOUNT BUDGETS:

1. Go to General Ledger > Add/Edit > Import Budgets from Excel.
2. Enter the override password.
3. A window opens with additional instructions. Be sure you have closed the 

Excel program. Click Open Excel Workbook.
4. Select the spreadsheet you want to import and click Open. Profit Builder will 

load the spreadsheet and automatically send you to the next screen.
5. If your template contains more than one spreadsheet, you will be prompted to 

select the spreadsheet that contains the data you want to import. Check the 
box next to the correct spreadsheet and click Next.

6. Click the button next to I want to import BUDGETS.

7. Enter the cell number that contains the first account number. The system 
automatically defaults to cell number A2. If you are using the template CDCI 
provided, there is no need to change this number. If you are using your own 
template, be sure to enter the correct cell.

8. Enter the cell number that contains the budget. The system automatically 
defaults to cell number C2. If you are using the template CDCI provided, 
there is no need to change this number. If you are using your own template, be 
sure to enter the correct cell.

9. Select the month that the budgets start in.
10. Enter the year for the budgets you are importing.
11. Click Next.
12. Click Finish to update your budgets.
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Chapter

4
Job Cost

This chapter walks you through setting up a new job, budgets, updating 
progress and job reporting.

The Job Cost Ledger stores information for your jobs, including budgets and costs 
charged to those jobs. The budgets are assigned at the category level (e.g., framing, 
HVAC, etc.). Then costs from Accounts Payable and Payroll are charged against these 
budgets.

During setup, you can enter costs directly into Job Cost and record labor costs when 
you are not running the Payroll module. Each cost item is further identified by type—
material, labor, subcontract, equipment, change order or other.

A variety of reports may be produced from your Job Cost Ledger to show cost and 
payment detail, budget variance and profit/loss. For more information on reports, 
see “Reports” on page 65.

Once you have created a job and category structure, you can “clone” it to create a new 
job. For more information on cloning a job, see “Cloning Job Records” on page 62. If 
you are using the optional Scheduling Interface module, you can print a complete set 
of schedule reports for the vendor, the builder and the owner from the Job Cost mod-
ule.

As you complete a job, you can move it to a job archive file. Moving inactive files from 
your Job Cost Ledger can save disk space and speed reporting time. If new activity is 
generated for a job that has been archived, it can be added to the archived job.

If you have purchased the optional cPM Scheduling Interface Module you can link 
scheduling information from CDCI’s Critical Project Management (cPM) with your 
Job Cost system. Schedule information for your jobs flows directly from the schedul-
ing program to Job Cost in Profit Builder, updating vendor assignments, start and fin-
ish dates and percent complete for each accounting category that is linked to a task on 
the schedule. For more information on integrating jobs with cPM, see “Integrating 
with cPM” on page 64.
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Master Job/Category Sets
Job costs in Profit Builder® are accumulated and organized at two levels of detail, first 
by category of work (e.g., electrical, mechanical, interior finish, etc.) and then by type 
of cost (e.g., material, subcontract, etc.) Budgets are set for the category as a whole. 
Job and category codes may be up to six characters each.

Your Profit Builder® system comes with two “template” job and category sets:

A job called NAHB that contains the standard National Association of Home 
Builders category set.
A job called CSI that contains a category set for commercial contractors 
based on UNI format codes.

Whatever category structure you elect to use we recommend that you create your 
own “master” or template job and category set in Profit Builder®. Entry of budget 
information is optional.

Then each time you need to set up a new job, you can use the Create New Jobs from 
Old Jobs function (available at Job Cost > Add/Edit).

Scheduling Interface Considerations
If you are using the cPM Scheduling module, it is important that you use the same 
category structure in each part of your system.

When you update start/finish dates for job categories in Profit Builder®, the interface 
program looks for a match between the category list in scheduling and in Profit 
Builder®’s Job Cost.

If you make changes in one area of your integrated construction management system, 
be sure to apply that change to all other components that you use. For example if you 
change any categories in Profit Builder®, be sure to make same change to cPM.

In the Project Management edition, your activity and category IDs default to the 
same ID.

Creating a New Job Record
To create a new job record from scratch follow the steps below. You can also create a 
new job from an existing job record. This allows you to use a template job record. For 
more information on cloning job records, see “Cloning Job Records” on page 62.

TO CREATE A NEW JOB RECORD:

1. Go to Job Cost > Add/Edit > Job Information.
2. In the Job field, enter the code for this job. The first two characters in this 

code refer to the community in which this job is being performed.
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3. In the Job Name field, enter a name for this job.

CATEGORIES

4. On the Categories tab, in the Plan field, enter the name of the plan used for 
this job.

5. In the Bldg permit field, enter the building permit number for this job.
6. Check the Built on spec box if this job is being built on the specification of 

the plan.
7. Check the Job closed box if this job is closed.
8. In the Contract amount field, enter the billable contract amount for this job.
9. In the Default GL field, enter or select the account number to be used by 

default for this job.
10. In the Sales tax rate field, enter the state sales tax rate for this job.
11. In the Total SF field, enter the total amount of square footage for this plan.
12. In the Heated SF field, enter the total amount of heated square footage for this 

plan.
13. In the Category column, enter a category code to correspond to a job cost 

activity.

14. In the Name column, enter a category name for the code.
15. In the Budget column, enter the total budget amount associated with this cat-

egory. When you charge costs to this category (e.g., when entering invoices) 
you can specify a cost class or type (e.g., material, subcontract, etc.). The pro-

If you use classes within categories, you should first enter all of your categories and 
then go back and enter classes for each category. For more information on using 
classes within categories, see “Control Information” on page 11.
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gram compares the total of all costs charged to this category against this 
amount for variance reporting.

16.  Continue entering categories by repeating steps 14–16.
17. Click the Dates/Custom tab.

DATES/CUSTOM

18. In the Activity column, enter the activity codes for the milestones listed.\
If you are also using cPM Scheduling, these codes should correspond to your 
activity codes in scheduling.

19. In the Scheduled Date column, enter the planned date for completing each of 
the listed activities.

20. In the Actual Date column, enter the actual date the activity was completed.
21. Click the Location tab.

LOCATION

22. Enter the address, city, state, zip and county for the property location.
23. Enter the name and phone number of the location contact person.
24. In the Purchaser section, enter the name, address, city, state, zip and phone 

number for the purchaser.
25. In the Lender section, enter the name of the lender and information about the 

loans involved in purchasing the property.
26. Click the Directions tab.

DIRECTIONS

27. You can enter directions to the job site or other notes for the job. These direc-
tions will print on purchase orders if you use a special PO form when creating 
purchase orders.

28. Click the T&M tab.

T&M

29. In the Amount billed from T&M field, enter the amount that has been billed 
from time and materials.

30. In the Markups section, enter any percentages that the listed classes are 
marked up.

31. Click Save when you have finished. Cancel causes the information you have 
just entered to be discarded. Delete removes any job you have called to the 
screen. An override code is required to delete an existing job record.

Do not delete any jobs that have accounting activity for the current year. 
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Entering Costs for Jobs in Progress
When entering information for a job in progress, you can record the total cost paid to 
date in a special category set up for that purpose.

If you are entering a new job and/or category, you will need to SAVE the entry before 
you can enter a cost for that job and category. 

TO ENTER COST INFORMATION FOR CATEGORIES:

1. After saving the job, call the job back up.
2. Click View Category Costs.

3. Click on the pick list button in the Class field and select the class to identify 
this cost item—labor, material, subcontract, equipment, change order or 
other.

4. In the Vendor field enter a vendor code or an employee number if it is a labor 
cost. During setup we recommend that you use a dummy vendor code 
‘SETUP’ to identify the item. 

5. Type in a description in the Name field.
6. In the Invoice field, enter a dummy number.
7. In the Invoice Date field, enter the base date. 
8. Enter the total cost paid to date amount in the Amount field.
9. Click Save.

If you wish to record the payment for a cost line item, click on the Total Payment but-
ton at the bottom of the cost detail window. Enter check number and the payment 
amount then click on OK. Be sure to click Save to exit this screen.
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Cloning Job Records
Once you have one or more jobs, some of which may have many categories, you can 
save time when you need to create a new job by using the Create New Jobs From Old 
Jobs option at Job Cost > Add/Edit. 

You can set up a “master” job that contains the category set you use, with or without 
budgets. Then clone new jobs from this master job, adding or adjusting the budget 
amounts as required. 

As mentioned earlier, your system comes with two template jobs on file: NAHB that 
contains the NAHB recommended category set and CSI that contains a commercial 
category set based on UNI format.

TO CLONE AN EXISTING JOB:

1. Go to Job Cost > Add/Edit > Create New Jobs From Old Jobs.

2. Select the job you want to copy.
3. Click Add.
4. In the Number field, enter the job number for the new job.
5. In the Name field, enter a name for the new job.
6. Check the Copy budgets box to copy the budgets from the old job.
7. Click OK.
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Updating Progress
If you have integrated your job cost module with the cPM scheduling program, you 
should automatically update progress by importing job schedule information from 
cPM. For more information about integrating with cPM, see “Integrating with cPM” 
on page 64. 

If you do not use cPM, you can manually update the job progress from the job record 
as activities are completed.

TO MANUALLY UPDATE JOB PROGRESS:

1. Go to Job Cost > Add/Edit > Job Information.
2. Click the search button next to the Job field.
3. Select the job you want to update and click OK.

The job pick list is sorted by name not code.
4. On the Categories tab, in the % column, enter the percentage complete for 

each task that needs to be updated.
5. You can also update start and finish dates, and actual costs for activities when 

updating job progress. This information allows you a more accurate picture of 
where you stand in the job’s progress and budget.

6. When you have finished, click Save.

Posting Labor Costs to Job Cost
If you need to record labor costs in Job Cost, you can either enter costs to the appro-
priate job categories or enter and post an invoice in Accounts Payable for a dummy 
vendor called ‘PAYROLL’. This allows you to make the necessary postings to your 
General Ledger and to Job Cost in a single entry.

The example below shows how to enter a single invoice to post a weekly payroll that 
consists of the following:

Cash 3724.82
Federal Income Tax Withheld 609.17
State Income Tax Withheld 182.51
FICA/Employee’s 376.00
FICA/Employer’s 376.00
Federal Unemployment 39.14
State Unemployment 0.00
Salaries 5330.14
401k Withheld 22.50
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The invoice amount is the net payroll amount (gross less payroll deductions), 
$3724.88 in this example. The completed invoice spread screen is shown below:

Integrating with cPM
Profit Builder® is designed to work closely with CDCI's cPM—Critical Project Man-
agement Scheduling program. In the Project Management edition, there is a Schedul-
ing button at the top of your Profit Builder main screen. Go to Control Information 
> Transfer to set the path to your scheduling software. Then, when you click the 
Scheduling button, cPM will open automatically.

Common information to both accounting and scheduling is passed between these 
programs throughout the life of a job. To accomplish this, the job cost category struc-
ture in Profit Builder® must be identical to the scheduling activity list.

Once your job record has been created, you can export this information to scheduling 
in order to accurately track and update the job’s progress. When inspection data is 
entered in the scheduling program, you can then update the job record by importing 
that data back into Profit Builder.

For more in depth information on how to effectively use Profit Builder and cPM to 
track and maintain your jobs, see “Scheduling the Job” on page 136 and “Updating 
the Schedule” on page 142.

GL Account Description Job Category Amount

14000 Work in Progress 321 20000 5,330.14

21561 Fed. Inc. Tax -609.17

21562 State Inc. Tax -182.51

21563 FICA/Employee’s -376.00

21564 FICA/Employer’s -376.00

21573 Federal Unemployment -39.14

21564 401k Withholding -22.50
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Reports
There are many reports that help you track your job costs and progress. A few of the 
most helpful and important are outlined below.

Detail Cost Report
You can run this report by going to Job Cost > Reports > Detail Report. The Detail 
Cost report shows individual cost items and hours information by category including:

Vendor
Invoice number and date
Hours
Budget
Cost
Variance

Note: Only categories with costs posted to them will be shown on the report.

You may run this report for ALL jobs or selected jobs; the default is all jobs. To select 
one or more jobs for the report, click on the bar labeled “All Jobs” at the top of the 
window. Instructions for picking the job(s) for the report are shown in the Pick win-
dow. At the bottom of the Pick window you may specify the categories to include as 
well.

Budget and hours information can be included or not and you can select the cost 
classes to include (e.g., material, subcontract, etc.). If you are including budget infor-
mation on the report, any variance between the budget and actual costs can be shown 
as either a dollar amount or as a percentage.

Category Variance Report
You can run this report by going to Job Cost > Reports > Category Variance Report. 
The Category Variance report includes the following information, subtotaled by cate-
gory and then by job.

Cost (total for all cost classes)
Budget
Budget Remaining (cost - budget)
% Complete (% time completed)
Variance

You may run the report for ALL jobs or selected jobs; the default is all jobs. To select 
one or more jobs for the report, click on the bar labeled “All Jobs” at the top of the 
window. Follow the instructions in the Pick window. At the bottom of the Pick win-
dow you may specify the categories to include as well.
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Job Summary
You can run this report by going to Job Cost > Reports > Job Summary. This report 
summarizes, by job the following:

Total Cost
Budget
Budget Remaining
Variance

Profit/Loss To Date
You can run this report by going to Job Cost > Reports > Profit/Loss To Date. This 
report shows, by job the following:

Selling Price
Total Budget
Total Cost to Date
Variance
Profit/Loss to Date.

You can also issue a bonding report from this report. The bonding report shows the 
following information for the date range selected:

Job
Contract Amount
Total Billings
Total Cost
Projected Cost
% Complete

All open jobs appear on the bonding report regardless of the date range selected. 
However, the totals for each job changed depending on the date range.

Schedule Reports—Builder, Owner, and Vendor
You can run the schedule reports at Job Cost > Reports. The three schedule reports 
on the Reports menu (Builder, Owner and Vendor) enable you to consolidate sched-
ule items for multiple jobs and print them on a single report.
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Closing a Job
We recommend that you close out your jobs in two separate phases. Phase 1 might be 
called the “posting & reporting” phase; Phase 2, the “archiving and deleting” phase.

The answers to one or two pivotal questions will tell you when the timing is right to 
perform each phase.

Phase 1
Before starting Phase 1 of a job close, ask yourself these questions:

Has all revenue for the job been booked and paid? If you haven’t been paid in 
full (both for original items as well as changes and extras), then the job 
shouldn’t be closed.
Has sufficient time (two or three Payables check runs) elapsed for final bills 
from subs and suppliers to “trickle in?” 

If you can say “yes” to both of these questions, you are ready for Phase 1 - Posting and 
Reporting.

In General Ledger:

If you use the “Completed Contract” method of accounting, you’ll need to 
transfer job activity from the Balance Sheet to the Income Statement. Use 
General Journal entries to transfer costs inventoried as Work In Progress 
(14000 series accounts on the standard CDCI and NAHB charts of accounts 
and also shown as the total Job Cost figure on your Job Cost reports for that 
job) over to the Cost of Sales (41000 series on CDCI chart and 35000 and 
above on the NAHB chart). For more information on journal entries, see 
“Journal Entries” on page 38.
Transfer any remaining liabilities to parties financing construction (e.g. 
owner deposits, bank draws, etc.) that have been applied to the sales price, to 
a job-related revenue account (31000 series on CDCI and NAHB charts).

In Job Cost

If you’d like your Job Profit & Loss report to show net profit, instead of gross 
profit and overhead, you’ll need to allocate indirect and/or overhead 
expenses (42000 and 43000 and higher expense accounts respectively on the 
CDCI and NAHB charts of accounts) back to your individual jobs. (You 
should be consistent - allocate on all jobs or none.) Consult with your 
accountant and other management when making this decision. 

By definition, indirect and overhead costs cannot be captured directly on the 
job-related transaction (sub or supplier’s invoice, crew’s time card, etc.), and 
therefore must be allocated back to individual jobs with some formula. Take, 
for example, a simple percentage formula. Assume last year’s 41000 (job-
related expense) accounts totaled $1,000,000 on the annual Income State-
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ment, and that indirect and overhead expenses totaled only $100,000. That’s 
a 10% overhead factor. You’ve booked all direct costs, so you can apply this 
formula to create the overhead posting to the job. 

Remember that this overhead cost has already been booked in General Led-
ger, so you’ll need to enter it directly in the Job Cost module. If you plan to 
allocate overhead back to jobs, you may have even created (and possibly bud-
geted) an overhead category, or perhaps you plan to post to Cost Class A or O 
(Administrative or Overhead) of each category.
Before running final Job Cost reports, you need to tell the Job Cost module 
that the job is complete. This lets it know that it should now report actual 
(not estimated) profit on the job. Call up the job and click on the 100% Com-
plete button at the bottom of the window. This automatically updates all cate-
gories. (Home builders may want to create separate “callback” and warranty 
jobs and then retire the original job.)

Phase 2
Phase 2 involves moving the job out of your Job Cost ledger. To determine if you’re 
ready to move the job out of your Job Cost Ledger, ask your self these questions:

Does your accountant need access to this job for any fiscal year adjustments?
Have you booked any transactions or run any reports on this job recently ?

If the phase 2 questions have been satisfied, it’s time to archive the job, saving a copy 
of it on floppy or on your hard disk. Once this is done you can delete it from the Job 
Cost Ledger.

On the Main Menu bar, select Modules, then select Housekeeping, Archive 
Jobs. You will be asked to enter the Override password, specify an .MDB stor-
age file name for your job archives and then the jobs to be transferred to the 
archive.
Go to Add/Edit, Job Cost and delete the job. 
Caution: If you need to process a cost item to a job that has been archived 
and then deleted from the main ledger, be sure to copy it back from the 
archive BEFORE you enter and process the cost item. When you copy to or 
from an archive the system overwrites any existing information with like job 
and category codes, etc.



P R O F I T  B U I L D E R

O P E R A T I O N S  G U I D E 69

Chapter

5
Payroll

This chapter offers step-by-step instructions for adding deductions, employees 
and issuing payroll checks.

Payroll is an important, necessary part of maintaining your business. This chapter 
outlines the daily operations of maintaining your payroll system and using Profit 
Builder® to issue payroll checks.

Setting up Payroll Taxes
Payroll taxes, including federal and state withholding, FICA/Medicare and unem-
ployment are calculated and deducted automatically based on your Profit Builder® tax 
tables and employee exemption information.

You can verify the settings for you federal payroll taxes at Payroll > Add/Edit > Fed-
eral Tax. These tax tables are updated annually with new tax laws and should not be 
changed.

State information is stored at Payroll > Add/Edit > State Tax. The withholding infor-
mation for each state is also updated annually with new tax laws. However, you will 
need to designate the general ledger accounts which you will track state tax withhold-
ings.

TO SET UP STATE PAYROLL TAXES:

1. Go to Payroll > Add/Edit > State Tax.
2. In the State field, enter the two letter abbreviation for your state.
3. In the State Income Tax ID field, enter you state income tax ID.
4. In the Income Tax GL Account field, select the general ledger account that 

will track state income tax withholdings.
5. In the State Unemployment Tax ID field, enter you SUT ID.
6. In the SUT GL Account field, select the general ledger account that will track 

state unemployment tax withholdings.
7. In the State Disability Insurance ID field, enter your state SDI ID.
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8. In the SDI GL Account field, select the general ledger account that will track 
your state disability insurance withholdings.

9. Click OK.
10. Repeat these steps for each state in which you do business.

If your employees work in areas that require local taxes to be withheld, you will need 
to turn on the local tax feature and set up the tax rates for each locality.

To turn on local taxes, go to Payroll > Add/Edit > Control Information > Payroll, 
check the Enable local tax withholding box and click OK.

TO SET UP LOCAL TAXES:

1. Go to Payroll > Add/Edit > Local Tax.
2. In the Locality field, enter a six character code for this tax rate.
3. In the Name field, enter the locality name for this tax rate.
4. In the Resident rate field, enter the tax rate charged to residents of this local-

ity.
5. In the Nonresident rate field, enter the tax rate charged to nonresidents 

working in this locality.
6. In the Credit method field, select the credit method used for this locality.
7. In the Credit Lower limit field, enter the credit lower limit for this locality.
8. In the Credit Upper limit field, enter the credit upper limit for this locality.
9. In the Account field, select the general ledger account that will track the local 

tax withholdings.
10. Repeat this process on a new line for each local tax rate you want to enter.
11. When you have finished, click OK.
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Entering Deductions, Pays & Contributions 
Before you can process your payroll, you must first ensure that all of the required 
deductions, payments and employer contributions are entered into the system so that 
they can be applied to employees’ checks. Deductions, pays and employer’s contribu-
tions (ADPs) are set up and then assigned to individual employees. 

TO CREATE ADDITIONAL DEDUCTIONS, PAYS AND CONTRIBUTIONS:

1. Go to Payroll > Add/Edit > Deductions, Pays, Contributions.

2. In the Code field, enter a code for this deduction.
Each additional deduction, pay or contribution is identified by a six character 
code (use no spaces or special characters).

3. In the Description field, enter a description of this item up to 60 characters.

SETUP

4. On the Setup tab, in the Function field, select one of the following functions 
for this ADP:
• Miscellaneous deduction
• Miscellaneous pay
• Employer’s contribution (an expense incurred by the employer on behalf of an 

employee that does not affect the employee’s paycheck)
• Additional federal withholding
• Additional state withholding

5. In the Frequency field, select the frequency for calculating this ADP.
6. In the Method field, select the method for calculating this ADP.
7. Depending on the method selected, enter the appropriate amount in the 

Amount field.
8. Check the Taxable box to indicate that this ADP is subject to federal and state 

income taxes.
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9. In the Cutoff and Reset fields, you can specify a maximum cutoff amount for 
the ADP. This cutoff amount, along with the reset period specified determine 
the limits of the ADP amount. The reset entry (e.g., every period, every 
month, etc.) determines the period that the program looks at to determine 
whether or not the maximum cutoff amount you specified has been reached.

10. In the Credit account and Debit account fields, you are required to specify 
the general ledger account to be credited or debited with the amount. For an 
employer’s contribution you must specify both the debit and the credit 
accounts.

11. If this item is to be printed on the employee’s W-2, indicate the W-2 box in the 
Box to print in on W-2 field (e.g., 13 or 14). 

12. For items that are to be printed in Box 13, enter the IRS letter code that is to be 
printed to identify the amount in the IRS code for W-2 box field.

13. Check the Print on Certified Payroll Report box to print this ADP on pay-
roll reports.

14. Click the Limits tab.

LIMITS

15. In the Jobs field, you can specify a job or range of jobs to trigger the calcula-
tion of this ADP. This means that the item will be calculated only for time card 
entries with the specified job.
If you want this ADP to appear in job cost, select the specific jobs or enter 1-
ZZZZZZ in this field. Entering this will post this ADP to any job that is 
entered on a time card.

16. In the Categories field, you can specify a category or range of categories to 
trigger the calculation of this ADP. 

17. In the Crafts field, you can specify a craft or range of crafts to trigger the cal-
culation of this ADP. 

18. In the Charge to section, you can select a job, category or class to redirect the 
charge of this ADP to.

19. In the Gross pay field, you can set starting and ending limits for this ADP. 
This means that this ADP will only be calculated for employees whose gross 
pay falls within this range.

20. Click the Advanced tab.

ADVANCED

21. On the Advanced tab, check the boxes for of the advanced setting you want to 
apply to this ADP.

22. Click Save when you have finished. Cancel causes the information you have 
just entered to be discarded. Delete removes any ADP you have called to the 
screen. An override code is required to delete an existing ADP record.

Once you have entered all of your ADPs, you can add them to your employee records.
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Payroll Taxes and Exempt Compensation
Many operators have difficulty figuring which taxes apply to certain deductions and 
payments. The instructions listed below are based on federal and most state codes. 
Please check with your state if you are not sure how a state treats certain payments.

Section 125 Cafeteria plans – Congress realized that many employers had been pay-
ing certain benefits which were never considered compensation and therefore were 
never included in an employee's payroll. As employers reduced benefits, Congress 
passed a law allowing these benefits to still be paid by the employer yet the cost could 
be deducted from the employees' pay.

These deductions would not have any payroll taxes. A cafeteria of benefits would be 
offered to employees and the employee could decide which ones to buy. There are a 
couple of basic rules:

The benefit must be disbursed by the employer (the employee cannot receive 
the funds and then pay for the benefit.
The benefit must qualify—health and disability insurance, day care, and 
other items are allowed.

Section 125 Deductions are exempt from:

Federal Income Tax
FICA withholding
Medicare withholding
Federal Unemployment Tax
State Income Tax
State Unemployment Tax
Worker's Compensation Insurance

401(k) Retirement Plans – Congress permits certain amounts of normal compensa-
tion to be deposited by the employer in specially secured and monitored accounts so 
that the funds will be available for retirement. Some companies put in matching 
funds as well. Congress allows the individual to defer payment of Federal Income 
taxes until the money is withdrawn at retirement. Then, the money is taxed as it is 
withdrawn. Since no other taxes are placed on this money when it is withdrawn in 
retirement, the other taxes are paid when the regular payment would have been made 
on payday.

401(k) Deductions are exempt from:

Federal Income Tax
State Income Tax (most states)
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401(k) is NOT exempt from:

FICA withholding
Medicare withholding
Federal Unemployment Tax
State Unemployment Tax
Worker's Compensation Insurance

Employee Reimbursements – When employees purchase tools or supplies for the 
company and are reimbursed, these payments are exempt from all taxes. The same 
treatment is given to employee reimbursements for travel, meals and lodging. Uni-
forms, tuition reimbursements and other benefits may or may not qualify for exemp-
tion. Talk with your CPA about how to categorize these items so that they qualify for 
exemption.

Employee reimbursements are exempt from:

Federal Income Tax
FICA withholding
Medicare withholding
Federal Unemployment Tax
State Income Tax
State Unemployment Tax
Worker's Compensation Insurance

Extra Pay
There may be times when you want to add additional compensation to your employ-
ees’ paychecks. For example, if you one of your employees uses their own tools to 
complete a job, you may want to pay them a stipend for the use of their tools.

This extra pay can be tracked by the job but posted to an expense account. This way 
you can keep track of your job cost accurately and the extra pay is written off as an 
expense.

All of this is accomplished by creating a special ADP for the extra pay. To do this, fol-
low the steps below in setting up your extra pay.

TO CREATE AN EXTRA PAY ADP:

1. Go to Payroll > Add/Edit > Deductions, Pays, Contributions.
2. In the Code field, enter a code for this payment.
3. In the Name field, enter a name for this payment.
4. In the Function field, select Miscellaneous pay.
5. In the Method field, select how you want the amount of this extra pay deter-

mined.
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6. In the Amount field, enter the amount to be used in conjunction with your 
selection in the Method field.

7. Check the Taxable box if this extra pay is taxable.
8. In the Cutoff field, enter a cutoff and reset period if one applies.
9. In the Debit account field, select an expense account for this extra pay.
10. If this extra pay is to appear on a W-2, fill in the information about W-2 print-

ing.
11. Check the Print on Certified Payroll Report box to have this payment print 

on the certified payroll report.
12. Click Limits.
13. Click Browse next to the Jobs field.
14. Select the jobs you want this extra payment to apply to and click Add.
15. When you have finished click OK.
16. Under Charge to, on the Limits tab, select a job to charge this expense to for 

job cost.
17. Click Advanced.
18. Clear any boxes for taxes this item is not subject to.
19. Click Save.

Once you have created this ADP, you must also assign it to the employees that will use 
it. Once it has been assigned to employees, when the job selected is entered on a time-
card, the extra pay will be calculated for that employee.

Worker’s Compensation

Worker’s compensation can be calculated three different ways in Profit Builder. The 
way it is calculated depends on several factors:

how you pay out worker’s compensation
whether or not you use crafts
whether or not you attach ADPs to categories
whether or not default worker’s compensation is set on employee records

Paying Worker’s Compensation Benefits
If you need to pay an employee worker’s compensation benefits you can use a 
worker’s compensation ADP or an Extra Pay ADP.  Depending on your state, you may 
be required to pay a percentage of the employee’s regular pay or a dollar amount per 
hour.

If you are required to pay a dollar amount per hour for worker’s compensation bene-
fits, you must use an Extra Pay ADP to pay out these benefits. For more information 
on creating an extra pay ADP, see “Extra Pay” on page 74.

If you are require to pay a percentage of the employee’s regular pay, you must set up 
and use the worker’s compensation ADP available in Profit Builder.
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TO SET UP A WORKER’S COMPENSATION ADP:

1. Go to Payroll > Add/Edit > Deductions, Pays, Contributions.

2. In the Code field, enter a code for this ADP.
3. In the Name field, enter a name for this ADP.
4. In the Function field, select Worker’s comp.
5. In the Amount field, enter the percentage amount required to be paid to 

employees.
6. In the Cutoff fields, enter any cutoff information. Some states have maximum 

benefits for worker’s compensation. Check with your local state laws to deter-
mine if cutoff limits apply.

7. In the Credit account field, select an account to credit this pay to.
8. In the Debit account field, select an account to debit this pay from.
9. When you have finished, click Save.

You can create multiple worker’s compensation ADPs. Once you have created the 
ADP, you can attach it to crafts, categories and employee records.

If you want to charge general liability insurance and worker’s compensation in a sin-
gle ADP, you need to combine these rates and create one worker’s compensation ADP 
that includes both. This is necessary because you can only assign one default worker’s 
comp ADP to each employee.
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Crafts
Crafts are used in certified payroll to record the activities of employees on timecards. 
Crafts also play a role in how worker’s compensation is calculated. If a craft is 
assigned a worker’s compensation code and entered on an employee’s timecard, the 
code assigned to the craft will be used to calculate worker’s compensation benefits.

TO ADD A NEW CRAFT:

1. Go to Payroll > Add/Edit > Crafts.
2. In the Craft column, enter a code for this craft. This code can be up to four 

characters.

3. In the Description column, enter a description for this craft.
4. In the Unit column, enter a unit of measure for the pay rate for this craft. For 

example, if the craft is paid by the hour, enter hour.
5. In the Regular Rate column, enter the regular pay rate for this craft.
6. In the Overtime Rate column, enter the overtime pay rate for this craft.
7. In the Premium Rate column, enter the premium pay rate for this craft.
8. In the Workers Comp column, select the worker’s compensation ADP for this 

craft. The worker’s compensation selected treats all payments as straight 
hourly and does not account for overtime and premium pay.

9. Repeat steps 2–8 for each craft you want to add.
10. When you have finished, click OK.
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Attaching ADPs to Categories
You can attach specific worker’s compensation ADPs to categories in order to specify 
the worker’s comp rate paid for each category. Then, when you select a category on a 
time card, the worker’s comp rate is applied for that time card line-item.

TO ATTACH A CATEGORY TO A WORKER’S COMP RATE:

1. Go to Payroll > Add/Edit > Deductions, Pays, Contributions.
2. In the Code field, select the worker’s compensation ADP that you want to 

attach a category to.
3. Click the Limits tab.

4. Click Browse next to the Categories field.
5. Select the categories you want this ADP to apply to and click Add. You can 

select categories individually or hold down Ctrl to select multiple categories.
6. When you have finished adding categories, click OK. The categories you have 

selected appear in the Categories field.
7. When you have finished, click Save.

Setting Default Worker’s Comp on Employee Records
You can set a default worker’s compensation ADP for each employee. This applies a 
worker’s compensation rate if rates are not set for crafts or categories. If you have not 
yet entered employee records, see “Entering Employee Records” on page 80.

TO SET A DEFAULT WORKER’S COMP ON EMPLOYEE RECORDS:

1. Go to Payroll > Add/Edit > Employees.
2. In the Employee number field, select the employee record you want to 

change.
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3. Click the Taxes tab.

4. In the Default WC field, select the default worker’s compensation ADP you 
want used for this employee.

5. Check the Exempt from Workers Comp box if this employee is exempt from 
receiving worker’s compensation.

6. When you have finished, click Save.

Important Notes about Worker’s Compensation
Worker’s compensation rates are applied in the following order:

By the craft logged on a time card
By the category logged on a time card
By the default selected on the employee record

What this means is that the worker’s compensation rate is first determined by the 
craft selected on a time card. If no craft is selected or the craft does not have a 
worker’s comp ADP associated with it, the rate is then determined by the category 
selected on the time card. If no category is selected or the category does not have a 
specified worker’s comp ADP associated with it, the rate is determined by the default 
ADP selected on the employee record.

NOTE: In order for worker’s compensation to be calculated for salaried employ-
ees, you must enter a timecard with 40 hours per week recorded for each employee.
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Entering Employee Records
Employee records are used to collect information about your employees. It is impor-
tant to maintain accurate employee records for payroll and human resources pur-
poses.

Unlike vendors and customers, employees are issued a number instead of a code. 
Each employee must be assigned an ID, up to six alphanumeric characters (no special 
characters or spaces allowed). 

If you choose to use a numeric ID, you may wish to group the IDs for easier selection 
on the pick list and for reports. For example you might assign hourly employees ID 
numbers from 100-600; salaried employees from 700-800.

Using the Employee Pick List
Before you add an employee, make sure that the employee record has not already 
been added. It is easy to search the employee list by both name and by code.

Go to Payroll > Add/Edit > Employees and click the search button next to the 
Employee number field. Click on the column heading "Employee" and the list will be 
sorted by the employee number.

You may sort on either the Employee Number or Name by clicking the appropriate 
column heading. The second click of the column heading reverses the order of the 
column. By default, the list is sorted by Name.

Using the search and the employee list makes it much easier to locate existing 
employee records and prevent unwanted duplicate entries.

You can type any letter to jump to that point in the employee list. Typing a letter 
shows a Find Name field in the employee list. Enter the employee name you are 
searching for in this field to determine if the employee record has already been cre-
ated.
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Creating New Employee Records

TO CREATE A NEW EMPLOYEE RECORD:

1. Go to Payroll > Add/Edit > Employees.
2. In the Employee number field, enter a number for this new employee.

3. On the Personal tab, enter the employee’s name, address, city, state, zip, phone 
numbers and e-mail address.

4. Click the Family tab.

FAMILY

5. In the Ethnic group field, select the ethnicity of this new employee.
6. In the Sex field, select male or female.
7. In the In Case of Emergency, Contact section, fill in the phone number, 

name, address, city, stat, zip and relationship of the employee’s emergency 
contact.

8. In the Children field, enter the names and ages of any children of the employ-
eee.

9. In the Insurance dependents field, enter the names and relationships of any 
insurance dependents this employee may have.

10. Click the Taxes tab.



P R O F I T  B U I L D E R P A Y R O L L

O P E R A T I O N S  G U I D E 82

TAXES

11. In the Social Security No. field, enter the employee’s complete social security 
number. A valid social security number is required for W-2 reporting.

12. In the Default WC field, select the default worker’s compensation ADP you 
want used for this employee.

13. Check the Exempt from Workers Comp box if this employee is exempt from 
receiving worker’s compensation.

14. In the Non Job Related Overhead field, select the account to charge non-job 
related payroll overhead expenses for this employee.
If no account is selected here, the system uses the default account specified in 
the Payroll Calculate function.

15. In the Job Related Overhead field, select the account to charge job related 
payroll overhead expenses for this employee.
Job related overhead may be prorated and charged to the jobs/categories and 
accounts on the time card OR you may specify a separate posting category 
and cost class. 
If you elect not to post overhead to Job Cost the system posts the expense to 
the Job Related Overhead account on file in Employee Information. If no 
account is specified, the system uses the default account entered in Payroll 
Calculate.

16. In the Federal status field, select the employee’s federal tax status as reported 
on their W-4.

17. In the Federal exemptions field, enter the number of federal tax exemptions 
claimed on their W-4.

18. In the Tax State field, enter the postal abbreviation for the state in which the 
employee pays taxes.
If you run payroll in more than one state for a single employee, you will need 
to calculate and print a separate check for each state, changing the state on the 
employee’s record as necessary.

19. In the State column, enter the state in which the employee pays taxes.
20. In the Marital status column, select the marital status as reported on the 

employee’s W-4.
21. Enter the state tax exemptions claimed on the employee’s W-4.
22. Repeat steps 19–21 for each state the employee pays taxes in.
23. Click the Rate/Historical tab.

Payroll overhead expense (or “burden”) is the employer’s share of FICA, 
FUT and SUT. You have several options for charging this expense in your 
general ledger and job cost. The Payroll Calculate function as well as 
Employee Information stores the posting instructions for job-related and 
non-job related overhead.
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RATE/HISTORICAL

24. In the Pay rate field, enter the employee’s pay rate. For an hourly employee 
enter the rate per hour; for a salaried employee enter the salary per pay 
period.

25. In the Pay periods per year field, enter the number of paychecks this 
employee receives in one year. (e.g., 52 for weekly, 26 for bi-weekly; 24 for 
semimonthly or 12 for monthly).

26. Select one of the following employee types for this employee.
• Hourly – An hourly employee is paid an hourly rate for the exact number of hours 

they work. You must enter a time card to generate a payroll check for an hourly 
employee.

• Salaried – A salaried employee is paid a set salary for a given period of time 
regardless of the number of hours worked. A time card is not required for a salaried 
employee unless you wish to charge his/her time to a specific job or general ledger 
account.

• Inactive – An Inactive employee is one for whom you do not wish to calculate a 
paycheck. However, they should remain on file in order to receive a W-2 at the cal-
endar year-end.

27. Check the Variable rate box if this employee’s rate of pay varies.
28. In the Default Expense Account field, select a default account for this 

employee’s payroll expense.
29. In the Vacation hours per year field, enter the number of vacation hours this 

employee is entitled to in a year.
30. In the Vacation hours remaining field, enter the number of vacation hours 

this employee has remaining for the current year.
31. In the Sick hours per year field, enter the number of sick hours this employee 

is entitled to in a year.
32. In the Sick hours remaining field, enter the number of sick hours this 

employee has remaining for the current year.
33. Click the Added Pay/Deduct. tab.

ADDED PAY/DEDUCT.

34. On the left, select any deductions and employer’s contributions that should be 
added to this employee’s paycheck.
You can select multiple entries by holding down Ctrl as you highlight each 
deduction.

35. Click the arrows to move selected deductions to the right and add them to this 
employee’s paycheck. 

36. You can also highlight deductions on the right and move them left to removed 
them from this employee’s paycheck.

37. Using the up and down arrows you can highlight deductions and reorder 
them in the employee’s profile.

38. Click the Notes tab.
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NOTES

39. Enter any information that is important to this employee’s record. For exam-
ple, you can use this space to record information that may be useful when 
conducting performance reviews.

40. Click the Performance tab.

PERFORMANCE

41. In the Employment date field, enter the date this employee began working for 
your company.

42. In the Termination date field, if this employee is no longer with your com-
pany, enter the date of the employee’s last day with your company.

43. In the Disciplinary/Safety Warnings section, you can enter the date, type, 
description and documentation for any disciplinary action that has been nec-
essary for this employee.

44. In the Reviews section, enter the results of any performance reviews you have 
conducted for this employee.

45. In the Next review due on field, enter the date of this employee’s next sched-
uled performance review.

46. Click Save when you have finished. Cancel causes the information you have 
just entered to be discarded. Delete removes any employee you have called to 
the screen. An override code is required to delete an existing employee record.

Recording Handwritten Paychecks
This function may be used when setting up a new system to enter year-to-date and/or 
quarter-to-date payroll history information for each of your employees. 

This history information is used for quarterly reports, as well as W-2’s at the end of 
the year. If you are setting up a new payroll system at the beginning of a quarter and 
do not need to run quarterly reports, you may enter a single, year-to-date check 
record for each employee. 

If you are setting up in the middle of a quarter you may need to enter two check 
records for each employee—one for the current quarter to date and one for all previ-
ous quarters.

During regular operation of the system, this function is used to record and post infor-
mation about a handwritten payroll check (i.e., one that was not calculated and 
printed using Profit Builder®).

Do not delete any employees that have accounting activity for the current year. 
These employees may require a W-2 to be printed at the end of the current tax 
year.
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TO RECORD A HANDWRITTEN CHECK:

1. Go to Payroll > Process > Handwritten Check.
2. In the Bank field, select the bank account this check was drawn on.
3. In the Check number field, the system automatically enters the next available 

check number, you may change this number if necessary.
4. In the Date field, enter the date of this check.
5. In the Pay to the order of field, enter or select the employee’s name for this 

check.
6. In the amount field, you can enter the net amount of the check or leave this 

field blank. After entering other information on the next screen the net 
amount will be calculated automatically.

7. Click Next.
8. The second Handwritten Check window allows you to enter time card infor-

mation for posting to Job Cost. During setup or when you do not need to post 
the payroll information to Job Cost you may skip this screen. Otherwise, you 
can enter the job, category, account, regular and overtime hours for each job 
on this check. All hourly employees are required to have a timecard entered. If 
this check is written to an hourly employee this screen is required.

9. Click Next.

10. Enter the regular hours and pay from this check.
11. Enter any overtime hours and pay from this check.
12. Enter any premium hours and pay from this check.
13. Enter the withholding from this check. 
14. As you make entries, the amounts are updated on the side of the window. If 

you entered an amount for the check on the first screen, the difference must 
be 0 before you can proceed recording this check.

15. When you have finished, click Next.
16. If you did not enter an amount for the check on the first screen the system will 

alert you to the difference in the amounts and ask if you want to set the check 
to the new net pay amount. Click Yes.
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17. In the Payroll cash account field, verify or select an account for this check to 
post to.

18. To adjust any other posting accounts, click Other Posting Accounts. Make 
any changes to other posting accounts and click OK.

19. If you need to adjust the check form printing, click Check Form Setup.
20. If you do not want to print this check, clear the Print this check? box.
21. Select how you want this check to be recorded.
22. Verify the total pay, total deductions and net pay.
23. Click Next.
24. If you have selected to print the check, you will be prompted to load your 

check stock into your printer. Click Next. Your check will then begin printing.
25. When it has finished, you will receive a message that your check has been 

recorded to your payroll accounts and the system will now print your audit 
trail reports. Click Finish.

This process should only be used to record checks that are not processed with your 
regular payroll. It is not intended to replace the automated payroll system used in 
Profit Builder®.

Entering Time Cards
Use Add/Edit Time Cards to record hours—standard and overtime—for hourly 
employees. You must enter a time card in order to calculate a paycheck for an 
employee designed as “hourly.” You may also enter time cards for salaried employees 
in order to charge all or part of their salary to Job Cost. 

TO ENTER A TIME CARD:

1. Go to Payroll > Add/Edit > Time Cards.
2. In the Employee field, enter or select the employee who you want to enter a 

time card for.
3. In the Weeks worked in this pay period field, enter the number of weeks in 

the current pay period.
4. If the hours are to be charged to job cost, enter or select a job and category in 

the Job and Category columns. If you enter a job or category code that is not 
on file, the program gives you the opportunity to add the new code. Then 
when you have completed the time card entry, go to Job Cost and complete 
the information for the new job.

5.  The Account column should fill in automatically. You can change the account 
if necessary.
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6. In the Regular column, enter the number of regular hours worked on this job.

7. In the Overtime column, enter the number of overtime hours worked on this 
job.

8. Continue entering time entries for this employee by repeating steps 4–8.
9. If you use certified payroll, you must also enter a craft and day for each line.
10. When you have finished, click OK to save the time card. You can continue 

entering addition time cards for other employees or click Exit to close the 
time card window.

Print the Time Card Report to proof your entries before you calculate the payroll and 
print the paychecks.

Tracking Vacation and Sick Time
Profit Builder allows you to manually track available and used vacation and sick time 
on each employee’s record. To track vacation and sick time. go to Payroll > Add/
Edit > Employees. On the Rate/Historical tab, you can enter the number of vacation 
and sick hours the employee receives each year and the number of hours that have 
been used. This information is not automatically updated when payroll is calculated, 
you must update this information manually in order to track vacation and sick time 
in Profit Builder.

If you are entering job hours for a salaried employee, the salary is prorated among 
the job/categories entered based on the number of regular hours entered on this 
time card. 

For example, if a salaried employee has a time card with 10 hours for one job, 35 
for another and 5 for a third (a total of 50 hours), the salary will be prorated 20%, 
70% and 10% respectively among the jobs specified.

It makes no difference how many regular hours are entered for a salaried 
employee. The program assumes that the total regular hours equal the salary 
regardless of the number of hours entered.

Overtime for an hourly employee is calculated using the overtime rate that is on 
file in Control Information.

Overtime pay for a salaried employee is calculated using the following formula: An 
hourly rate is computed by multiplying the salary per pay period times the number 
of pay periods per year and then dividing by 2080 (average hours per year). Next, 
that rate is multiplied by the number of overtime hours and then by the overtime 
rate from Control Information.
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When an employee uses vacation or sick time, there are two ways you can pay that 
employee—with a job or an ADP. The most effective way to track and pay vacation 
and sick time for both hourly and salary employees is by setting up a job for sick and 
vacation time.

Creating two separate “dummy” jobs for vacation and sick time allows you to enter 
this information on time cards when employees utilize these benefits. In the case of 
hourly employees, entering the job information on the time card generates payment 
for those hours without requiring additional ADPs to be added to the employee’s 
paycheck. Using jobs to track vacation and sick time also allows you to print reports 
for those jobs and update your employee records on a scheduled basis.

To create a job for vacation and sick time, go to Job Cost > Add/Edit > Job Informa-
tion. Enter a code and description for each job and click Save. Now, when you need 
to utilize the job, enter the job code on the time card just as you would any other job.

If you do not want to use jobs to track and pay vacation and sick time, you can also 
create a miscellaneous pay ADP for both vacation and sick time. This allows you to 
add additional pay to an employee’s paycheck when they utilize these benefits. To 
create an ADP for vacation and sick time, go to Payroll > Add/Edit > Deductions, 
Pays, Contributions. For more information about creating an ADP, see “Entering 
Deductions, Pays & Contributions” on page 71.

Calculating Payroll
If this is the first time you are calculating payroll, you must first set up your payroll 
posting accounts.

Setting up Payroll Posting Accounts
When setting up the posting accounts you will:

Setup the posting accounts for payroll expense, and
Specify how you wish to charge the payroll burden (i.e., the employer’s por-
tion of FICA, FUT and SUT). 
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TO SET UP PAYROLL POSTING ACCOUNTS:

1. Go to Payroll > Process > Payroll Calculation > Other Posting Accounts.

2. On the Wages & Withholdings tab, select the appropriate accounts for wages 
and withholdings to be debited from.

3. Click the Employer Taxes tab.
4. Select the appropriate accounts to deduct the employer taxes from.
5. Click the Non-Job-Related Overhead tab.
6. Select the account to debit non-job-related salaries from.
7. Click the Job-Related Overhead tab.
8. Make selections on this tab for how you want employer’s shares of taxes to 

post in relation to job expenses.
9. When you have finished, click OK.

Processing Payroll
Once your accounts have been set up you can run payroll and generate the Payroll 
Preview report.

TO PROCESS PAYROLL:

1. Go to Payroll > Process > Payroll Calculation.

2. If you want to process payroll for only certain employees, click All Employ-
ees, make your selections and click OK.
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3. In the Posting Date field, the system automatically fills in the processing date 
set in control information. Changing this date will change the date for the 
entire system.

4. In the Period starting date field, select a start date for this pay period.
5. In the Period ending date field, select an end date for this pay period.
6. In the Payroll bank account field, select the bank account you use to issue 

payroll checks.
7. In the Include sections, check the boxes for the types of employees you want 

to include in this payroll run.
8. When you have finished, click Calculate.

When the Calculate process is complete, review the preview report that is produced.

No postings are made until you actually print the checks so you can make any neces-
sary changes to the time cards, employee information, etc. and then recalculate. 

You can make changes and then recalculate as many times as necessary BEFORE you 
print the checks and therefore post the payroll.

Printing Checks and Posting Payroll
After you have calculated the payroll, use the Print Checks function on the Process 
Menu to print the paychecks. 

TO PRINT PAYROLL CHECKS:

1. Go to Payroll > Process > Print Checks.
The Print Payroll Checks Wizard appears.

2. Click Next.
3. The next screen shows how many checks need to be printed. You can change 

the check number if necessary. 
4. If you need to adjust the alignment of your checks, click Align Checks.

5. When you have finished, click Next.
6. Once your checks have printed, verify that they match the information on the 

next screen. 
7. If they did not print correctly, select that option on the screen and click Next.

Adjusting Check Printing

The first time you use the print program, you should print a check to plain paper 
and hold it up against an actual check form to check the position. If necessary you 
can shift the print position on the check until it is correct.

The default unit setting should be left as Twips. Start by entering 500Twips and 
click OK. Print a check on plain paper and hold up to an actual check form. If too 
high or low, modify the 500 by + or = - 50 Twips at a time, continuing to test on 
plain paper. Profit Builder® will save your setup.
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8. Enter the numbers of the failed checks and the new starting check number 
and click Next.

9. Print the checks again.
10. If the checks printed correctly, select that option on the screen and click Next.
11. Ensure that all of your checks have printed correctly and insert plain paper 

into your printer to print the GL reports.
12. Click Finish to post the checks to your accounts and print your reports.

When printing is complete, you will have a chance to examine the checks. If you need 
to run another set of check copies on plain paper, you must load plain paper and 
reprint the checks BEFORE you click on FINISH and therefore post the payroll. 
Checks cannot be reprinted after the payroll has been posted.

Voiding a Payroll Check

Any payroll check regardless of how it was generated can be voided. Voiding always 
generates reversing entries throughout Profit Builder in Payroll, Job Cost and General 
Ledger.

TO VOID A PAYROLL CHECK:

1. Go to Payroll > Process > Void Checks. 
2. Click OK to make the preprocessing backup.
3. Highlight the check you wish to void. 

To select multiple checks, hold down the Ctrl key and then click on the other 
check numbers.

4. You can temporarily override the Control Information Processing Date for the 
reversing entries by changing the Posting Date.

5. Click Void Check  when you are ready to void the selected checks.

The standard Job Cost and General audit trails will be printed automatically.

Note: Only the last check printed for each employee is shown. If you need to void a 
check from two check runs ago, you must first delete the last check before you can 
“see” the check you want to void. 
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Chapter

6
Accounts Receivable

This chapter offers step-by-step instructions for adding new customers, invoices 
and recording payments.

Accounts Receivable is used to record customer billings and payments, prepare cus-
tomer statements and generate the corresponding postings for General Ledger. If you 
bill customers periodically for a set amount, you can enter groups of recurring 
invoice items. Payments are tracked by customer and the program provides a journal 
report for collection follow-up.

During regular operation of the system, you will record billings and process them to 
add them to the Receivables Journal. Recurring invoices may be processed to add 
them to the Receivables Journal. Invoices and statements are printed from the 
Reports menu. Customer payments are recorded using the Quick Receipt function on 
the Process menu. A deposit slip will be printed along with an audit trail when you 
process the receipts.

At the end of the fiscal year for each company, the program will move the cumulative 
sales totals for your customers from “this year” to “last year” when you process the 
first invoice in the new fiscal year If you wish to roll customer totals, change the AR 
Year End Rollover option setting at Accounts Receivable > Add/Edit > Control 
Information > Receivables.
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Entering Customer Records
Customer information can be entered on-the-fly when starting a house, but it is good 
practice to enter customer information beforehand so that you do not feel rushed to 
research critical information when starting a house.

Rules for Assigning Customer Codes
Establishing rules for assigning codes to customers yields predictability, prevention of 
duplication, and logical ranging capability on reports.

Using the Customer Pick List
Before you add a customer, make sure that the customer record has not already been 
added. It is easy to search the customer list by both name and by code.

Go to Accounts Receivable > Add/Edit > Customers and click the search button 
next to the Code field. Click on the column heading "Customer" and the list will be 
sorted by the customer code.

You may sort on either the Customer Code or Name by clicking the appropriate col-
umn heading. The second click of the column heading reverses the order of the col-
umn. By default, the list is sorted by Name.

Using the search and the customer list makes it much easier to locate existing cus-
tomer records and prevent unwanted duplicate entries.

If the customer is Rule Example Code

A person Use the first six 
letters of his/her 
last name.

Bill Shocker SHOCKE

A company Use the first three 
letters of the first 
two words of the 
company name.

Ace Plumbing, 
Inc.

ACEPLU

You can type any letter to jump to that point in the customer list. Typing a letter 
shows a Find Name field in the customer list. Enter the customer name you are 
searching for in this field to determine if the customer record has already been cre-
ated.
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Creating New Customer Records

TO CREATE A NEW CUSTOMER RECORD:

1. Go to Accounts Receivable > Add/Edit > Customers.

2. In the Code field, enter the customer code as determined by your established 
coding rules. Note that the Customer Code is automatically capitalized as you 
enter it. Do not use special characters (& $ % , : * #, etc.) in your customer 
codes.

3. In the Job field, enter or select a job to associate with this customer.
4. In the Name field, enter the customer’s full name.
5. In the remaining fields on the Contact tab, enter this customer’s contact 

information. It is important to provide as much accurate information as possi-
ble. This information is used to contact the customer throughout the building 
cycle.
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6. Click the Payments and Notes tab.

7. In the Sales section, in the Invoiced Sales this year field, enter the dollar 
amount this customer has been invoiced this year. Profit Builder® continues to 
update this field.

8. In the Invoiced Sales last year field, enter the dollar amount this customer 
was invoiced last year.

9. In the Last invoice or pmt date field, enter the date of the last invoice or pay-
ment for this customer.

10. In the Payments section, select when this customer’s payments are due.
11. You can enter up to six lines of notes in the numbered fields below.
12. Click Save when you have finished. Cancel causes the information you have 

just entered to be discarded. Delete removes any customer you have called to 
the screen. An override code is required to delete an existing customer record.

Do not delete any customers that have accounting activity for the current year.
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AR Invoices
Accounts receivable invoices allow you to bill your customers for services and materi-
als used on their projects. With AR invoices you can keep track of how much is owed 
to you from your customers and track payments as they come in.

Entering New Invoices
Before you enter an invoice for a customer, you must first make sure the customer has 
a record in the system. See “Entering Customer Records” on page 93 for more infor-
mation on creating new customer records.

In control information, you can set preferences concerning how you enter invoices 
for your customers. Go to Accounts Receivable > Add/Edit > Control Information 
>Receivables to set these preferences. Under Automatically number invoices select 
how you want invoices to your customers to be numbered. 

Check the Use item catalog in AR invoices box to use your master catalog on cus-
tomer invoices. This option allows you to add specific items to your customer 
invoices. If you do not want to use this feature, you will enter all line-item informa-
tion on invoices by hand.

TO ENTER A NEW INVOICES:

1. Go to Accounts Receivable > Add/Edit > Invoices and Credit Memos.
2. In the Customer field, enter or select the code for the customer you want to 

enter an invoice for.
3. In the Invoice number field, if you do not use auto-numbering, enter a num-

ber for this invoice.

4. In the Job field, select or enter a job number for this customer. This field is 
optional.

5. The current processing date automatically fills in the Invoice date field. You 
can change this date if you like.
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6. The system automatically calculates the Due date from the invoice date and 
the information entered on the customer’s record. You can change the due 
date if you like.

7. The system automatically fills in the default Receivables Account. You can 
change this account if you like.

8. The system automatically fills in the default Sales Tax Account. You can 
change this account if you like.

9. In the Summary Description  field, enter a description for this invoice.
10. In the Amount field, enter the total amount for this invoice.
11. In the Adjustment field, enter any adjustment amounts that should be made 

to the invoice total. This amount in this field can be a positive or negative 
number.

12. If there is sales tax on this invoice, select the sales tax area in the Sales Tax to 
field. This percentage is automatically filled in and calculated. If you need to 
add a sales tax area, type the name in the field and click Yes when prompted to 
add the sales tax area. The Net Amount of the invoice is automatically calcu-
lated from the Amount, Adjustments and Sales Tax.

13. If you wish to enter line-items for this invoice, use the grid at the bottom por-
tion of the window to select items from your catalog or enter line items by 
hand. Line items are not required for an invoice. However, if you choose to 
enter line items, the total amount of line items entered must match the 
Adjusted Gross total for this invoice.

14. If you use your item catalog on invoices, in the Item column, select an item 
from your catalog.

15. In the Description column, enter a description for the item. If you select an 
item from your catalog the description automatically fills in.

16. In the Quantity column, enter the quantity for this item.
17. In the Unit column, enter the unit of measure for this item. For example, acre 

would be an appropriate unit of measure for land. If you selected an item from 
your catalog the unit is automatically filled in.

18. In the $Per column, enter the price per unit for this item. If you selected an 
item from your catalog the price is automatically filled in. The Total for this 
line item is automatically calculated.

19. In the Account column, select an income account for this line item.
20. Repeat steps 14–19 for each line item you want to add to this invoice.
21. When you have finished, click Save.

Credit Memos

The default setting for this entry screen is for an invoice. You can change the setting 
to credit memo by clicking the button next to Credit Memo on the right side of the 
window. When you change the setting to Credit Memo the background of the entry 
window changes color to remind you that this is a credit entry.
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Entering a Paid Invoice
Payment information for the invoice can be entered after you have completed the 
entry fields. (Remember, completion of detail invoice lines is optional).

Click on the Apply Payment button. The program will confirm that you wish to 
SAVE the invoice information and enter a payment for it. 

Next, the payment window displays. Complete the payment entry information and 
click Save.

Note: The Apply Payment window is available only when you enter a NEW invoice. 
You may record a full or a partial payment. Once the invoice has been processed, you 
cannot add or change payment information.

Use the Quick Receipt function to record a payment against a processed invoice. Use 
the Void Payment function to change or delete payments for a particular invoice.

For more information on payments, see “Recording Payments” on page 104.
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Editing Invoices
You can edit an unprocessed invoice at any time without requiring that the invoice be 
reposted to the general ledger. Once an invoice has been processed, if you edit the 
invoice you must reprocess it to post the changes to your general ledger.

TO EDIT AN INVOICE:

1. Go to Accounts Receivable > Add/Edit > Invoices and Credit Memos.
2. In the Customer field, enter or select the customer code for the invoice you 

want to change.
3. In the Invoice number field, enter or select the invoice number of the invoice 

you want to change.
4. Make any changes necessary to the invoice. Remember that any line items 

entered on this invoice must match the adjusted gross total shown at the top of 
the window.

5. When you have finished, click Save.

Changing or Deleting a Paid Invoice

When modifying the invoice amount for a partially paid item, the system will pro-
hibit you from reducing the invoice amount below the total paid on that invoice.

The system will prohibit you from deleting a paid invoice; you must first void all pay-
ments associated with that invoice and then delete it.

For more information on payments, see “Recording Payments” on page 104.

Processing Invoices
The process function posts invoice and credit memo information to the Accounts 
Receivable Journal and to General Ledger. You may wish to print the new or changed 
information and proof your entries before you process.

TO PRINT THE NEW ITEMS REPORT:

1. Go to Accounts Receivable > Reports > New Items.
2. A window appears detailing the contents of the report. Click Preview to view 

the report, click Print to print the report, or click Cancel to cancel the opera-
tion.

3. Review the items and make any changes necessary.

Once you have proofed any new items, you can process accounts receivable to post 
the new items and changes to your general ledger.
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TO PROCESS INVOICES AND CREDIT MEMOS:

1. Go to Accounts Receivable > Process > Invoices and Credit Memos.
2. Make your preprocessing backup. This allows you to backup your data before 

changing your general ledger with the processing.

3. In the Posting date field, the current system processing date is displayed. You 
may change it. Once changed, this becomes the posting date system wide. 

4. Click OK.

The system will post all new items to the General Ledger using the accounts specified 
on the individual invoices and credit memos. This process function also updates the 
Invoiced Sales This Year and Last Invoice or Payment Date fields in customer infor-
mation. The processing date is used to select invoices for the Reconciliation Journal 
report.
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Printing Invoices
You can print invoices at any time regardless of if they have been processed or not. 
Printing invoices allows you to deliver them to your customers.

TO PRINT INVOICES:

1. Go to Accounts Receivable > Reports > Invoices.
2. Enter the date you want printed on the invoices.

3. Click All Customers to filter the customers you want to print invoices for.
4. Click All Invoices to filter the specific invoices you want to print.
5. In the Select Invoices section, you can choose to print all invoices or enter a 

date range for the invoices you want to print. This is helpful if you print 
invoices at a regularly scheduled time. For example, if you print invoices once 
week you can enter the date range for the past week and print all of the 
invoices entered in the previous week.

6. Select the form you want to use for your invoices.
7. If you use the standard form, in the Standard Form Setup section, select if 

you are using a preprinted form with company information or blank paper. If 
you select blank paper, Profit Builder prints your company information on the 
invoice.

8. Under Invoice Message you can enter up to three messages to appear on the 
invoices you are printing now. This message only appears on the invoices 
printed in this batch. If you go back to print the same invoice again you will 
have to reenter the message for it to appear again.

9. Check the Show sales tax box to show sales tax on the invoices.
10. When you have finished, click Preview to preview the invoices, Print to print 

the invoices, or Exit to cancel and return to the main menu.
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Recurring Invoices
Recurring invoices are invoices that you send out on a regular basis, for example, an 
invoice for a monthly extended warranty fee. These invoices are entered and main-
tained separately from regular invoices. 

Invoices that are normally entered and processed at the same time may be assigned to 
a “group” (e.g., Monthly, etc.). Each item is assigned an Invoice ID for reference in the 
recurring invoice file. When you process recurring invoices, the system automatically 
transfers a COPY of each of the invoices in the selected group to the New Items file.

You supply a starting invoice number and an invoice date at processing time. The 
recurring items are then available for printing and processing in the usual manner.

TO ENTER A RECURRING INVOICE:

1. Go to Accounts Receivable > Add/Edit > Recurring Invoices.
2. In the Customer field, enter or select the customer code for this recurring 

invoice.

3. In the Item ID field, enter an ID used to distinguish this recurring invoice 
from other recurring invoices.

4. In the Group field, select a group for this invoice. For more information on 
recurring invoice groups, see “Recurring Invoice Groups” on page 103.

5. In the Job field, select a job for this invoice.
6. The system automatically fills in the default Receivables Account. You can 

change this account if you like.
7. The system automatically fills in the default Sales Tax Account. You can 

change this account if you like.
8. In the Summary Description  field, enter a description for this invoice.
9. In the Amount field, enter the total amount for this invoice.
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10. In the Adjustment field, enter any adjustment amounts that should be made 
to the invoice total. This amount in this field can be a positive or negative 
number.

11. If there is sales tax on this invoice, select the sales tax area in the Sales Tax to 
field. This percentage is automatically filled in and calculated. If you need to 
add a sales tax area, type the name in the field and click Yes when prompted to 
add the sales tax area. The Net Amount of the invoice is automatically calcu-
lated from the Amount, Adjustments and Sales Tax.

12. If you wish to enter line-items for this invoice, use the grid at the bottom por-
tion of the window to select items from your catalog or enter line items by 
hand. Line items are not required for an invoice. However, if you choose to 
enter line items, the total amount of line items entered must match the 
Adjusted Gross total for this invoice.

13. If you use your item catalog on invoices, in the Item column, select an item 
from your catalog.

14. In the Description column, enter a description for the item. If you select an 
item from your catalog the description automatically fills in.

15. In the Quantity column, enter the quantity for this item.
16. In the Unit column, enter the unit of measure for this item. For example, acre 

would be an appropriate unit of measure for land. If you selected an item from 
your catalog the unit is automatically filled in.

17. In the $Per column, enter the price per unit for this item. If you selected an 
item from your catalog the price is automatically filled in. The Total for this 
line item is automatically calculated.

18. In the Account column, select an income account for this line item.
19. Repeat steps 12–19 for each line item you want to add to this invoice.
20. When you have finished, click Save.

Recurring Invoice Groups

A group name is a tag that is used for selecting invoices for processing. Each invoice 
may be assigned to one group. 

To enter a group name, click Groups just above the Exit button. Enter a name on the 
list. To delete a group name, click in the column to the left of the group name to high-
light the name, then click on the Delete button.

Note: Deleting a group name does not delete any recurring invoices that were 
assigned to that group. In order to process those items, however, they must be 
assigned to another group.

Processing Recurring Invoices
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Processing recurring invoices transfers a COPY of all invoice items in one or more 
recurring invoice groups to the new items file. You specify an invoice date and a start-
ing invoice number.

For each invoice copied, the Invoice ID is replaced with an invoice number based on a 
starting number. This starting invoice number increments by one for succeeding new 
invoices in the group being processed. The program checks invoices already on file 
for each customer for duplicates.

The invoice date supplied at process time is inserted as the invoice date. If there is a 
payment default on file for the customer, the due date will be calculated from the 
invoice date; otherwise, the due date will be calculated by adding 30 days to the 
invoice date. 

Note: This function does not post the recurring invoices to the Accounts Receivable 
Journal or to General Ledger. You can print the New Items Report if you wish; then 
process them in the usual manner.

Recording Payments
When you receive payment from a customer for an invoice on file, you must record 
that payment in your general ledger. If you receive payment for which there is no 
invoice on file, use Add/Edit and enter an invoice as a PAID item. For more informa-
tion about entering paid invoices, see “Entering a Paid Invoice” on page 98.

TO RECORD A CUSTOMER PAYMENT:

1. Go to Accounts Receivable > Process > Receipts.
2. Make your preprocessing backup. This allows you to backup your data before 

changing your general ledger with the processing.
3. Select a deposit date for this payment.
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4. Select the bank account you want this money deposited into.
5. Click OK. The Receipt window opens.

6. Select the method of payment—Check, Cash or Credit Card.
7. If the payment method is check, enter the Check number and Check date. If 

the payment method is credit card, enter Credit card and Expiration date.
8. In the Received from field, select the customer you are recording a payment 

for. Only customers with open invoices appear in the list.
9. Enter the amount of the payment.
10. The customer’s open invoices appear in the grid below. In the This Payment 

column, enter the amount to apply to each invoice from this payment.
11. Click Process.
12. Repeat steps 6–11 for each payment you want to record.
13. When you have finished, click Exit.

The system automatically prints an audit trail. The payments will be posted to general 
ledger using the account information on the individual invoices.

Voiding Receipts
It may be necessary to void payments made to you by customers. When voiding a 
payment the system generates a reversing posting for the general ledger.

TO VOID A PAYMENT RECEIPT:

1. Go to Accounts Receivable > Add/Edit > Void Receipts.
2. Enter the override password.
3. Make your preprocessing backup. This allows you to backup your data before 

changing your general ledger with the processing.
4. Click in the left hand column to highlight the entire receipt line you wish to 

void. To select multiple receipts hold down the Ctl key while you select each 
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line. Remember, a single receipt may have been applied as a payment to more 
than one invoice.

5. When you have finished selecting receipts, click Void Receipts.
6. If you have selected multiple receipts to void, the program asks you to confirm 

each individual item.

The system creates reversing entries for these payments and the invoices are added 
back to the list of open invoices.

Printing Statements
You can print statements for your customers to keep them informed of their account 
activity and remind them when a payment is due.

TO PRINT AN ACCOUNTS RECEIVABLE STATEMENT:

1. Go to Accounts Receivable > Reports > Statements.
2. In the Statement Date field, select the date for the statements.
3. Select Standard form or  Specified form by user. 
4. If you have chosen to specify the form, in the Report field, enter the name of 

the report you want to use.
5. If you have chosen the standard form, select if you want company information 

printed or not.
6. Check the Include paid invoices box to include all activity on each account.
7. If you want to enter a statement message to print on each statement do so in 

the Statement Message section.
8. If you want to select specific customers, click All Customers and select the 

customers you want to print statements for.
9. Click Preview to preview your statements, Print to print the statements, or 

Cancel to cancel the reports.

Statements are an excellent way to keep your customers informed of the status of their 
accounts on a regular basis.
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Chapter

7
Draw Request

This chapter introduces you to the daily operations of residential and commer-
cial draws, such as, entering new contracts, releasing retainage, and issuing pay-
ment requests.

The Draw Request module is designed to assist you in providing a disbursement 
schedule for lenders and owners on a contract or job. There are two types of Draw 
Request that are available in this module—residential and commercial.

Residential draws are maintained in a loan journal and payment requests are issued 
in the form of accounts receivable invoices. Commercial draws are maintained with 
contract information and payment requests are issued with AIA G702/703 forms.

Residential draws do not allow for retainage and stored materials while commercial 
contracts do allow for these features. If available, you can use either of these methods 
to bill your clients regardless of whether or not the job is residential or commercial. 
The method you use depends on your needs and how the client prefers to be billed.

Residential Draws
Residential draws are tracked through the loan journal. You enter information about 
your customers and their financing in the loan journal and then add payment 
requests when you need funds from this financing.

Processing payment requests for residential draws generates an accounts receivable 
invoice. This allows you to send this invoice to your customer to receive payment.
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Adding a New Loan
You can enter information about the loans you use to finance your residential projects 
in the loan journal.

TO ENTER NEW LOAN INFORMATION:

1. Go to Draw Request > Add/Edit > Residential Draw.

2. In the Lender field, enter or select a lender for this loan.
3. In the Job field, enter or select a job for this loan.
4. In the Lender’s Loan ID field, enter the loan number the lender has assigned 

to this loan.
5. In the Description field, enter a description for this loan.
6. In the Draws Receivable field, select a default account for loan draws to be 

received in to.
7. In the Loans Payable field, select a default account for loans to be paid from.
8. In the Cash field, select a default cash account for this loan.
9. In the Loan Date field, enter the date for this loan.
10. In the Loan Amount field, enter the amount for this loan.
11. In the Initial Draw field, enter the dollar amount of the initial loan draw.
12. Check the Send to Accounts Receivable box if you want an AR invoice cre-

ated for each draw.
13. Click Save to save the information you have entered. Click Cancel to loose the 

information you entered. Click Delete to delete the current loan.

Once you have entered the loan information you can come back at any time to 
request additional draws.
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Requesting Residential Draws
Requesting a residential draw generates an accounts receivable invoice that you can 
then forward to the bank or customer. Accounts receivable invoices for residential 
draws are generated by adding the draw to the loan journal, saving the journal and 
then processing the request.

TO REQUEST A RESIDENTIAL DRAW:

1. Go to Draw Request > Add/Edit > Residential Draw.
2. In the Request number field, enter the number for this request.
3. In the Request date field, enter the date for this request.
4. Fill in the start and end date for the period this draw applies to.
5. In the Item column below, enter the item number for your first draw item.
6. In the Description column, enter a description for this item.
7. If this item is a change order, enter the order number in the C/O column.
8. In the Value column, enter the value for this item.

The % Loan column fills in automatically with the percentage of the entire 
loan.

9. In the Previous Total column, enter the amount of any previous draws made 
on this item.

10. In the This Request column, verify or change the amount to request for this 
item in this draw.
The This % column fills in automatically with the percentage of this draw you 
are requesting.

11. The Balance column shows if the item is over budget or out of balance.
12. Make any notes in the Notes column.
13. When you have finished with this line, press Tab to go to the next line.
14. Repeat steps 5–13 for each line you want to add.
15. When you have finished adding lines, click Process to process the requests 

and generate accounts receivable invoices.

Commercial Draws
Contract information is maintained on file, providing the basis for the actual draw or 
payment request, also referred to as the “Application and Certificate for Payment.”

The contract is an agreement to pay for specific work items (pay items) at a specific 
price or scheduled value. As the work is performed, job progress is recorded for the 
individual pay items and a request for payment is produced in a format similar to that 
of the AIA (American Institute of Architects) G702/703 forms. 

A receivables invoice can be created automatically for each draw. Payments on the 
related invoice are then recorded and tracked in the Accounts Receivable module.
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Setting Up Commercial Contracts
When setting up commercial contracts, there are a few approaches that can be taken 
to ensure that all pay items are entered correctly. You can enter a new contract com-
pletely from scratch for any contract that is brand new. 

You may also want to clone an existing contract if your new contract has similar pay 
items. You can then edit your new contract and make any changes necessary. Cloning 
an existing contract is often a valuable time-saver when entering new contracts.

You may find it necessary to create contracts that are already in progress. In that case 
there are a few special steps involved to ensure that contract events that have already 
occurred are recorded properly.

The sections below outline how to create a new contract from scratch, enter an in-
progress contract and clone an existing contract.

Creating a New Commercial Contract

If you already have a contract on file, that you wish to use as a template for a new con-
tract, see “Cloning an Existing Commercial Contract” on page 114. 

TO CREATE A NEW COMMERCIAL CONTRACT:

1. Go to Draw Request > Add/Edit > Commercial Draws.
2. In the Customer field, enter or select the customer ID associated with this 

contract. This field is required.

3. In the Contract ID field, enter a code to identify this contract. The code can 
be up to 6 alphanumeric characters. This field is required and used in all pick 
lists to identify this contract.
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4. In the Job field, enter or select the job associated with this contract. If there is 
a default job on file for the customer selected, the ID appears here automati-
cally.

5. In the Contract date field, enter a date for this contract. Profit Builder auto-
matically enters the current processing date, you may change this if necessary. 
This information is on the G702 report and is required.

6. In the Project No. field, enter the architect’s project number associated with 
this contract. This field is required.

7. In the Architect field, enter or select the vendor code for the architect on this 
project. If the vendor is not yet on file, you can enter vendor information in 
the window that pops up. This information is presented on the G702/703 
reports.

8. In the Application No. field, the system automatically inserts “1" for the 
application (or payment request) number. Once you process a payment 
request, the system automatically increments this application number by one 
in anticipation of the next request. If you are setting up a contract already in 
progress, you can override this number.

9. In the Period field, enter the to and from dates to be used for payment 
requests. Typically, this is by month (see the AIA G702 form). As you enter 
successive payment requests, you will need to update this field. This is a 
required field.

10. In the Due date field, enter the date specified in the contract for job comple-
tion. This is a required field.

11. In the Retainage rate for WIP field, enter the retainage rate for work in 
progress. This rate is entered as a percentage.

12. In the Retainage rate for stored mat’ls field, enter the retainage rate for mate-
rials that have been ordered and received but have not yet been put to use on 
the building site. This rate is entered as a percentage. For more information on 
retainage and contracts, see “Commercial Contract Retainage” on page 112.

13. Check the Send information from this Contract to Accounts Receivable 
box to have payment request information sent to AR in the form of customer 
invoices. For more information about linking to accounts receivable, see 
“Accounts Receivable Link” on page 113.

14. In the Description field, enter a description for the contract. This description 
appears on the Commercial Draw Information report and identifies this con-
tract on pick lists.

15. In the GL Accounts section, enter the GL numbers for the accounts to be used 
for posting related receivables invoices—Receivables, Cash, Sales Tax, Retain-
age and Income.

Be very careful to enter the correct application number. Once you process the first 
payment request, you cannot change the application number.

Note: You are required to enter valid GL accounts for each of these fields even if 
the Accounts Receivable link is off.
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16. The spreadsheet type entry grid in the lower portion of the contract window is 
used for defining the individual pay items that make up the contract. 
In the Item No. column, enter a unique item number for each pay item.

17. The CO column is used to differentiate between base (or original) contract 
items and change orders so that they can be reported correctly on the G702 
report. Leave this field blank—but do not enter 0—if the pay item you are 
entering is part of the base (or original) contract. If the item is a change order, 
enter a number greater than 0.

18. In the Status column, enter the status of this pay item. When you enter a new 
pay item, either for the base contract or a change order, the status flag is auto-
matically set to N for new. When you process the next payment request, the 
status flag is reset to A for approved. The system uses the status flag to deter-
mine which change orders were added during the period specified for a pay-
ment request for reporting on the G702 report.

19. In the Description of Work column, enter a short description of the pay item.
20. In the Scheduled Value column, enter the contract amount for this pay item.

The remaining columns in this spreadsheet are used after the initial contract 
information is entered. Negative numbers may be entered.

21. Repeat steps 16–20 for each of the pay items for this contract.
22. When you have finished, click Save.

Stored Materials versus Work-in-Place (WIP)

Stored materials are materials that have not been installed at the site but have been 
delivered and paid for. These materials are often stored, either on or off the site, until 
they are needed for installation in the project.

Stored materials typically carry a different retainage rate than WIP. Usually the 
retainage is half that of WIP or even nothing at all. When stored materials are placed 
into the project, the amount of stored materials should be reduced and the WIP for 
that period should increase. However, another payment for these used materials will 
not be generated because the stored materials have already been paid for.

Commercial Contract Retainage
When you process a payment request, retainage may be withheld at different rates for 
work-in-place (WIP) versus stored materials. When you enter payment request infor-
mation, these percentages are used to calculate the retainage on each line item.

When the Accounts Receivable link is on, an invoice is automatically created for each 
payment request that you process. The numbering convention for a contract billing 
invoice created in this manner is: CBddddddnn where dddddd is the contract ID and 
nn is the payment request number. 

The first time you process a payment request for a contract, the system also creates a 
single retainage invoice that is used to track the retainage for the contract. The con-
tract retainage invoice number is CBdddddd00, where dddddd is the contract ID and 
00 indicates that it is the retainage invoice.
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Retainage withheld on subsequent payment requests is added to this invoice; likewise, 
as you release retainage, the retainage reduction is subtracted from it. At the end of 
the contract, when all retainage has been released, this invoice should have a 0.00 bal-
ance.

Releasing Retainage

In order to release retainage on subsequent payment requests, you reduce the retain-
age percent (for WIP and/or Stored Materials) when you enter the payment request 
information. The retainage reduction amount is then billed on that payment request. 
At the end of the contract, enter 0.00% to release all retainage.

To partially release retainage, you must move from globally tracking retainage to 
tracking it by individual line items. When you attempt to partially release retainage, 
you get a warning asking if you want to do this and stating that you can no longer use 
global retainage. After agreeing, you must manually calculate retainage for each line 
when you make a change. If you do not manually calculate retainage, the system will 
add no retainage for new work and your contract will calculate incorrectly.

Accounts Receivable Link

When your contracts are automatically linked to accounts receivable, the system cre-
ates a receivables invoice when you process a payment request in Draw Request. The 
AR invoice is then used to record and track payments. In addition the program cre-
ates one retainage invoice for each contract. For more information on the retainage 
invoice, see “Commercial Contract Retainage” on page 112. This invoice is used to 
record retainage throughout the life of the contract and should have a zero balance at 
contract completion when all retainage has been released.

When setting up a contract that has already had draws against it, turn the Receivables 
link on and enter a single payment request reflecting all draws to date. Assuming that 
you have already billed the draws to date, go to Accounts Receivable and delete the 
invoice associated with the payment request. DO NOT delete the contract retainage 
invoice. You must process this invoice to reflect changes in retainage and reverse the 
general ledger postings from this invoice. For more information about contracts in 
progress, see “Commercial Contracts In Progress” on page 113.

Commercial Contracts In Progress
A commercial contract in progress is a contract that has already had draws (or pay-
ment requests) made against it. The process for setting up this type of contract is sim-
ilar to creating a new contract but there are a few extra steps that should be included.

TO SET UP A CONTRACT IN PROGRESS:

1. Enter the basic contract information by following the steps on page 110 for 
creating a new contract. Be sure to turn the Accounts Receivable link on.

2. In the Application No. field, set the payment request number to the last pay-
ment request made.
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3. In the pay items section, enter the total work-in-place and stored materials 
amounts to date for each pay item.

4. Enter the total retainage withheld to date.
5. Click Save.
6. Go to Draw Request > Reports > Commercial Payment Request to print the 

G702 and G703 reports and check your entries.
7. Go to Draw Request > Process > Commercial Draw to process the payment 

request.
8. Go to Accounts Receivable > Add/Edit > Invoices and Credit Memos, select 

the customer and click the search button next to Invoice number. 
You will see two invoices related to the processed payment request:
• CBdddddd00, where dddddd is the contract ID and 00 indicates that this is the 

contract retainage invoice, and
• CBddddddnn, where dddddd is the contract ID and nn is the payment request 

number.
9. Delete only the invoice for the cumulative to date payment request since you 

have already invoiced these draws. DO NOT, however, delete the contract 
retainage invoice. That invoice is used to track the retainage for the remainder 
of the life of the contract.

10. Using the general ledger audit trail as a reference, reverse the GL postings 
with a journal entry.

11. Subsequent payment requests can be entered and processed in the usual man-
ner. For more information about making payment requests, see “Commercial 
Payment Requests” on page 116.

Cloning an Existing Commercial Contract
You can use an existing contract as a pattern or template for a new contract. This can 
greatly reduce the data entry time necessary to enter new contracts.

TO CLONE AN EXISTING COMMERCIAL CONTRACT:

1. Go to Draw Request > Add/Edit > Clone Commercial Draw.

2. In the Old Contract section, select the customer and contract you want to 
clone.
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3. In the New Contract section, select the customer you want the new contract 
created for. If this customer has a default job, it automatically appears in the 
Job field.

4. In the Contract ID field, enter a contract ID for the new contract.
5. Change orders on the old contract will be copied by default. Clear the Include 

Change Orders box if you wish to copy without the change orders.
6. Click Process to create the new contract. You can then select the contract and 

make any necessary additions and/or corrections.

Change Orders
Change orders—positive or negative—may be added to the contract at any time as 
individual pay items on the base contract. A change order is identified with an entry 
in the CO field. The program tracks change orders entered in the current payment 
request period in accordance with the AIA G702 form requirements.

Change orders are shown separately on the G702 and G703 reports. The G702 report 
shows the total change orders for each period, while the G703 report subtotals the 
change orders by group and then shows the total for each period.

TO ADD A CHANGE ORDER TO A COMMERCIAL CONTRACT:

1. Go to Draw Request > Add/Edit > Commercial Draws.
2. Select the contract you want to add to.
3. Select the next available line in the spreadsheet grid of pay items.
4. Enter a unique item id.
5. Enter a unique change order number in the CO column.
6. In the Status column, enter N to indicate this change order is new in this 

period.
7. Enter a scheduled value for this change order. It can be a positive or negative 

value.
8. When you have finished, click Save.

When you process the next payment request for this contract, the change order status 
is automatically be changed to A for Active regardless of whether or not funds have 
been requested for that item. All change orders entered during the current period are 
reported as such on the G702 and G703 reports.
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Commercial Payment Requests
Payment or Draw Request for commercial projects are entered by recording job 
progress information for individual pay items and change orders. You can then print 
the G702 and G703 format reports and process the payment request to create the 
receivables invoice. 

Recording Progress

In order to begin issuing a payment request, you must record the progress on the con-
tract. The amount of the payment request is determined by the progress that has been 
made on the contract.

TO RECORD COMMERCIAL CONTRACT PROGRESS:

1. Go to Draw Request > Reports > Commercial Work Sheet to print a Pay-
ment Request Worksheet. This worksheet uses the G703 format, showing the 
current status of the contract, including the scheduled value for base contract 
items and change orders, along with previous WIP amounts and any stored 
materials.

2. Record the job progress information in the blank WIP This Period and 
Retainage fields.

3. Go to Draw Request > Add/Edit > Commercial Draws and call up the con-
tract. Note that the Application No. automatically increments by one each 
time you process a payment request; therefore the number displayed should 
be the one for the next payment request.

4. In the Period field, enter the start and end dates covered by this payment 
request.

5. Enter job progress information for individual pay items (including change 
orders) by entering a dollar amount in the WIP this Period column or a per-
centage in the % column.

6. If you have Stored Materials (i.e., materials on the job site but not yet 
installed), enter as a dollar amount in the Stored Materials column.

7. When you have finished entering all the progress information, click Save.

Note: When you process a payment request, the stored materials amount is not 
moved to the Previous WIP column. When the materials have been installed, you 
must take that amount out of the Stored Materials column and add it to the WIP 
this Period field for that payment request.
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Printing Commercial Payment Request Reports

Once you have entered the progress information into the contract, you must print the 
G702 and G703 payment request reports in order to process the payment requests.

TO PRINT COMMERCIAL PAYMENT REQUEST REPORTS:

1. Go to Draw Request > Reports > Commercial Payment Request.
2. In the Select Form field, select the form(s) you want to print. If you want to 

first preview the forms, you must choose a single form. If you want to print 
both forms you can choose BOTH.

3. Click All Customers to select which customers you want to print these 
reports for.

4. Click All Contracts to select which contracts you want to print these reports 
for.

5. On the printed forms, proof the progress information you have entered to 
ensure it is correct.

Processing a Commercial Payment Request

Once you have recorded progress, printed your G702 and G703 reports and proofed 
your entries, you are ready to process the payment request.

TO PROCESS A PAYMENT REQUEST:

1. Go to Draw Request > Process > Commercial Draw.
2. Back up your business information to your hard drive.
3. In the Processing Date field, select the date you want this payment processed. 

Your current working date is automatically entered in this field. Changing the 
date changes your current working date.

4. Clear any check boxes next to contracts you do not want processed.
5. Click Process.
6. Click Yes for the warning message that reminds you to print the payment 

request reports.
7. Your reports will print and if the accounts receivable link is on, the system 

notifies you that new invoices have been created for this payment request.

The process function does the following:

Moves the WIP This Period amounts to the Previous total column.
When the accounts receivable link is on, it creates a new receivables invoice 
for the payment request. The format for that invoice number is CBddddddnn 
where dddddd is the contract id and nn is the payment request number.

Caution: You must print these reports BEFORE you process. This information is 
not available for reporting once you have processed the payment request.
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Note: The first time you process a payment request, the system also creates a special 
invoice that is used to track retainage. For more information on contract retainage, 
see “Commercial Contract Retainage” on page 112.

If the accounts receivable link is on, you can then go to Accounts Receivable > Pro-
cess > Invoices and Credit Memos to process your new invoices.

Voiding a Commercial Payment Request

Only the last processed payment request can be voided. Voiding a payment request is 
a two step process consisting of deleting the accounts receivable invoices and voiding 
the payment request in Draw Request.

TO DELETE THE ACCOUNTS RECEIVABLE INVOICES:

1. Go to Accounts Receivable > Add/Edit > Invoices and Credit Memos.
2. In the Customer field, select the customer whose invoice you want to delete.
3. In the Invoice field, select the corresponding invoice to the payment request 

you want to delete. (i.e. CBddddddnn, where dddddd is the contract ID and 
nn is the payment request number). 

4. If either invoice has been processed in Accounts Receivable, you must delete 
the invoice and then process new items to create the reversing postings.

TO VOID A COMMERCIAL PAYMENT:

1. Go to Draw Request > Add/Edit > Commercial Draws.
2. Pull up the contract you want to void a payment for.
3. Click Void Payment to void the last posted payment.
4. Click Save.

The previously recorded progress information is removed from the contract and any 
recorded retainage is removed from the retainage invoice.

Removing Completed Commercial Contracts
The Remove Commercial Draw function allows you to delete contracts that have 
been completed.

TO REMOVE A COMPLETED COMMERCIAL CONTRACT:

1. Go to Draw Request > Add/Edit > Remove Commercial Draw.
2. In the Customer field, select the customer you want to remove a contract for.
3. In the Contract ID field, select the contract you want to remove.

The remaining fields are filled in automatically.
4. To remove the contract, click the Delete button.

Note: A contract must be completed before you can remove it.
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Reports
The following reports are available to help you maintain your commercial and resi-
dential Draw Request information, collect progress information and make payment 
requests.

Commercial Draw Information
This report displays the customer and contract information, including contact infor-
mation, job, contract value and balance, and general ledger accounts.

TO PRINT THE COMMERCIAL DRAW INFORMATION REPORT:

1. Go to Draw Request > Reports > Commercial Draw Information.
2. Click All Customers to select the customers you want included on this report.
3. Click All Contracts to select the contracts you want included on this report.
4. Check the Show Contract List Only box if you just want to print a list of your 

open contracts without any details.
5. Click Preview to preview the report before printing. Click Print to print the 

report. Click Cancel to return to the main menu.

Commercial Payment Request
The program produces an AIA G702 format cover sheet and G703 format continua-
tion sheet for selected, unprocessed payment requests.

TO PRINT COMMERCIAL PAYMENT REQUEST REPORTS:

1. Go to Draw Request > Reports > Commercial Payment Request.
2. In the Select Form field, select the form(s) you want to print. If you want to 

first preview the forms, you must choose a single form. If you want to print 
both forms you can choose BOTH.

3. Click All Customers to select which customers you want to print these 
reports for.

4. Click All Contracts to select which contracts you want to print these reports 
for.

5. On the printed forms, proof the progress information you have entered to 
ensure it is correct.

You can use Add/Edit to make any necessary changes to the payment request prior to 
processing.

Caution: Once processed the payment request information is no longer available 
for printing, as the WIP amounts have been moved to the Previous Period column.
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Commercial Work Sheet
The commercial work sheet is designed to help you record project progress so that it 
can be entered to generate a payment request. This report is a G703 format report 
that shows the current scheduled value, Previous Work-in-Place and Stored Materials 
with blanks for the This Period information.

TO PRINT A COMMERCIAL WORK SHEET:

1. Go to Draw Request > Reports > Commercial Work Sheet.
2. Click All Customers to select the customers you want included on this report.
3. Click All Contracts to select the contracts you want included on this report.
4. Click Preview to preview the report before printing. Click Print to print the 

report. Click Cancel to return to the main menu.

Residential Draw Journal
The residential draw journal shows a list of your current residential loans. This report 
is helpful in tracking the number of requests that have been made on each loan and 
outstanding draws.

TO PRINT A RESIDENTIAL DRAW JOURNAL:

1. Go to Draw Request > Reports > Residential Draw Journal.
2. Select how you want the report sorted—by lender or community.
3. Enter a date range for draws to include on the report.
4. Click All Lenders to select the lenders you want to include on this report.
5. Click All Communities to select the communities you want to include on this 

report.
6. Click Preview to preview the report before printing. Click Print to print the 

report. Click Cancel to return to the main menu.
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Chapter

8
Purchasing & Production Building

This chapter offers step-by-step instructions for entering your plans, adding 
them to communities and starting a new house.

Developing a New Plan
The ability to control your building cycle begins with defining the homes you build. 
This includes all of the parts used in each of the different elevations and options. 
Every time you add a new plan to your product line, you must go through a series of 
steps to define the elevations and options for that plan.

Each option is listed and analyzed to determine if it conflicts with any other options 
or if it requires additional options or elevations. It is very important to accurately list 
and organize all the parts and work make up each elevation and option.

These definitions are then used for the framework to price the plans in each commu-
nity. Once these tasks are complete, you are ready to enter your new house starts.

Defining the Structure
Defining the plan structure consists of organizing what the builder does in the order 
of how the owner buys. This is different from the normal estimating process which 
follows the building sequence or the division list of homogeneous work.

First, the estimate must be made in terms of work packages—a work package is a 
group of materials or subcontract work that can be delivered/performed by one ven-
dor without interruption. Work packages become purchase orders and scheduling 
activities.

Many times a plan has several different elevations and the estimate must include all 
work packages that are common (i.e. the core) to every elevation and also every pack-
age that is unique to each individual elevation. The term elevations means the front 
and sides that can be changed to give the plan a different appearance. 
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In addition to elevations, many plans have options for features available at an addi-
tional charge. These options must also be broken into work packages. Materials must 
be taken off (counted) for each material work package and subcontractors are 
instructed to bid in this manner. By organizing the job into work packages, the take-
off and bidding process is simplified.

Below is an example of how to list the packages for two different options—a 3 sided 
fireplace and 8 inch columns in the master suite.

Option Code Description Activity ID Description Vendor ID

06MBRFP 3 sided FP

06MBRFP 3 sided FP 3000 Dlvr Framins Pkg 84LUUM

06MBRFP 3 sided FP 3015 Framing Sub WPBCOM

06MBRFP 3 sided FP 3250 Fireplace Inst. DAVINS

06MBRFP 3 sided FP 3300 Roofing Sub TAYMNR

06MBRFP 3 sided FP 3600 Dlvr Siding, Shutters & 
Cornice

TAYMNR

06MBRFP 3 sided FP 3620 Install Siding & 
Shutters

TAYMNR

06MBRFP 3 sided FP 5125 Inst Fireplace 
Surround

DAVINS

06MBRFP 3 sided FP 5110 Dlvr Int Trim 84LUUM

06MBRFP 3 sided FP 5130 Inst Interior Trim TRIMSP

06MBRFP 3 sided FP 5400 Interior Paint DEPPAI

06MBRFP 3 sided FP 6210 Carpet ABBEYC

07COLSTE 8 in Cols-Suite

07COLSTE 8 in Cols-Suite 5110 Dlvr Int Trim 84LUUM

07COLSTE 8 in Cols-Suite 5130 Inst Interior Trim TRIMSP
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Determining Prerequisites, Conflicts & Suggestions
Once you have all elevation and option packages listed, you need to put together rules 
for selecting packages. 

There are three sets of rules to consider:

Prerequisites – Options or elevations that are required in order to select the 
desired option. You cannot have the Raised Hearth option unless you have 
already selected the Fireplace option.
Conflicts – Options that cannot both be selected. You cannot have both the 
Granite Tops and the Solid Surface Tops.
Suggestions – Options which are normally selected with another option. 
Basement Windows Triple Glazed is suggested when Main House Triple 
Glazed Windows option is selected.

When selecting your elevations and options, the program highlights suggested 
options in green and conflicts in red.

Once you have your list of work packages, you need to assign the default vendors. 
When you place a plan into a community for local pricing, you can still change ven-
dors and pricing.

Creating a New Plan
When you have assembled all of the information about the plan you can create a new 
plan in Profit Builder®.

TO CREATE A NEW PLAN:

1. Go to Purchasing > Add/Edit > Plan Takeoff. All plans on file are displayed.
2. Right-click the word Plan and select New Plan.
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3. In the Code field, enter a short name for this plan.
4. In the Name field, enter the name for this plan that you want to see in the 

Plans menu and on reports.
5. In the Scope field you can enter information to further identify this plan. This 

information is not available when starting a new house but does appear on 
this screen for anyone modifying this plan. The information entered here is 
for internal use only.

6. Click Exit and save your work.

Your new plan is now created. You can now return to the plan and add the main orga-
nizational structure—elevations and options. 

It takes some thought and planning to properly organize the structure of the house. 
The Elevations section should contain a list of elements that are required for con-
struction. 

For example, you must have one front elevation and one foundation. The different 
types of foundations (slab, crawl, basement) should therefore be placed in the eleva-
tions area. Elements placed in the Options section are not required to build the house 
and may be ignored by the person creating a new property.

Adding Elevations
It is not required that all elevations, foundations, and options be added during the 
initial plan creation process. You may come back at any time and add these elements. 
If you are using this plan in different communities, the added elements appear auto-
matically in each community.

TO ADD ELEVATIONS TO A PLAN:

1. Go to Purchasing > Add/Edit > Plan Takeoff.
2. A window opens with a list of the available plans. Check the box next to the 

plan you want to add elevations to and click These Plans.
3. Expand the tree under the plan by clicking the plus sign next to the name of 

the plan to reveal the Base and Options.
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4. Right-click Base and select New Elevation.
The first elevation you should add to any new plan is the CORE elevation. 
This elevation includes all work packages that will be included in every house.

5. In the Code field, enter a short identifier for this elevation.
6. In the Name field, enter the name for this elevation. The name should be clear 

so that the elevation can be selected without confusion when starting a new 
house. 
All elevations and options are sorted alphabetically by this name.

7. In the Scope field you can enter information that helps further identify this 
elevation. This information is not available when starting a new house but 
does appear on this screen for anyone modifying this plan. The information 
entered here is for internal use only.

8. In the conflicting items field, enter the codes for any elements that conflict 
with this elevation. You can also click Browse next to this field to choose from 
a list of all elements. If conflicting items are selected, both items appear red 
when starting a new house.
For more information on conflicting items, see “Determining Prerequisites, 
Conflicts & Suggestions” on page 123.

9. In the prerequisites field, enter the codes for any elements that are required 
for this elevation. You can also click Browse next to this field to choose form a 
list of all elements. 
For more information on prerequisites, see “Determining Prerequisites, Con-
flicts & Suggestions” on page 123.

10. In the optional links field, enter the codes for any elements that are recom-
mended when this elevation is selected. Any recommended elements appear 
green when this elevation is selected for a new house.
For more information on recommendations, see “Determining Prerequisites, 
Conflicts & Suggestions” on page 123.

11.  When you have finished, click Exit and save your work.
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Continue to add all your foundations and elevations in this manner. Be sure that you 
enter an element for the core elevation—this includes everything that is required but 
not present in the other elevations and foundations.

Adding Options
Once you have added your elevations, it is time to add options. Options are additional 
features that are often offered to upgrade a house. Options may be added later if you 
do not have them fully designed. It is important to realize that subcontractors and 
material suppliers must have enough information to bid on the work packages that 
you are specifying.

TO ADD OPTIONS TO A PLAN:

1. Go to Purchasing > Add/Edit > Plan Takeoff.
2. A window opens with a list of the available plans. Check the box next to the 

plan you want to add options to and click These Plans.
3. Expand the tree under the plan by clicking the plus sign next to the name of 

the plan to reveal the Base and Options.
4. Right-click Options and select New Option.
5. In the Code field, enter a short identifier for this option.
6. In the Name field, enter the name for this option. The name should be clear so 

that the option can be selected without confusion when starting a new house. 
All elevations and options are sorted alphabetically by this name.

7. In the Scope field you can enter information that helps further identify this 
option. This information is not available when starting a new house but does 
appear on this screen for anyone modifying this plan. The information 
entered here is for internal use only.

8. In the conflicting items field, enter the codes for any elements that conflict 
with this option. You can also click Browse next to this field to choose from a 
list of all elements. If conflicting items are selected, both items appear red 
when starting a new house.
For more information on conflicting items, see “Determining Prerequisites, 
Conflicts & Suggestions” on page 123.

9. In the prerequisites field, enter the codes for any elements that are required 
for this option. You can also click Browse next to this field to choose form a 
list of all elements. 
For more information on prerequisites, see “Determining Prerequisites, Con-
flicts & Suggestions” on page 123.

10. In the optional links field, enter the codes for any elements that are recom-
mended when this option is selected. Any recommended elements appear 
green when this option is selected for a new house.
For more information on recommendations, see “Determining Prerequisites, 
Conflicts & Suggestions” on page 123.

11.  When you have finished, click Exit and save your work.

Once the structure is in place, it is time to enter the work packages and their compo-
nents for both elevations and options.
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Adding Work Packages
A work package is a group of materials or subcontract work that can be delivered/
performed by one vendor without interruption. Once you have created new work 
packages for your elevations and options, you can add catalog items to the work pack-
ages.

TO ADD WORK PACKAGES TO A PLAN:

1. Go to Purchasing > Add/Edit > Plan Takeoff.
2. A window opens with a list of the available plans. Check the box next to the 

plan you want to add work packages to and click These Plans.
3. Expand the tree under the plan by clicking the plus sign next to the name of 

the plan to reveal the Base and Options.
4. Expand the tree again to reveal your elevations and options.
5. Right-click the option or elevation you want to add to and select New Pack-

age.

6. In the Code field, enter a short identifier for this package.
7. In the Name field, enter the name for this package. 
8. In the Scope field you can enter information that helps further identify this 

package. This information is printed on purchase orders. The information 
entered here should be used to provide contractors and suppliers special 
instructions about the work package.

9. In the Vendor field, select a default vendor for this work package.
You can change this later if necessary.

10. In the Category field, select a default category for this work package.
You can change this later if necessary. Job cost categories cannot be added to 
any plan until they have been added in a template at Job Cost > Add/Edit > 
Job Information. For more information on adding categories, see “Master Job/
Category Sets” on page 58.

11. In the Class field, enter a default class for this work package.
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12. In the Activity field, select a default activity for this work package.
You can change this later if necessary.

13. Check the TBD PO box if this package should create a To Be Determined 
purchase order. For more information on TBD POs, see “Special Purchase 
Orders” on page 154.

14. Click Show Detail Lines to add catalog items to this work package.
You can add catalog items now or later. See below for step-by-step instruc-
tions for adding catalog items to work packages.

15. When you have finished, click Exit and save your work.

Your work package is now created and added to your plan. Work packages are made 
up of line items from your main catalog. If you did not add items when you created 
the work package or if you need to add additional items, follow the instructions below 
to add items to your work package.

TO ADD ITEMS TO YOUR WORK PACKAGES:

1. Go to Purchasing > Add/Edit > Plan Takeoff.
2. A window opens with a list of the available plans. Check the box next to the 

plan you want to modify and click These Plans.
3. Expand the tree under the plan by clicking the plus sign next to the name of 

the plan to reveal the Base and Options.
4. Expand the tree until you can see the work package you want to add items to.
5. Click on the work package you want to edit.
6. If the Properties for this work package are displayed, click Show Detail Lines 

to display the line items associated with this work package.
7. In the Item Code column, enter or select an item code for the line item.

Click the arrow to search for your item in the main catalog.
8. If the item code you enter is not already stored in your main catalog the sys-

tem prompts you to create the item. If you want to add the item, select Yes.
9. In the Add Item to Catalog window, enter or verify the division, description, 

category, class, unit description, unit cost, and unit tag for this item.

10. Click OK.
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11. If your item is already in the catalog the information in the remaining col-
umns is automatically filled it according to the item record and the work 
package defaults. In the Quantity column, enter the quantity of this item that 
is necessary for this work package.

12. If you need to change any default information, select the information in the 
appropriate column and make your changes.

13. Continue to add items to this work package and other packages.
14. When you have finished, click Exit and save your work.

Once items are added to the work packages your plan is complete and ready to price 
for your communities.

Costing a Plan
When a plan is finished being entered in the system, you must then place the plan 
into the community where it is to be built. In order to do this, the communities must 
be created in Profit Builder®.

TO ADD A COMMUNITY RECORD:

1. Go to Job Cost > Add/Edit > Community Names.
2. In the Community column, enter a 2 character code to identify the commu-

nity. This code becomes a part of each Job ID that is built in the community.
For example, if the community’s name is Roswell Downs, RD would be an 
appropriate code to identify the community.

3. In the Name column, enter the name of the community.
4. In the Sales Tax % column, enter the sales tax for this community.
5. When you have finished, click OK.

When your communities are entered in Profit Builder®, you can then make plans 
available in those communities and set up plan pricing.

Adding Plans to a Community
With your community added and your plans defined, you can now add the available 
plans to your communities and price them accordingly.

TO ADD A PLAN TO A COMMUNITY:

1. Go to Purchasing > Add/Edit > Plan Costing.
2. A window appears with the available communities listed. Check the box next 

to the communities you want to work with. If the community you want is not 
listed, check any other community and click These Communities.

3. The Plan Costing window appears with a tree listing all the available commu-
nities. If the community you want is not listed, right-click Communities at the 
top of the tree, select New Community. Find the community you want to add 
and click OK.

4. Right-click the community you want to add to and select New Plan.
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5. Select the plan you want to add and click OK.
6. When you have finished adding plans, click Exit and save your work.

The plans you have added are now available in those communities. You can now 
select those plans when starting a new house in a community.

Starting a New House
When you start a new house in Profit Builder®, you use the communities and plans 
that have already been entered in the system. You also enter information about the 
job, customer and loan for this property.

Once you have started the house and made all the specifications for the property, 
Profit Builder® automatically creates the POs and budgets for the entire job.

TO START A NEW HOUSE:

1. Go to Purchasing > Process > Start a House.
A window appears listing all the communities and the available plans within 
those communities. 

2. Find the community you are building this new house in and locate the plan 
you want to use. Check the boxes next to the elevations and options you want 
to use. For example, begin by checking Core because every house contains the 
core elevation.
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3. When you have finished selecting elevations and options, click OK.
A window appears for you to enter information about this property and job.

4. On the Jobs from Sales tab, in the Lot/Block column, enter the lot and block 
numbers for this property.

5. In the Description column, enter at description for this job.
6. In the Customer column, click the arrow to select a customer from your list of 

customers.
You can enter a new customer on the Customer tab.

7. In the Tax Rate column, enter the tax rate for the location of the property.
8. In the WIP Acct column, select a general ledger account for this job’s work-

in-place materials.
9. Click the Customer tab.
10. If you are adding a new customer, fill in their information here. If you have 

selected a customer on the previous tab, verify the customer’s information 
here.

11. Click the Job tab.
12. On the Job tab, enter information about this job.
13. Click the Date Review tab.
14. On the Date Review tab, you can enter the expected dates for each of the con-

tract events listed. These dates are meant to act as a guide to keep the project 
on schedule.

15. Click the Loan Setup tab.
16. On the Load Setup tab, if the customer is using a loan to secure the property, 

enter information about the loan here.
17. When you have finished, click Process.

Once you have entered the dates, go to Job Cost > Add/Edit > Job Information > 
Dates/Custom to enter activity codes to correspond with these events. When these 
activity codes are entered, cPM will automatically update these dates as inspection 
reports are entered.
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When you click Process the system automatically creates all the purchase orders nec-
essary for the job. Any job and customer records needed for the project are also cre-
ated.

Issuing Purchase Orders
Once the purchase orders are auto-created by the system, you should review the bud-
get, make any changes and release the purchase orders to your vendors.

You can review the budget for each job and compare it to the pending purchase 
orders using the Job Buyout report. You can customize this report to see a detailed or 
summary view. You can also decide exactly which jobs, vendors, categories, purchase 
orders and classes you want to appear on the report.

TO VIEW THE JOB BUYOUT REPORT:

1. Go to Purchasing > Reports > Job Buyout.
2. At the top of the Job Buyout window, select Detail or Summary report.

A detail Report shows you each PO for the entire job.
3. If you select a detail report and want to see all categories and classes regardless 

of activity, then check the Include Categories/Classes with no PO Activity 
box.

4. Click the buttons below to filter this report. Select the information you want 
to include and click Add. When you have finished, click OK.
You can filter by vendors, purchase orders, jobs. categories or classes.
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5. When you have finished, click Preview to see the report before printing. Click 
Print to print the report.

The job buyout report shows the budget, pending POs, issued POs, invoiced POs and 
the percentage of the PO that has been invoiced. This information is helpful in deter-
mining if the budget for the job needs to be adjusted.

TO ADJUST A JOB’S BUDGET:

1. Go to Job Cost > Add/Edit > Job Information.
2. Click the search button next to the community field.
3. Select the job you want to change from the bottom portion of the window.
4. Click OK.
5. In the Budget column below, make any changes to this job’s budget.
6. When you have finished, click Save and Exit.

Once you have updated your budget, you may also need to adjust your purchase 
orders before releasing them. 
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TO CHANGE A PENDING PURCHASE ORDER:

1. Go to Purchasing > Add/Edit > Purchase Orders.
2. Click the search button next to the Number field.
3. Select the PO you want to change and click OK.

You can sort the PO list by clicking the columns at the top of the window.
4. Make any changes to the PO that are necessary.
5. When you have finished, click Save and then Exit.

When making changes to a purchase order, it is important to include a variance code. 
This code tracks the reason for any variance in budget and cost due to these changes. 
Tracking this code allows executives to keep a close watch on any potential problems 
with budgets and costing.

After you have reviewed the budget, made any changes and adjusting any purchase 
orders, you are ready to release the purchase orders to the vendors and subcontrac-
tors.

TO RELEASE PENDING PURCHASE ORDERS:

1. Go to Purchasing > Process > Issue/Print.
2. The system prompts you to make a preprocessing backup. Verify the backup 

location and click Make Backup.
The Purchase Order: Issue – Print window appears.

3. In the Posting Date field, select the posting date for the POs you are about to 
release.

4. Select Issue and Print to release and print the purchase orders. Select Issue 
Only to release the purchase orders but not print them. Select Print Only to 
print any purchase orders that were previously issued by not printed.

5. Check the boxes next to the type of POs you want included.
Clear any boxes for types you do not want included.

6. If you want to filter the purchase orders you are processing by vendor, click 
All Vendors.

7. Select the vendors you want to include and click Add.
8. When you have finished, click OK.
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9. If you want to filter the purchase orders you are processing by individual PO 
number, click All POs.

10. Select the POs you want to include and click Add.
11. When you have finished, click OK.
12. If you want to print a verification report, check the Print Verification Report 

box and select how you want the report organized—by category or purchase 
order number.

13. Select if you want the POs to be printed to a printer or sent to the vendors 
automatically.
If you select Send by preferred method, the purchase orders are printed, faxed 
or e-mailed depending on the selection made on each individual vendor 
record. You can change these settings at Accounts Payable > Add/Edit > Ven-
dors.

14. Click Process.

Your purchase orders are now processed and can be sent to your vendors and subcon-
tractors.

With your purchase orders released, it is now time to add this job to Profit Builder®’s 
companion scheduling system.
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Scheduling the Job
Profit Builder® is designed to work closely with CDCI's cPM—Critical Project Man-
agement Scheduling program. 

Common information to both accounting and scheduling is passed between these 
programs throughout the life of a job. To accomplish this, the job cost category struc-
ture in Profit Builder® must be identical to the scheduling activity list.

 In the Project Management edition, there is a Scheduling button at the top of your 
Profit Builder main screen. Go to Control Information > Transfer to set the path to 
your scheduling software. Then, when you click the Scheduling button, cPM will 
open automatically.

Exporting Job Information
Once your house has been started in Profit Builder® and the purchase orders have 
been issued, you can then export the information to the scheduling program to track 
the job’s progress more efficiently.

TO EXPORT A JOB TO SCHEDULING:

1. Go to Purchasing > Process > Export to Scheduling.
2. Click All Jobs.
3. Select the jobs you want to export and click Add.
4. When you have finished, click OK.
5. Click Export.
6. Choose where you want to save your exported file.

Typically you want to save this file in your Outbox, however you can save it 
anywhere as long as you can tell the scheduling program where to find it.

7. Click Save.
8. A window appears letting you know your export was successful. Click OK.

You can now import the saved file to the scheduling program.

Setting up Jobs in Scheduling
When setting up your scheduling system, you can use the job structure imported 
from accounting to create the job in scheduling. With one activity per category, each 
activity is cost loaded with the total amount of the POs issued for the matching cate-
gory in accounting.

After you add the scheduling logic—the duration for each activity and the order in 
which they must be performed, etc.—this job can be used as a template. When creat-
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ing new jobs in scheduling, you can copy a template scheduling job and then import 
from accounting to update the cost loading and/or vendor assignments.

TO SETUP A JOB IN SCHEDULING:

1. In cPM Scheduling, go to File > New > Job.
2. In the Job ID field, enter the ID for this job. This ID must match the account-

ing ID.

3. In the Accounting Company ID field, enter the company number for your 
company in Profit Builder®.
You can find this number at the top of the Profit Builder® window when 
signed into the company.
You must enter the company number here in order to link this job to the 
accounting information.

4. In the Projected Start Date field, check the box next to the date and select the 
start date for the project.

5. If this job has a deadline that it must be completed by, in the Mandatory Job 
Finish Date field, check the box next to the date and select the date for the 
deadline.

6. In the Properties section, check the box to indicate that you want to create 
this job based on information from accounting.

If you have already set up your scheduling logic, see page 139 to create a new job 
in scheduling. It is important to use the instructions on page 33 to prevent having 
to re-enter your scheduling logic.
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7. If you want to update time and budget at the same time, check the box in front 
of Yes, I do. that corresponds to this option at the bottom of the box.
Checking this option means that when an activity is complete the vendor will 
be paid.

8. When you have finished, click Create.
9. A window appears asking you to select the file from accounting. Find the file 

you exported from accounting in the previous section and click Open.
The schedule window for the new job is displayed.

Your job is now created in scheduling based on the information from accounting. 
Before you can fully utilize the scheduling program, you must define the scheduling 
logic.

Scheduling logic tells cPM how long a given activity should last and which activities 
come before and after. This allows the program to map out a schedule according to 
the dates for the job. 

You must set up the scheduling logic in cPM manually. Once you have set up the logic 
in one job, you can then use that job as a template for other jobs. This means that you 
do not have to set up the scheduling logic every time you create a new job.

TO SETUP JOB SCHEDULING LOGIC:

1. In cPM, open a job.
2. In the Job Details section, in the Calendar In Use field, select the type of cal-

endar to be used for this job.
3. Right-click on the first activity to display the activity detail window.
4. In the Original Duration field, enter the typical number of days this activity 

takes to complete.
5. Click Pred/Succ.

6. On the Predecessors tab, select any activities that occur immediately before 
this activity.
Use the arrow buttons to move activities between the Not Selected and 
Selected columns.
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7. On the Successors tab, select any activities that occur immediately after this 
activity.
Use the arrow buttons to move activities between the Not Selected and 
Selected columns.

8. When you have finished, click Save.
9. Click Save in the Activity Detail window.
10. Continue this process with each of the activities for this job.
11. When you have finished entering all of the activity details, check the Recalc. 

Required box in the Job Details section of the main window.
12. Click Calculate.
13. You are asked to supply an inspection date. Because this is the initial setup of 

this job, select the job start date.
14. Click OK.

You have now established your scheduling logic and you can use this job as a template 
for other jobs you create in cPM.

The procedure for creating jobs in cPM once your scheduling logic has been estab-
lishing is slightly different from setting up that initial job. The next section outlines 
the steps for creating additional jobs based on the job template you just created.

Creating a New Job in Scheduling
Once you have set up your scheduling logic, you can create new jobs based on that 
logic. You can then link those jobs with accounting information to update budgets 
and progress.

If you have not yet set up your scheduling logic, see “Setting up Jobs in Scheduling” 
on page 136.

TO CREATE A NEW JOB IN SCHEDULING:

1. In cPM Scheduling, go to File > New > Job.
2. In the Job ID field, enter the ID for this job. This ID must match the account-

ing ID.
3. In the Accounting Company ID field, enter the company number for your 

company in Profit Builder®.
You can find this number at the top of the Profit Builder® window when 
signed into the company.

Take care when you specify the inspection date! 

The system always uses the inspection date that you specify for a calculation as the 
date on which ALL remaining incomplete activities should begin. 

For example, if you have a job start date of 8/1/2004 and calculate the schedule 
with an inspection date of 8/15/2004, all remaining work is scheduled from August 
15th forward.
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You must enter the company number here in order to link this job to the 
accounting information.

4. In the Projected Start Date field, check the box next to the date and select the 
start date for the project.

5. If this job has a deadline that it must be completed by, in the Mandatory Job 
Finish Date field, check the box next to the date and select the date for the 
deadline.

6. In the Properties section, check the box to indicate that you want to use a pre-
vious job as a template.

7. In the Which Job? field, select the job you want to use as a template.
8. If you want to update time and budget at the same time, check the box in front 

of Yes, I do. that corresponds to this option at the bottom of the box.
Checking this option means that when an activity is complete the vendor will 
be paid.

9. When you have finished, click Create.
The system creates the new job using the job you selected as the scheduling 
logic template.
When it has finished, your new job appears in the cPM window. Before you 
can work with the new job, you must import the accounting information.

10. Go to Tools > Accounting Interface > Import.
11. Click Accounting File. Locate the file you exported from Profit Builder® and 

select Open.
12. Click Process.

The system notifies you when it has finished importing the accounting infor-
mation.
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13. You must now recalculate the job schedule with the accounting information. 
Check the Recalc Required box and click Calculate.

14. You are asked to enter an inspection date. Because this is a new job, the 
inspection date is the job start date. Click OK.
cPM now calculates the job schedule. When it has finished you can see the 
schedule in the cPM window. 

Once the schedule has been completed, you can use the Reports menu to print the 
schedule and to do lists for the job. This information is all very useful for vendors and 
contractors. It allows you to keep a close watch on the progress of your jobs and 
ensure that they remain on schedule throughout the building process.

Take care when you specify the inspection date! The program always uses the 
inspection date that you specify for a calculation as the date on which ALL remain-
ing incomplete activities should begin. This means, for example, that if you have a 
job start date of 8/1/2004 and calculate the schedule with an inspection date of 8/
15/2004, all remaining work is scheduled from August 15th forward.
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Updating the Schedule
As the project continues, you will need to update the schedule to reflect the progress 
being made. This is done by recording job inspection information for each activity 
that has been completed or partially completed.

You can use the Inspection Worksheet to gather information about the activities that 
need to be updated.

TO PRINT AN INSPECTION WORKSHEET:

1. In cPM, go to Reports > Inspection > Worksheet.
2. Select the job(s) you want to include on the worksheet.
3. Check the Hide Budget Information box if you want budgets to be omitted 

from the worksheet.
4. Click OK.
5. A preview of the report appears, click the print button to print the report.

This report contains places for you to enter new information concerning the percent 
complete, budget and duration of each activity. From this report, you can then enter 
information about schedule updates into cPM.
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Entering Inspection Data
Once you have compiled the inspection data that needs to be entered, you must enter 
the progress updates into the system. When you have finished updating the informa-
tion, you can then recalculate the schedule.

TO ENTER JOB INSPECTION DATA:

1. In cPM, go to File > Open.
2. Select the job you want to update and click OK.
3. Right-click the activity you want to update.
4. Click Progress Updates.

5. In the Percent Paid field, enter the percentage the activity has been com-
pleted.

6. Click Save.
The activity now appears in red.

7. Continue updating all of your activities in this way. 
When you have finished updating each activity, you need to recalculate the 
schedule.

8. Notice that the Recalc Required box is checked. Click Calculate.
9. Enter the date the job inspections were made. This date is used to calculate the 

start dates of all remaining activities.
10. Click OK.

Your job is now updated with the progress updates.

Once you have entered inspection data and updated your schedule, you must export 
that information to accounting. Your accounting data is then updated to reflect this 
progress that has been made on the job.
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TO EXPORT TO ACCOUNTING:

1. Go to Tools > Accounting Interface > Export.
2. In the Jobs field, select the job(s) you want to export.

If you want to filter the list of jobs by the company, select the company ID 
number in the Filter By Company ID field.

3. Click OK.
4. Locate your Profit Builder® Inbox and save the file.

The next time you open Profit Builder® you should receive a message that you have 
updates from sales and scheduling. For more information about creating invoices 
from scheduling updates, see “Auto-creating Invoices via Scheduling” on page 23.
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Importing the Master Catalog
You can import a series of items into your Profit Builder master catalog using an 
Excel spreadsheet. This feature is especially helpful when first implementing Profit 
Builder. To utilize this feature, you must be using Excel 10.0 or higher.

CDCI provides an Excel template to use for importing your catalog items. However, if 
you do not have the template, you can create your own fairly easily. Your spreadsheet 
must contain the following columns in the order they are listed. 

Division – Enter a division for this item. You can enter up to 6 alphanumeric 
characters for the division.
Catalog ID – Enter an item code for this item. You can enter up to 16 alpha-
numeric characters for the catalog ID.
SKU – Enter the vendor’s item code for this item. You can enter up to 16 
alphanumeric characters for the SKU.
Vendor – Enter the code for the vendor that supplies this item. The vendor 
code entered must already exist in the system or the import will fail. You can 
enter up to 6 alphanumeric characters for the vendor.
Description – Enter a description of this item. You can enter up to 255 alpha-
numeric characters for the description.
Price – Enter a the cost per unit for this item. You can only enter numerals in 
currency format for the price.
Unit – Enter a unit of purchase for this item. You can enter up to 6 alphanu-
meric characters for the unit.

These columns mirror the columns in Profit Builder’s master catalog screen. The 
information entered into your Excel spreadsheet must match the order and format 
exactly for the import to work properly.

TO IMPORT THE MASTER CATALOG:

1. Go to Purchasing > Process > Update Catalog from Excel.
2. Locate the catalog spreadsheet, select the file and click Open.
3. Confirm that the correct file is selected and click OK.

You can verify that your catalog has been updated by going to Purchasing > Add/
Edit > Master Catalog. If any of your items include a division that is not yet defined, 
the item will import and create a new undefined division. To complete the division 
record, go to Purchasing > Add/Edit > Catalog Divisions.
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Updating Catalog Prices
There will be times when it is necessary for you to update your vendor prices in your 
master catalog. This is necessary to maintain accurate purchase orders and job bud-
gets. There are four ways to update vendor prices:

Import Catalog Prices – Use this method to update your prices in Microsoft 
Excel and import the spreadsheet.
Item Scan Method – Use this method to review prices by catalog division. 
This is the most efficient way to enter or update prices.
One Item Method – Use this method to update individual items.
Percentage Method – Use this method to apply a percentage markup or dis-
count to all items in a catalog division.

Import Catalog Prices
You can update your catalog items by importing an Excel spreadsheet with your 
changes. If you do not already have the CDCI template for importing catalog items, 
you can create your own. For more information, see “Importing the Master Catalog” 
on page 145.

When you want to update your catalog prices by importing a spreadsheet, change the 
information in the spreadsheet and follow the steps below to import the data.

TO IMPORT THE MASTER CATALOG:

1. Go to Purchasing > Process > Update Catalog from Excel.
2. Locate the catalog spreadsheet, select the file and click Open.
3. Confirm that the correct file is selected and click OK.

You can verify that your catalog has been updated by going to Purchasing > Add/
Edit > Master Catalog. If any of your items include a division that is not yet defined, 
the item will import and create a new undefined division. To complete the division 
record, go to Purchasing > Add/Edit > Catalog Divisions.
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Item Scan Method
The Item Scan Method provides you with the most efficient way to update prices for a 
particular vendor. 

TO UPDATE PRICES WITH ITEM SCAN:

1. Go to Purchasing > Add/Edit > Catalog Price Maintenance.
2. Click the Item Scan Method tab.

3. In the Vendor field, enter or select a vendor from the vendor list.
4. To filter the item list by divisions or communities, click Filter in the lower 

corner of the window.
5. To change the vendor price, tab to the Cost column and type the new price 

over the old price. 
6. Click Save when you have completed all your changes for this vendor.
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TO ADD NEW ITEMS FOR A VENDOR:

1. On the Item Scan Method tab, enter or select a vendor in the Vendor field.
2. Click Add New Items.

3. Select the items from your master catalog to add for this vendor and click 
Add.

4. When you have finished, click OK.
5. For each item, enter the vendor’s price in the Cost column.
6. In the Unit column, enter a unit of measure for each item.
7. When you have finished, click Save.

One Item Method
The one item method is typically used when price conversion is needed due to a dif-
ference in the units used by vendors in pricing an item and the company in ordering 
that item. This method allows you to easily make the necessary conversion.

TO UPDATE AN ITEM PRICE WITH ONE ITEM METHOD:

1. Go to Purchasing > Add/Edit > Catalog Price Maintenance.
2. Click the One Item Method tab.

3. In the Vendor field, enter or select a vendor from the vendor list.
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4. In the Item Code field, enter an item code or select the item that you wish to 
change from the list.
Once you select an item, the division, community, vendor’s SKU, unit cost and 
unit description values appear.

5. In the Unit Cost field, type the new unit cost for the item.
6. Tab through the Conversion field to update the conversion factor.

For example, if plywood is ordered by the sheet (32 sq. ft.), but is priced by the 
hundred square foot (CSF), the system converts the pricing information into 
ordering information.

7. In the Unit Description field, type a different unit description if necessary.
8. To change the unit cost for another item, use the First, Previous, Next or Last 

buttons to display all the records in this division for this vendor.
Note: Only items that have been assigned to this vendor appear. For more 
information on assigning items to vendors, see “Item Scan Method” on 
page 147.

9. When you have finished, click Save.

Percentage Method
Frequently, commodity items like dimensional lumber change pricing by percentage. 
This method allows you to change a particular vendor’s prices throughout a division 
or on all items the vendor supplies.

TO UPDATE VENDOR PRICES BY A PERCENTAGE:

1. Go to Purchasing > Add/Edit > Catalog Price Maintenance.
2. Click the Percentage Method tab.

3. In the Vendor field, enter or select a vendor from the vendor list.
4. In the Percentage field, enter the percentage amount to change the prices.

To decrease the price, enter a minus (-) sign before the percentage.
For example, to reduce prices by five and a quarter percent, enter -5.25.

5. To filter the communities included in this reprice, click All Communities and 
select the communities to include.
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6. To filter the divisions included in this reprice, click All Divisions and select 
the divisions which contain the items to be repriced.

7. When you have finished, click Save.

Creating Purchase Orders
Purchase orders are an integral part of the building process. POs tell your vendors 
what materials and services you need to complete your scheduled jobs. In addition to 
auto-creating purchase orders when starting a house, you can also enter purchase 
orders directly into Profit Builder®.

There are three other ways to create purchase orders:

Entered directly in Profit Builder® – A new PO can be entered manually in 
Profit Builder® from Purchasing > Add/Edit > Purchase Orders.
Cloned from an existing PO – A new PO can be created by copying an exist-
ing purchase order.
Importing from a Bid Team estimate – Using CDCI’s estimating program, 
purchase orders can be imported from customer estimates.

Manually Entering Purchase Orders
Entering a purchase order from scratch is the most time consuming way to enter pur-
chasing information, but allows you to control every aspect of the purchase order.

TO ENTER A PURCHASE ORDER MANUALLY:

1. Go to Purchasing > Add/Edit > Purchase Orders.
The Purchase Order window opens.

CAUTION: All the vendor’s items within the selected divisions and communities 
will be repriced.
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2. In the Number field, enter the number for the PO you are creating. If you use 
autonumbering, leave this field blank. The number may be up to 10 charac-
ters.

3. In the Vendor field, enter the vendor or select one from the vendor list.
4. In the Type field, select a type for this PO. The default type is standard. 

For more information about other types of POs, see “Special Purchase 
Orders” on page 154.

5. Check the Overrun Budget box if you want to allow this purchase order to go 
over the allotted budget for this job without requiring reason and resolution 
codes. This box must be checked before any line items are entered on the next 
tab.

6. In the Status field, the status of the purchase order appears. Valid statuses are 
New, Issued, Revised, Pending and Complete.

7. In the PO Net field, the net amount of the purchase order appears.
8. On the General Tab, in the Description field, enter a description for the pur-

chase order you are creating. Up to 50 characters.
9. In the Buyer field, enter the name of the buyer. The default is the user cur-

rently logged in.
10. In the FOB field, enter the point at which the freight charges are paid.
11. In the Ship Via field, enter the shipping instructions for the order.
12. Click Edit Terms to change the terms for this order. This defaults to the terms 

that have been entered in vendor information in Accounts Payable.
13. In the Form Name field, select the purchase order form name from the drop-

down list. Go to Control Information > Purchase Orders to set default 
forms.

14. In the Quotation Form field, select the quotation form from the drop-down 
list. This field is optional. 

15. In the Job field, enter the job code or select it from the job list. Multiple jobs 
on a single PO are not permitted.

16. In the Category field, after selecting the job code, enter or select the category.
Job cost categories cannot be added to any purchase order until they have 
been added in a template at Job Cost > Add/Edit > Job Information. For more 
information on adding categories, see “Master Job/Category Sets” on page 58.

When selecting forms, you have five options:
Pozfmsub.rpt
Pozplain.rpt
Pozqfstd.rpt
Pozf 505.rpt
Pozf525.rpt

If you select Pozplain.rpt, the purchase order will be formatted to print on plain 
paper. Pozfmsub.rpt is the subcontract form. Pozqfstd.rpt is the quotation request 
form. You can have directions to the job site printed on your purchase orders using 
a special form. If you are interested in utilizing this feature, contact CDCI support.
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17. In the Class field, enter the class (Labor, Material, etc.) or select from the 
drop-down menu.

18. In the GL Account field, enter the GL Account Code or select it from the GL 
Account List.

19. Click the Line Details tab to enter the item details for the purchase order.

20. In the Division column, enter the division or select one from the Catalog 
Division list.

21. In the Item Code column, enter an item code or select one from the list. If the 
item code does not exist, you are prompted to add it to the catalog on the Add 
New Items window. Click Add to add the item to the catalog.

22. In the Category column, enter a category or enter a job code, then select the 
job category from the list. Job cost categories cannot be added until they have 
been added in a template at Job Cost > Add/Edit > Job Information. For more 
information on adding categories, see “Master Job/Category Sets” on page 58.

23. In the Quantity Ordered column, enter the quantity for this item.
24. In the Activity column, enter the activity code for import into scheduling.
25. Click the Tax Freight and Scope tab to enter tax, discount, freight and memo 

fields.
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26. In the Sales Tax field, enter a tax rate here if it is different from the default. 
This defaults to the tax rate on file for the vendor or the rate on file for the job. 

27. In the Freight field, enter the freight amount.
28. In the Discount field, enter the discount rate.
29. In the Memo - Scope field, enter any specifications you want printed on the 

PO or subcontract form.
30. In the Remarks section, select up to four permanent remark codes that are 

printed on the bottom of the PO/Subcontract form. Enter a code, and then the 
full remark. Profit Builder® stores your entries for use on future POs.

31. When you have finished, click Save to create the purchase order.

Cloning an Existing Purchase Order
The Copy Existing POs (Cloning) function from the Add/Edit menu allows you to 
create a purchase order based on information copied from an existing purchase order. 
The existing purchase order serves as a template for cloning the new purchase order.

TO CLONE AN EXISTING PURCHASE ORDER:

1. Go to Purchasing > Add/Edit > Copy Existing POs (Cloning).
2. In the Existing PO’s section, use the following buttons to select the existing 

PO information from which you want to create the new purchase order.
• All Vendors: Click to select vendors from the vendor list.
• All POs: Click to select POs from the PO list.
• All Jobs: Click to select jobs from the PO-Job list.
• All Categories: Click to select categories from the PO-Job list.
• All Classes: Click to select classes from the JC class list.

3. In the New POs section, leave the Vendor field blank. This ensures that the 
vendors from the POs being copied are used. Selecting a vendor in this field 
will result in all of the copied POs being issued to the selected vendor.

4. In the Job field, enter or select a job from the job list.
5. In the Sales Tax field, enter the applicable tax rate.
6. Click Taxable Classes and select the classes to which the tax rate is to be 

applied.
7. Check the Preview verification report box to display the Cloned POs Report, 

which shows the purchase orders which were copied and the new purchase 
order information.

8. Click Copy to create the purchase order(s).



P R O F I T  B U I L D E R P U R C H A S I N G  &  P R O D U C T I O N  B U I L D I N G

O P E R A T I O N S  G U I D E 154

Special Purchase Orders
There are four types of purchase orders that can be used instead of a standard PO. 
These special purchase orders are used under special circumstances.

Field PO – A field purchase order is used when you want to assign a pur-
chase order number before the order is complete. Typically when a purchase 
order is created manually the number is automatically assigned when the 
order is saved. With a field purchase order, the number is assigned before 
submitting the order. Because of this, cancelling a field PO throws away the 
number it was assigned. If the PO is to be associated with a job, enter the job 
number before clicking the Field PO button.
Variance – A variance purchase order is used to assign a variance to an entire 
purchase order to account for deviations from the budget. Because any bud-
get overages are already accounted for, the budget is not checked when sub-
mitting the purchase order.
TBD – To be determined (TBD) purchase orders are used to estimate the 
amount of materials or labor that may be required for a particular job. TBDs 
are used for purchases where there is no way to know exactly how much of 
the materials is needed to complete the job. For example, electricity at a job 
site it typically estimated on a TBD because there is no way to know before-
hand how much electricity will be used on any given job.
Change Order – A change order indicates a change to the original budget 
that is paid for by the owner. The budget adjustment postings for a change 
order add to the original budget and to the PO/Contract budget, leaving the 
uncommitted budget amount the same.
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Chapter

9
Custom Building

This chapter offers step-by-step instructions for setting up a custom plan using 
Profit Builder®’s automated purchasing system.

Custom plans are plans that are only going to be built once. These plans are one-of-a-
kind and must be set up differently in Profit Builder®.

Setting up a custom plan requires that you create a template plan to use as your base. 
You can then copy and customize this plan to adjust for any new or changed ele-
ments. Then you can specify the prices for items included in each work package. You 
will repeat this process for each custom plan you intend to build.

Once the custom plan is established in Profit Builder® you can use the Start a House 
feature to generate the purchase orders, jobs and budgets automatically. This elimi-
nates much of the tedious updating typically involved in custom building.

Creating a Template Plan
It is important to create a template that can be used to create each individual plan. 
Although each plan is one-of-a-kind, they all contain the basic elements necessary to 
build a house. Using a template as a starting point saves time when creating each indi-
vidual plan.

The template should contain all of the basic elevations and work packages necessary 
to build the home. You can then customize the available items and pricing for each 
individual house.

The template is created the same way any production plan would be created, by add-
ing a plan, elevations, options and work packages. 
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Creating a Plan
You must first create a plan to begin your template. You can create multiple templates 
by repeating the steps outlined below.

TO CREATE A NEW PLAN:

1. Go to Purchasing > Add/Edit > Plan Takeoff. All plans on file are displayed.
2. Right-click the word Plan and select New Plan.

3. In the Code field, enter a short name for this plan.
4. In the Name field, enter the name for this plan that you want to see in the 

Plans menu.
5. In the Scope field you can enter information to further identify this plan. This 

information is for internal use only.
6. Click Exit and save your work.

Your new plan is now created. You can now return to the plan and add the main orga-
nizational structure—elevations and options. 

Adding Elevations
It is not required that all elevations, foundations, and options be added during the ini-
tial plan creation process. You may come back at any time and add these elements. 

TO ADD ELEVATIONS TO A PLAN:

1. Go to Purchasing > Add/Edit > Plan Takeoff.
2. A window opens with a list of the available plans. Check the box next to the 

plan you want to add elevations to and click These Plans.
3. Expand the tree under the plan by clicking the plus sign next to the name of 

the plan to reveal the Base and Options.
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4. Right-click Base and select New Elevation.
The first elevation you should add to any new plan is the CORE elevation. 
This elevation includes all work packages that will be included in every house.

5. In the Code field, enter a short identifier for this elevation.
6. In the Name field, enter the name for this elevation. The name should be clear 

so that the elevation can be selected without confusion when starting a new 
house. 
All elevations and options are sorted alphabetically by this name.

7. In the Scope field you can enter information that helps further identify this 
elevation. This information is not available when starting a new house but 
does appear on this screen for anyone modifying this plan. The information 
entered here is for internal use only.

8. In the conflicting items field, enter the codes for any elements that conflict 
with this elevation. You can also click Browse next to this field to choose from 
a list of all elements. If conflicting items are selected, both items appear red 
when starting a new house.
For more information on conflicting items, see “Determining Prerequisites, 
Conflicts & Suggestions” on page 123.

9. In the prerequisites field, enter the codes for any elements that are required 
for this elevation. You can also click Browse next to this field to choose form a 
list of all elements. 
For more information on prerequisites, see “Determining Prerequisites, Con-
flicts & Suggestions” on page 123.

10. In the optional links field, enter the codes for any elements that are recom-
mended when this elevation is selected. Any recommended elements appear 
green when this elevation is selected for a new house.
For more information on recommendations, see “Determining Prerequisites, 
Conflicts & Suggestions” on page 123.

11.  When you have finished, click Exit and save your work.
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Continue to add all your foundations and elevations in this manner. Be sure that you 
enter an element for the core elevation—this includes everything that is required but 
not present in the other elevations and foundations.

Adding Options
Once you have added your elevations, you can add options. Options are additional 
features that are often offered to upgrade a house. Because you are building one-of-a-
kind plans, you will continue to develop new options. If you wish, each successive 
plan can become a new template for the next plan.

TO ADD OPTIONS TO A PLAN:

1. Go to Purchasing > Add/Edit > Plan Takeoff.
2. A window opens with a list of the available plans. Check the box next to the 

plan you want to add options to and click These Plans.
3. Expand the tree under the plan by clicking the plus sign next to the name of 

the plan to reveal the Base and Options.
4. Right-click Options and select New Option.
5. In the Code field, enter a short identifier for this option.
6. In the Name field, enter the name for this option. The name should be clear so 

that the option can be selected without confusion when starting a new house. 
All elevations and options are sorted alphabetically by this name.

7. In the Scope field you can enter information that helps further identify this 
option. This information is not available when starting a new house but does 
appear on this screen for anyone modifying this plan. The information 
entered here is for internal use only.

8. In the conflicting items field, enter the codes for any elements that conflict 
with this option. You can also click Browse next to this field to choose from a 
list of all elements. If conflicting items are selected, both items appear red 
when starting a new house.
For more information on conflicting items, see “Determining Prerequisites, 
Conflicts & Suggestions” on page 123.

9. In the prerequisites field, enter the codes for any elements that are required 
for this option. You can also click Browse next to this field to choose form a 
list of all elements. 
For more information on prerequisites, see “Determining Prerequisites, Con-
flicts & Suggestions” on page 123.

10. In the optional links field, enter the codes for any elements that are recom-
mended when this option is selected. Any recommended elements appear 
green when this option is selected for a new house.
For more information on recommendations, see “Determining Prerequisites, 
Conflicts & Suggestions” on page 123.

11.  When you have finished, click Exit and save your work.

Once the structure is in place, it is time to enter the work packages and their compo-
nents for both elevations and options.
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Adding Work Packages
A work package is a group of materials or subcontract work that can be delivered/
performed by one vendor without interruption. Once you have created new work 
packages for your elevations and options, you can add catalog items to the work pack-
ages. These items will be priced later according to the specific custom plan you are 
creating.

TO ADD WORK PACKAGES TO A PLAN:

1. Go to Purchasing > Add/Edit > Plan Takeoff.
2. A window opens with a list of the available plans. Check the box next to the 

plan you want to add work packages to and click These Plans.
3. Expand the tree under the plan by clicking the plus sign next to the name of 

the plan to reveal the Base and Options.
4. Expand the tree again to reveal your elevations and options.
5. Right-click the option or elevation you want to add to and select New Pack-

age.

6. In the Code field, enter a short identifier for this package.
7. In the Name field, enter the name for this package. 
8. In the Scope field you can enter information that helps further identify this 

package. This information is printed on purchase orders. The information 
entered here should be used to provide contractors and suppliers special 
instructions about the work package.

9. In the Vendor field, select a default vendor for this work package.
You can change this later if necessary.

10. In the Category field, select a default category for this work package.
You can change this later if necessary.

11. In the Class field, enter a default class for this work package.
12. In the Activity field, select a default activity for this work package.

You can change this later if necessary.
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13. Check the TBD PO box if this package should create a To Be Determined 
purchase order. For more information on TBD POs, see “Special Purchase 
Orders” on page 154.

14. Click Show Detail Lines to add catalog items to this work package.
You can add catalog items now or later. See below for step-by-step instruc-
tions for adding catalog items to work packages.

15. When you have finished, click Exit and save your work.

Your work package is now created and added to your plan. Work packages are made 
up of line items from your main catalog. If you did not add items when you created 
the work package or if you need to add additional items, follow the instructions below 
to add items to your work package.

The items you add to your template work packages should be items that can later be 
customized in price and supplier.

TO ADD ITEMS TO YOUR WORK PACKAGES:

1. Go to Purchasing > Add/Edit > Plan Takeoff.
2. A window opens with a list of the available plans. Check the box next to the 

plan you want to modify and click These Plans.
3. Expand the tree under the plan by clicking the plus sign next to the name of 

the plan to reveal the Base and Options.
4. Expand the tree until you can see the work package you want to add items to.
5. Click on the work package you want to edit.
6. If the Properties for this work package are displayed, click Show Detail Lines 

to display the line items associated with this work package.
7. In the Item Code column, enter or select an item code for the line item.

Click the arrow to search for your item in the main catalog.
8. If the item code you enter is not already stored in your main catalog the sys-

tem prompts you to create the item. If you want to add the item, select Yes.
9. In the Add Item to Catalog window, enter or verify the division, description, 

category, class, unit description, unit cost, and unit tag for this item.

10. Click OK.
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11. If your item is already in the catalog the information in the remaining col-
umns is automatically filled it according to the item record and the work 
package defaults. In the Quantity column, enter the quantity of this item that 
is necessary for this work package.

12. If you need to change any default information, select the information in the 
appropriate column and make your changes.

13. Continue to add items to this work package and other packages.
14. When you have finished, click Exit and save your work.

Once items are added to the work packages your template is complete and ready to 
customize for the individual project.

Customizing the Template
When you have your template plan created, you can then clone that plan and create 
your new custom project based on the template. This allows you to still utilize Profit 
Builder®’s automated features and create one-of-a-kind plans for your clients.

Cloning the Template
Before you can begin creating your custom plan, you must first copy your template to 
create a new plan.

TO CLONE THE TEMPLATE:

1. Go to Purchasing > Add/Edit > Plan Takeoff.
2. A window opens with a list of the available plans. Check the box next to your 

template and click These Plans.
3. Right-click the template and select Copy.
4. Right-click Plans and select Paste.
5. Select the copied plan and click Show Properties.

6. In the Code field, enter a new code for your custom plan.



P R O F I T  B U I L D E R C U S T O M  B U I L D I N G

O P E R A T I O N S  G U I D E 162

7. In the Name field, enter a new name for you custom plan.
8. In the Scope field you can enter information that helps further identify this 

custom plan. This information is not available when starting a new house but 
does appear on this screen for anyone modifying this plan. The information 
entered here is for internal use only.

9. When you have finished, click Exit and save your work.

You now have a cloned template as your new custom plan. Now, you must create a 
new individual community for this custom plan.

Creating a Community
Each custom plan must have its own individual community. This allows you to cus-
tomize the prices for each item necessary for the plan. Placing custom plans into a 
community with other houses would change the prices for all the items in that com-
munity.

TO ADD A COMMUNITY RECORD:

1. Go to Job Cost > Add/Edit > Community Names.

2. In the Community column, enter a 2 character code to identify the commu-
nity. This code becomes a part of each Job ID that is built in the community.
For example, if the custom plan is for John Parker, JP would be an appropriate 
code to identify the community.

3. In the Name column, enter the name of the community.
4. In the Sales Tax % column, enter the sales tax for this community.
5. When you have finished, click OK.

When this community is entered in Profit Builder®, you can then add your custom 
plan and set up costing.
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Adding the Plan to the Community
With your community added and your custom plan defined, you can now add the 
plan to the community and price it accordingly.

TO ADD A PLAN TO A COMMUNITY:

1. Go to Purchasing > Add/Edit > Plan Costing.
2. A window appears with the available communities listed. Check the box next 

to the custom community you want to work with. If the community you want 
is not listed, check any other community and click These Communities.

3. The Plan Costing window appears with a tree listing all the available commu-
nities. If the community you want is not listed, right-click Communities at the 
top of the tree, select New Community. Find the community you want to add 
and click OK.

4. Right-click the community you want to add to and select New Plan.
5. Select your custom plan and click OK.
6. When you have finished adding plans, click Exit and save your work.

You can now customize the plan costing for this individual property.

Adjusting Plan Costing
Because you have created an individual community for your custom plan, you can 
adjust the costing and budget for the plan without affecting any of your other 
projects.

TO ADJUST PLAN COSTING:

1. Go to Purchasing > Add/Edit > Plan Costing.
2. A window appears with the available communities listed. Check the box next 

to the custom community you want to work with. If the community you want 
is not listed, check any other community and click These Communities.

3. Expand the tree next to the plan you want to adjust to see the elevations, 
options and work packages.

4. You can adjust the prices of individual items by changing the amounts in the 
unit cost column.
You can only change prices on individual items not on an entire package.
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If the window is showing packages, click Show Detail Lines at the bottom to 
see the line items.

5. When looking at the packages, you can add freight charges in the Freight col-
umn. Freight charges are exempt from sales tax.

6. When you have finished adjusting the prices for the entire plan, click Exit and 
save your work.

You can use the plan costing window to keep track of your progress when customiz-
ing plans. To see all of the communities and their costing, click Communities at the 
top of the tree. All of the items in each community are listed. You can then sort by 
item number to ensure that you have updated everything that requires changing.

Once your custom plan has been adjusted, you can use the Start a House feature just 
as you would if you were creating a house from a normal plan. For more information 
on starting a house, see “Starting a New House” on page 130.



P R O F I T  B U I L D E R

O P E R A T I O N S  G U I D E 165

Chapter

10
Appendix

This chapter offers additional information and tools for you to utilize during 
your daily operations.

Checklists
In this section you will find several easy-to-use checklists to walk you through some 
of the operations tasks you perform on a regular basis. 

These checklists are intended to remind you of the basic steps necessary to carry out 
the operations. For more detailed information on each step, refer to the chapter in 
this guide covering that activity.

Click the links below to jump to that checklist. The following checklists are available 
in this section:

“Creating a New Plan” on page 166
“Start a House” on page 167
“Creating a New Job in Scheduling” on page 168
“Closing the Accounting Month” on page 169
“Closing a Job” on page 170
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Creating a New Plan
Create the plan record – Go to Purchasing > Add/Edit > Plan 
Takeoff. All plans on file are displayed. Right-click the word Plan 
and select New Plan. Enter a code, name, and scope for this plan. 
Click Exit and save your work.
Add elevations – Go to Purchasing > Add/Edit > Plan Takeoff. 
Select the plan you want to add elevations to and click These Plans. 
Right-click Base and select New Elevation. Enter a code, name, and 
scope for this elevation. Select conflicting items, prerequisites, and 
optional links for this elevation. Click Exit and save your work. 
Continue entering all of your elevations.
Add options – Go to Purchasing > Add/Edit > Plan Takeoff. 
Select the plan you want to add options to and click These Plans. 
Right-click Options and select New Option. Enter a code, name, 
and scope for this option. Select conflicting items, prerequisites, 
and optional links for this option. Click Exit and save your work. 
Continue entering all of your options.
Add work packages – Go to Purchasing > Add/Edit > Plan Take-
off. Select the plan you want to add work packages to and click 
These Plans. Right-click the option or elevation you want to add to 
and select New Package. Enter a code, name, and scope for this 
package. Select a default vendor, category, class, and activity for this 
work package. Check the TBD PO box if this package should create 
a To Be Determined purchase order. Add catalog items to this work 
package. Click Exit and save your work. Continue entering all of 
your work packages.
Create a community – If the community you are building this plan 
in has note been added to Profit Builder®, go to Job Cost > Add/
Edit > Community Names and add the new community.
Place the plan in a community – Go to Purchasing > Add/Edit > 
Plan Costing. Check the box next to the communities you want to 
work with and click These Communities. Right-click the commu-
nity you want to add to and select New Plan. Select the plan you 
want to add and click OK. 
Review vendors and prices – For each plan, review the default ven-
dors and make any changes necessary to use locally available ven-
dors. Also, review and change any prices as necessary. You must 
make at least one edit to each plan in order to save that plan in the 
community. When you have finished, click Exit and save your work.
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Start a House
Select elevations and options – Go to Purchasing > Process > 
Start a House. Check the boxes next to the elevations and options 
you want to use and click OK.
Enter job information – Enter the lot and block numbers for this 
property. Enter a description for this job. Select a customer from 
your list of customers or add a new customer on the Customer tab. 
Enter the tax rate and WIP account for this job. (optional)
Enter scheduling information – On the Date Review tab, enter the 
expected dates for each of the contract events listed. (optional)
Enter loan information – On the Loan Setup tab, enter informa-
tion about the customer’s loan. Click Process. (optional)
Review job buyout report – Go to Purchasing > Reports > Job 
Buyout. Select how you want to view the report. Click Preview to 
see the report before printing. Click Print to print the report.
Make any budget adjustments – Go to Job Cost > Add/Edit > Job 
Information. Select the job you want to change and click OK. In the 
Budget column below, make any changes to this job’s budget. Click 
Save and Exit.
Make any changes to pending purchase orders – Go to Purchas-
ing > Add/Edit > Purchase Orders. Select the PO you want to 
change and click OK. Make any changes to the PO that are neces-
sary. If these changes cause you to exceed budget for any category, 
you must place a variance for the amount of the overrun on the 
appropriate PO lines. Click Save and then Exit.
Release pending purchase orders – Go to Purchasing > Process > 
Issue/Print. Verify the backup location and click Make Backup. 
Select the posting date for the POs. Select how you want to release 
the purchase orders and which POs you want to release. Set any fil-
ters you want to include. Click Process.



P R O F I T  B U I L D E R A P P E N D I X

O P E R A T I O N S  G U I D E 168

Creating a New Job in Scheduling
Export job information – Go to Purchasing > Process > Export to 
Scheduling. Select the jobs you want to export. Click Export. 
Choose where you want to save your exported file. Click Save.
Create a new job record – In cPM Scheduling, go to File > New > 
Job. Enter the ID for this job. Enter the company number for your 
company in Profit Builder®. Select the start date for the project. 
Check the box to indicate that you want to use a previous job as a 
template. Select the job you want to use as a template. Click Create.
Import accounting information – Go to Tools > Accounting 
Interface > Import. Locate the file you exported from Profit 
Builder® and select Open. Click Process.
Recalculate the schedule – Check the Recalc Required box and 
click Calculate. Enter an inspection date. Click OK.
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Closing the Accounting Month
This checklist applies to closing an accounting month when depreciation is recog-
nized on an annual basis.

Make any additional journal entries – If you need to record any 
special entries at the end of a month—such as, depreciation or AR 
write offs—go to General Ledger > Add/Edit > General Journal 
Entries.
Reconcile Accounts Receivable – Print the Reconciliation Journal 
at Accounts Receivable > Reports > Reconciliation Journal. Bal-
ance the receipts spent on jobs with the AR accounts in the general 
ledger.
Reconcile Accounts Payable – Print an open Accounts Payable 
summary at Accounts Payable > Reports > Payables Journal. Ver-
ify the balance in the Trade Payables account in the general ledger.
Reconcile Job Cost – Print the Job Reconciliation report at General 
Ledger > Reports > Job Reconciliation. When printing this report, 
select all jobs and the appropriate WIP account. Print and retain a 
Job Cost Summary report for your records.
Reconcile General Ledger – Print a trial balance sheet and income 
statement at General Ledger > Reports. Verify that the proofs for 
each report match. Print a detail of all postings for the month at 
General Ledger > Reports > Detail of Ledger. Bind this report for 
your records.
Reconcile Bank Accounts – Print the Bank Reconciliation report 
for each account at General Ledger > Reports. Print a check register 
with invoices and payments at Accounts Payable > Reports > 
Check Register. Compare these two reports and clear all items in 
your monthly bank statements.
Close the account period – Go to General Ledger > Process > 
Close Period. Enter the override password. The system examines 
your account balances.
Backup your information – Select where you want to backup infor-
mation and click Make Backup.
Verify your accounts are in balance – The program checks to see if 
the net difference between the Asset and Liability (Balance Sheet) 
accounts is equal to the net difference between the Income and 
Expense (Income Statement) accounts.
Process the accounting period – When the Proof line shows equal 
amounts for the Balance Sheet and Income Statement accounts, click 
Process.
Print reports – Print your Balance Sheet and Income Statements at 
General Ledger > Reports.
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Closing a Job
This checklist applies to closing a job using the completed contract method.

Verify work payments – Print accounts payable and accounts 
receivable journals for the job to ensure that all work payments have 
been received. This includes payments you make to vendors and 
subcontractors and payments made to you by customers.
Print the Job Cost Detail – Go to Job Cost > Reports > Detail 
Report. Print this report for your records.
Move WIP Costs  – Using a journal entry, move your work in 
progress costs from WIP account 14000 to Direct Cost account 
40000.
Move Revenue – Using a journal entry, move your revenue from 
Construction Advance account 20000 to Sales account 30000.
Change WIP account – Go to Job Cost > Add/Edit > Job Infor-
mation. Change the Default GL account from the WIP account to 
the Warranty Costs account.
Mark Job Closed – In Job Information, click the Set 100% Com-
plete button. This will set all job categories to 100% complete.
Archive Job – At the end of the fiscal year, archive all closed jobs 
when completing your year-end procedures.
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How To...
In this section you will find straightforward step-by-step instructions to walk you 
through some of the operations tasks you perform on a regular basis. 

These how tos are intended to remind you of the basic steps necessary to carry out the 
operations. For more detailed information on each step, refer to the chapter in this 
guide covering that activity.

Click the links below to jump to that how to. The following how tos are available in 
this section:

“Field PO” on page 172
“Change Order PO” on page 173
“Variance PO” on page 174
“Reconciling a Bank Statement” on page 175
“Releasing Retainage” on page 176
“Placing Vendors on Hold” on page 177
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Field PO
A field purchase order is used when you want to assign a purchase order number 
before the order is complete. Typically when a purchase order is created manually the 
number is automatically assigned when the order is saved. 

With a field purchase order, the number is assigned before submitting the order. 
Because of this, cancelling a field PO throws away the number it was assigned.

TO ENTER A FIELD PURCHASE ORDER:

1. Go to Purchasing > Add/Edit > Purchase Orders.

2. If this PO is to be associated with a job, in the Job field, enter or select a job for 
this PO and enter any additional information about the job.

3. Click Field PO to assign a number to this purchase order.
4. In the Vendor field, enter the vendor or select one from the vendor list.
5. In the Type field, select a type for this PO. The default type is standard. 

For more information about other types of POs, see “Special Purchase 
Orders” on page 154.

6. On the General Tab, fill in any additional information about this purchase.
7. Click the Line Details tab and enter the item details for the purchase order.
8. Click the Tax Freight and Scope tab to enter tax, discount, freight and memo 

fields.
9. When you have finished, click Save to create the purchase order.
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Change Order PO
A change order indicates a change to the original budget that is paid for by the owner. 
The budget adjustment postings for a change order add to the original budget and to 
the PO/Contract budget, leaving the uncommitted budget amount the same.

TO ENTER A CHANGE ORDER PO:

1. Go to Purchasing > Add/Edit > Purchase Orders.

2. In the Number field, enter the number for the PO you are creating. If you use 
autonumbering, leave this field blank. The number may be up to 10 charac-
ters.

3. In the Vendor field, enter the vendor or select one from the vendor list.
4. In the Type field, select Change Order. Reason and Resolution fields appear 

with selections already made. These selections indicate that the change is cus-
tomer requested and approved.

5. In the Status field, the status of the purchase order appears. Valid statuses are 
New, Issued, Revised, Pending and Complete.

6. In the PO Net field, the net amount of the purchase order appears.
7. On the General Tab, fill in any additional information about this purchase.
8. Click the Line Details tab and enter the item details for the purchase order.
9. Click the Tax Freight and Scope tab to enter tax, discount, freight and memo 

fields.
10. When you have finished, click Save to create the purchase order.
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Variance PO
A variance purchase order is used to assign a variance to an entire purchase order to 
account for deviations from the budget. Because any budget overages are already 
accounted for, the budget is not checked when submitting the purchase order.

You can create a new variance purchase order or add a variance to an existing pur-
chase order.

TO ENTER A NEW VARIANCE PO:

1. Go to Purchasing > Add/Edit > Purchase Orders.

2. In the Number field, enter the number for the PO you are creating. If you use 
autonumbering, leave this field blank. The number may be up to 10 charac-
ters.

3. In the Vendor field, enter the vendor or select one from the vendor list.
4. In the Type field, select Variance. 
5. In the Reason field, select a reason for this variance.
6. In the Resolution field, select a resolution for this variance. 
7. In the Status field, the status of the purchase order appears. Valid statuses are 

New, Issued, Revised, Pending and Complete.
8. In the PO Net field, the net amount of the purchase order appears.
9. On the General Tab, fill in any additional information about this purchase.
10. Click the Line Details tab and enter the item details for the purchase order.
11. Click the Tax Freight and Scope tab to enter tax, discount, freight and memo 

fields.
12. When you have finished, click Save to create the purchase order.
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TO ADD A VARIANCE TO AN EXISTING PO:

1. Go to Purchasing > Add/Edit > Purchase Orders.
2. In the Number field, enter the number for the PO you want to change.

Use the search button next to the field to search for the PO.
3. In the Revision field, enter the revision number for this PO.
4. In the Type field, select Variance.
5. In the Reason field, select a reason for this variance.
6. In the Resolution field, select a resolution for this variance. 
7. Click the Line Details tab and make any changes to the item details for the 

purchase order.
8. When you have finished, click Save to save the purchase order.

Reconciling a Bank Statement
Reconciling your bank statement in Profit Builder® allows you to reconcile your 
checking account statement to it’s associated general ledger account balance.

The first time you use the bank reconciliation function, you will need to setup the 
reconciliation to flag all checks written with Profit Builder® as cleared. Then rerun the 
reconciliation to flag outstanding items and actually reconcile the statement. 

TO SETUP RECONCILIATION:

1. Go to General Ledger > Add/Edit > Reconcile Bank Account.
2. Select the bank account you want to set up reconciliation for.
3. Enter a statement end date.
4. Click Begin Reconciliation.
5. The system attempts to compute the balance and display an out of balance 

message. Ignore this message and click Proceed.
6. All checks issued with Profit Builder® should be listed on the checks tab. Click 

Clear All to mark all of the checks as cleared.
7. Manually “unclear” any items that are currently outstanding by clicking the 

button in the CLR column.
8. Repeat steps 6–7 for deposits and general journal entries.
9. Click OK and accept the “Out of Balance” warning.
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TO RECONCILE A BANK STATEMENT:

1. Go to General Ledger > Add/Edit > Reconcile Bank Account.
2. Select the bank account you want to set up reconciliation for.
3. Enter a statement end date.
4. Enter the opening balance, closing balance, service charges and interest 

earned.
5. Click Begin Reconciliation. 

Profit Builder® then calculates the balance based on your entries, the actual 
account balance in General Ledger and all outstanding or “uncleared” items 
on file—checks, deposits and GL journal entries.

6. On the Checks, Deposits and General Journal tabs, mark any cleared items 
by clicking the button in the CLR column. 
A running total of cleared items, along with the bank reconciliation proof is 
displayed at the top of the window.

7. When the reconciliation is complete (i.e., the proof is zero), click OK. The sys-
tem prints a report listing all cleared items, etc. that should be filed with your 
bank statement.

Releasing Retainage
Retainage on an invoice is not posted to either the general ledger or job cost until it is 
released and therefore eligible for payment. Use the Retainage report in Accounts 
Payable to track retainage either by vendor or by job. Retainage may be released or 
confiscated using the Process Retainage function.

TO RELEASE RETAINAGE:

1. Go to Accounts Payable > Reports > Retainage and print a detail report by 
vendor or job.

2. Go to Accounts Payable > Process > Retainage.
3. Click All Vendors and select the vendors you want to include.
4. Click All Jobs and select the jobs you want to include.
5. Click the button next to Release.
6. Click OK.
7. Click Yes to confirm your selections.
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Placing Vendors on Hold
Placing a vendor on hold prevents any checks to be issued to that vendor. This is a 
common practice when a vendor’s insurance information has expired, however you 
may place a vendor on hold for a number of other reasons.

TO PLACE A VENDOR ON HOLD:

1. Go to Accounts Payable > Add/Edit > Vendors.
2. In the Code field, enter or select the code for the vendor you want to place on 

hold.
3. Click the Payments tab.
4. At the bottom of the tab, check the On Hold. Do not pay this vendor box.
5. In the By order of field, enter your name.
6. In the Reason field, enter the reason for placing this vendor on hold.
7. Click Save. 
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